优势

本编辑器可以有效提高tsl语言开发的效率,具有如下特征:

1. tsl语言输入提示以及跨文件跳转

2. 完整的tsl语法高亮(包括<?tslx>)

3. begin end ,( ) [ ] 匹配高亮

4. tsl语言代码树

5. tsl语言自动格式化

6. tsl语言调试(本地以及远程)

7. 代码块输入


安装

根据平台选择不同的安装包

安装包 | 说明
tsleditor-setup.exe | windows平台
tsleditor.*.*.*.*.deb | linux对应的版本


具体使用


新建,打开

编辑器—菜单—文件—打开(新建)

新建文件会在临时目录中新建一个文件以new(i) 为文件名.可以通过另存为保存为自己的文件.


设置tab字符设置:

由于tab键在各种编辑器中的显示不一致,给语言开发带来不必要的麻烦,可以将tab用空格替换,具体操作:编辑器—菜单—tab设置


设置tsl语言函数搜索目录

tsl语言输入提示,以及自动补全可以通过添加tsl所在函数目录实现,当添加目录后录后,输入可以自动提示,右键鼠标可以跳转到函数定义.调试运行时,也会在此目录下面查找对应tsf文件源代码.

编辑器—菜单—运行—tsl函数目录

设置界面简介:

左侧为工程名(可以定义多个工程别名),右侧为别名对应的目录,一个别名可以对应多个目录

添加工程别名:

右侧文本框输入工程别名,然后点击文本框旁边的+按钮,新建了一个工程别名,此时在文本框下面的列表框中就会出现刚刚新建的别名.

当前执行的工程:

左侧选中的工程别名为当前执行或者调试执行查找目录(如上图所示default对应目录为运行查找目录)

给工程添加查找目录:

用鼠标选择工程别名,此时在右侧的列表框中会出现对应工程的函数查找目录.可以通过搜索目录列表框右侧的+,-按钮添加或者删除按钮修改工程目录

保存:

右下侧的确定按钮保存当前所做的修改.


执行命令行设置

该功能是设置执行命令行,可以方便的执行程序

如上图所示构造一个tsl_dbg别名的命令行,用F:\tslnext\tsl.exe 执行当前页面脚本,以当前工程的搜索目录作为-libpath的参数;

该功能是为了构造执行命令行,提供五个常量FULL_CURRENT_PATH当前的文件全名, SEARCH_PATH函数搜索目录, CURRENT_DIRECTORY当前文件目录,SEARH_PATH函数搜索目录,TSL_EXE当前的tsl.exe全名,下拉框可以切换执行的命令行,也可以修改命令行的别名,点击[保存/添加]的时候如果别名不存在就会新建,如果存在就会修改别名对应的命令行.[删除当前]按钮为删除当前的命令行

注意:该功能不单独针对tsl解析器,其他命令行也可以.本地调试的时候也可以使用配置的命令行作为调试器,见下文(修改默认的本地tsl语言调试器)


编码转换

目前编辑器实现了 ansi,utf8 utf8bom ucs2-big ucs2-little五中编码,可以在这五中编码进行相互转换,具体操作可以在编辑—菜单—编码查看,如果下图所示,编码菜单分为两部分,下部分是将当前的编码转换到对应的编码.上部分是当前的文本的编码方式,由于ansi和utf8的重叠原因,编辑器可以让使用者自己判断是ansi还是utf8,如果使用者在上部分菜单中设置了错误的编码(本身是ansi强行指定为utf8)将会造成编码转换的混乱.


调试


Tsl.exe 调试原理

Tsl.exe 新版的tsl.exe 通过ip协议支持了调试功能,被调试程序运行代码的时候需要在命令行中添加如下参数:

-DEBUGSERVER "127.0.0.1"

-DEBUGPORT 22222

-DEBUGLOGIN 0

-WAITATTACH

参数简介

-DEBUGSERVER 监听ip地址

- DEBUGPORT 监听端口

-DEBUGLOGIN 是否需要用户名登陆

-WAITATTACH 运行时等待调试程序连接


用编辑器调试tsl.exe

通过工具栏按钮,或者 F5 添加删除调试断点

调试分为本地脚本调试,远程调试,远程调试等待三种方式:

本地脚本调试是以当前页面作为tsl的入口程序.远程调试,以及远程调试(attach)是专门针对web服务开发

调试中:

调试工具栏按钮(断点添加删除,继续运行,暂停,进入,跳出,下一行,停止,刷新变量)

行标处的绿圈是当前到的位置.下方是调试信息包括:代码堆栈\当前变量\命令执行窗口


修改默认本地tsl语言调试器

运行调试,默认采用当前编辑器作为tsl语言的调试程序,如果需要修改调试程序可以在菜单-运行-调试器 下面选择调执行程序或者编辑器作为调试程序


远程调试

远程调试主要针对web后端tsl开发, 相对于本地调试,增加了

1. 服务器地址,端口

2. 用户名 密码

3. 脚本目录 :当连接到远程服务器后,会在该目录下查找对应的启动tsl脚本文件

需要配置apche和tsl执行程序,配置范例如下:

apache安装位置 C:\Apache24

tsl.exe 所在位置 F:\tslnext

tsl文件所在位置 F:\dotsl

apache配置

修改C:/Apache24/conf/httpd.conf 配置文件

#监听

Listen 127.0.0.1:8989

#配置tsl语言模块

LoadModule tslldlib_module "F:/tslnext/TSLLdLibAp24.dll"

#tsl.exe为新版tsl解析器

#LoadModule tsl_module "F:/tslnext/tslapache.dll"

#tsl.exe为旧版tsl解析器

LoadModule tsl_module " F:/tslnext/mod_tsl24.dll"

#脚本后缀

AddType tslscript-handler .tsl

AddHandler tslscript-handler .tsl

#脚本主目录

DocumentRoot "F:/dotsl"

tsl.exe配置

修改F:\tslnext\TSL.INI 文件如下

[WebDebug]

#启动调试

Enable=1

DisableDebug=0

#调试监听地址和端口,和apache无关

Listen=0.0.0.0

Port=22222

#线程数

Threads=1

#是否需用户登录,0不需要登陆1需要登陆

NeedLogin=0

#用户登陆信息,user:用户名=密码

#用编辑器中的tsl.exe 对密码进行编码: TSL.exe -ENCODEDEBUGPASS abc,abc就被编码加密了

User:jianjun=13313494039380B774414F9F5F9586D3

添加测试脚本

F:\dotsl\web.tsl

for i := 0 to 1000 do

begin

abcd();

echo "\r\n<br/>hello:",i,"==",datetimetostr(now());

sleep(100);

end;

function abcd();

begin

for j := 0 to 999 do c++;

end

在C:\Apache24\bin目录下运行命令行启动apache

httpd.exe -X

然后在浏览器地址栏输入:

http://127.0.0.1:8989/web.tsl

tsl本地编辑器菜单—运行—远程调试

根据配置信息填好地址端口以及用户名密码,tsl文件目录,点击链接按钮

如果登陆成功就会在下面的列表中展示可以调试的线程,用鼠标选择需要调试的线程点击调试按钮

进入调试状态:


远程等待调试

采用上面的调试可以看到刚进入调试,程序中for循环以及运行了很久,如果需要从头开始调试程序,可以采用远程等待方式

编辑—菜单—运行—远程调试(waitattach)

然后在浏览器中输入:

http://127.0.0.1:8989/web.tsl?TSLWaitDebugAttach=1

此时立刻进入链接状态:


其他功能


代码树

打开tsl代码树的快捷键键为alt+m ,打开后,可以使用上下键移动选中的节点,代码将会自动定位到该节点.右键可以展开选中节点,左键可以折叠选中节点,enter键隐藏代码树窗口.


代码块插入

代码块设置

操作简介

删除按钮 | 删除选中的行
添加按钮 | 添加新的输入提示
保存按钮 | 保存所做的修改
双击表格 | 查看或者修改双击行的内容

表格列标简介:

显示 | 键盘输入时的提示内容
提示关键字 | 和键盘输入匹配的字符串
插入代码块 | 插入的代码块
前缀 | 是否将值的内容以及扩展内容合并插入到代码中


Dpi设置

有时候因为设置了系统屏幕的缩放比例,导致字体模糊,可以通过单独设置编辑器程序的高dpi来修正这种情况:


tsl语言本地编辑器