函数目录

  • tvclib
    • tslvcl
      • initializeapplication
      • registercomponenttype
      • getanddispatchmessagea
      • exitmessageloop
      • notifycomponent
      • tslcstructure
      • calldatafunction
      • checktslcode
      • copyusedtsldlltonewdir
      • messageboxa
      • _timeproc_
      • _twinproc_
      • remotetslcallback
      • tapplication
        • wmactivateapp
        • initialize
        • createform
        • run
        • showerrormessage
        • closemainform
      • tlabel
      • tsyscontrol
      • twincontrolwraper
        • wraphandle
        • createwnd
      • tscrollingwincontrol
      • tpanel
      • ttray
        • notification
      • tvcform
        • menubarheight
        • wmsyscommand
        • wmcommand
        • notification
      • tform
      • tpanelform
      • tbtn
      • tcheckbtn
      • tradiobtn
      • tedit
      • tpassword
      • tmemo
      • tgroupbox
      • tlistbox
      • tcolorbox
        • getcolor
        • getcolorname
        • addcolor
        • appendcolors
      • tcolorcombobox
        • addcolor
        • appendcolors
        • clean
        • getcurrentcolor
        • getcolorname
        • getcolorvalue
      • tcombobox
      • ttoolbutton
      • ttoolbar
      • tstatusbar
      • tcoolbar
      • tsplitter
      • ttreectlnode
      • ttreenode
        • getsibling
        • insertsibling
        • moveup
        • movedown
        • insertnode
        • getnodebyposition
        • getnodecount
      • ttreectl
      • ttreeview
        • expand
        • collapse
        • switchcollapse
        • insertnodes
        • insertnode
        • deleteitem
        • getitemcount
        • clean
      • ttabsheet
      • tpagecontrol
      • tpairsplitterside
      • tpairsplitter
        • docontrolalign
      • ttlvnactiveevent
      • tgridbase
        • clickedgriditem
        • rclickedgriditem
        • getsubitemrect
        • getitemrect
        • hittestitem
        • deletecolumn
        • insertcolumn
        • deleteallcolumns
        • deleteallitems
        • clean
      • tdrawgrid
      • tlistview
        • menus
        • deleteallitems
        • griddrawitem
        • setselectedvalue
        • clickedgriditem
        • rclickedgriditem
        • moveup
        • movedown
        • deletebyid
        • finditemid
        • deletebyvalue
        • deleteselect
        • checkitem
        • insertitem
        • appenditem
        • setsubitem
        • setsubitembyindex
        • getitem
        • setitem
        • appenditems
        • dodrawsubitem
        • setselectedbyvalue
        • columnasbool
        • unselected
      • tprogressbar
      • tmonthcalendar
        • getcurrentselection
        • setcurrentselection
      • tdatetimepicker
        • showdropdown
        • getdate
        • setdate
      • ttimepicker
        • gettime
        • settime
      • tipaddr
      • tspinedit
      • tapplicationwindow
      • timagelistdrawstyle
      • timagelistcreateflags
      • tcontrolimagelist
      • ttimer
      • taction
      • tmessageboxadlg
      • tcolorchooseadlg
      • tfontchooseadlg
      • tsavefileadlg
      • topenfileadlg
      • tfolderchooseadlg
      • tmenu
      • tpopupmenu
      • tmainmenu
      • tclipboard
      • tthreadworker
      • tregkey
        • getregkeyroot
        • getregkeyuser
        • getregkeymachine
        • getenviromentkey
        • environmentpath
        • openkeya
        • getvaluea
        • setvaluestringa
        • deletevaluea
        • deletekeya
        • deletetreea
        • getvaluenames
        • getsubkeynames
        • sinit
      • twinenviroment
        • getpaths
        • appendpath
        • removepath
      • tquotations
        • remotecallback
        • remoteexecute
        • marketsubscription
        • dispatch
        • echodata
        • errormessage
        • result
      • tlogincontrol
        • getloginstatus
      • tinifileexta
        • create
      • tcreateprocessa
        • doonecho
        • createprocesswaitread
        • createprocesswaitreadblockthread
      • tmyarraya
      • tmyarrayb
    • cstructurelib
      • memoryalignmentcalculate
      • readstringfromptr
      • writestringtoptr
      • readbytesfromptr
      • writebytestoptr
      • parserctypestr
      • dealcppcomment
      • csstotslarray
      • csstotslarray2
      • csstotslarray3
      • cstructtotslclass
      • tslarraytocstructcalc
      • ctypedefine
      • tmemoryclass
        • getpointersize
        • opblocks
        • tmalloc
        • tfree
        • trealloc
        • mtool
      • ctslctrans
        • operator [1]
        • operator []
        • create
        • _getptr2_
        • _getptr_
        • _setcptr_
        • _size_
        • arraynumberchek
        • _getvalue_
        • _getvalueaddr_
        • _getvalueaddr2_
        • _getdata_
        • copytostring
        • copyfromstring
      • tslcstructureobj
        • create
      • tcbytearray
        • create
        • reset
        • occupancy
        • length
        • _getptr_
        • setv
        • getv
        • ptr
      • tcstring
        • getv
        • setv
      • tcstructwithcharptr
        • create
        • operator [1]
        • operator []
        • _setvalue_
        • _getvalue_
        • _getdata_
        • setstringi
    • 底层伪接口
      • getsenderdatabyid
      • gettslvariableptr
      • getctypesize
      • getwinprocptr
      • 内存管理对象
        • tmalloc
        • trealloc
        • tfree
        • tmset
        • readbyte
        • writebyte
        • readint
        • writedouble
        • readdouble
        • writellong
        • readlong
        • writeshort
        • readshort
        • writebytes
        • readbytes
        • writeshorts
        • readshorts
    • parserch
      • pcstruct
      • parserctokens
    • getmsgd_crc32
    • iofileseparator
    • tcomponent
      • notification
      • setdesigning
      • isdescendant
      • setowner
      • executeaction
      • updateaction
      • destroycomponents
      • freenotification
      • insertcomponent
      • removecomponent
      • getpublishproperties
      • getpublishevents
      • getchangedpublish
      • setchangedpublish
      • setpublish
    • tcontrol
      • paintstruct
      • messagecreater
      • controlappended
      • controldeleted
      • mousedown
      • mouseup
      • contextmenu
      • notification
      • getclientrect
      • docncommand
      • docnnotify
      • domousewheel
      • getactionlinkclass
      • recycling
      • getboundsrect
      • setboundsrect
      • getbounds
      • dispatch
      • wndproc
      • perform
    • tcustomcontrol
    • tcustomscrollcontrol
      • getxscrolldelta
      • getyscrolldelta
      • getclientxcapacity
      • getclientycapacity
      • getclientxcount
      • getclientycount
      • positionchanged
    • tcustomsplitter
    • tgdiplusflat
    • tgraphiccontrol
      • realsettext
      • paint
      • invalidaterect
    • tuieventbase
      • create
      • hilparam
      • lolparam
      • hiwparam
      • lowparam
      • hilparamsigned
      • lolparamsigned
      • hiwparamsigned
      • lowparamsigned
    • twincontrol
      • sinit
      • initializewnd
      • createparams
      • realsettext
      • createwndclass
      • hitcontrol
      • captionheight
      • wmgetminmaxinfo
      • getclientrect
      • wmerasebkgnd
      • wmnotify
      • keyup
      • keydown
      • keypress
      • dosetfocus
      • dokillfocus
      • clienttowindow
      • show
      • endmodal
      • updatewindow
      • movecontrolorder
      • invalidaterect
      • createwnd
      • handleallocated
      • destroyhandle
      • handleneeded
      • setbounds
      • mainwndproc
      • designingsizer
      • designingclick
      • designingmove
      • docontrolalign
      • docontrolanchor
      • wnddefaulthandler
      • defaulthandler
      • broadcast
      • _send_
    • utslmemo
      • tcustommemocmd
      • tcustommemo
        • executecommand
      • tsyncompletion
      • tcustomsynhighlighter
        • executecommand
      • tsyncustommemo
    • utslvclaction
      • tbasicaction
      • tcustomaction
        • assignto
        • create
      • tcustomactionlist
        • deleteaction
        • addaction
      • tbasicactionlink
        • execute
      • tactionlink
      • tcontrolactionlink
        • assignclient
    • utslvclauxiliary
      • includestate
      • excludestate
      • makelong
      • makeposition
      • getbitsfrominteger
      • unsignedtosigned
      • signedtounsigned
      • lowuperdword
      • formattsldata
      • gettemppath
      • pointinrect
      • intersectrect
      • bitcombination
      • tsltohexformatstr
      • hexformatstrtotsl
      • deleteallfiles
      • createdirwithfilename
      • tbytedataop
        • bytesasint
        • intasbytes
        • shortstoint
        • inttoshorts
        • strasbytes
        • bytesasstr
      • tarray1dlk
        • setdata
        • clean
        • create
        • append
        • geti
        • seti
        • deli
        • delis
        • insertbefor
        • insertafter
        • findvid
        • getprev
        • getnext
        • ergodic
        • data
        • replace
        • len
        • setorder
        • swap
      • tfplist
        • indexof
        • operator []
        • add
        • remove
        • last
        • count
      • tstrindexarray
        • deleteindex
        • size
        • toarray
        • indexnames
        • haveindex
        • trueindex
      • tnumindexarray
        • create
        • operator [1]
        • operator []
        • length
        • push
        • pop
        • splice
        • shift
        • unshift
        • swap
      • tarraytreeclass
        • create
        • addcomponent
        • recycle
        • toarray
        • totree
        • treearraytoarray
        • totreearray
      • tnode
        • getnodebyindex
        • getindex
        • appendnode
        • hasnode
        • deletenode
        • deletechildnode
        • deletenodebyindex
        • deletechildren
        • insertnodes
        • insertnode
      • ttire
      • tinifileexter
        • create
        • readsection
        • readsections
        • readsectionvalues
        • renamesection
        • renamekey
        • readsectionvalues2
        • readsectionvalues3
        • readkey
        • writekey
        • erasesection
      • tcanvsrgnclipautosave
        • create
    • utslvclbase
      • tswin32api
        • getscreenrect
        • getpathbyprocid
        • enumprocesses
        • toolhelp32snapshot
        • toolhelp32snapshotmodule
      • tsluibase
        • sinit
        • iskeywords
        • norecycled
        • recycling
        • hashset
        • hashget
        • hashdel
        • temppath
    • utslvclconstant
      • constant
      • tenumeration
        • basevalue
        • initenumeration
      • talign
      • tanchorkind
      • tmousebutton
      • tshiftstateenum
      • talignstyle9
      • talignstyleh3
      • tsyscursor
      • tmbbtnstyle
      • tmbiconstyle
      • trasteroperationconst
      • tsystembitmap
      • tsystemcursor
      • tmacroconst
      • tconstant
      • tsluiconst
      • _winuserdef_
      • _tvclmsageid_
    • utslvclcoolbar
      • tcustomcoolbar
    • utslvcldlg
      • tcommdlg
        • opendlg
        • choosedlg
      • tcustommsgadlg
      • tcustomcolordlg
      • tcustomfontdlg
      • tcustomfolderdlg
      • tcustomfsdlg
        • getselecteditemname
        • choosedlg
        • getresults
    • utslvclevent
      • tmnotify
      • tmmenuselect
      • tmkey
      • ttagedrawitem
      • tgridmdrawitem
      • tsiftstate
        • keystoshiftstate
      • tmmousewheel
        • shiftstate
      • tmmouse
        • pos
        • button
        • shiftstate
        • shiftdouble
      • tmstylechang
    • utslvclgdi
      • gettextwidthandheightwidthfont
      • getgdipstatus
      • tcustomfont
        • fontinfo
        • copyfont
        • setvalues
      • tfontcontrol
      • trgn
        • combinergn
      • trgnellip
      • trgnrect
      • trgnroundrect
      • trgnpoly
      • tcustomimage
        • destroyhandle
        • recycling
        • loadfromfile
        • savetofile
        • imagetostring
        • stringtoimage
        • tohbitmap
        • fromhbitmap
        • fromhicon
        • tohicon
      • tpicturebase
      • tcustombitmap
        • setid
        • loadsysbmp
        • destroyhandle
        • handleallocated
        • draw
        • stretchdraw
        • readvcon
        • tovcon
        • copyrect
        • toicon
      • tcustomicon
        • destroyhandle
        • handleallocated
        • tobitmap
      • tcustomcursor
        • loadsysico
        • show
      • tcustomimagelist
        • change
        • sethandle
        • handleallocated
        • destroyhandle
        • addbmp
        • addicon
        • draw
        • removeimge
        • replaceimge
        • geticon
      • tcustomcontrolimagelist
        • handlechanged
        • deletecontrol
        • recycling
      • tcustomcanvas
        • gettextextent
        • selectcliprgn
        • recycling
        • handleallocated
        • requiregdi
        • setviewportorg
        • setpixel
        • fillrgn
        • fillrect
        • invertrect
        • moveto
        • lineto
        • textout
        • drawtext
        • stretchdraw
        • drawbitmap
        • drawicon
        • draw
        • copybitmap
        • setworldtransform
        • setpolyfillmode
        • setbkmode
        • getbkmode
        • settextalign
        • savedc
        • restoredc
    • utslvclgrid
      • tcustomgridctl
        • getitemrect
        • getitemstarty
        • getitemybound
        • getsubitemrect
        • getturesubitemrect
        • getcolindexbypos
        • invalidateitem
        • invalidatesubitem
        • getindexbypos
        • getrowindexbypos
        • setcolumns
        • getcolumnwidth
        • setcolumnwidth
        • drawcell
        • getrowheight
        • mergecells
        • getmergeinfo
        • cleanmergecells
      • tgriddrawcellevent
    • utslvclmemstruct
      • ttagmsg
      • tcrect
      • tpaintstruct
      • tbrowseinfoa
      • tbrowseinfoa_
      • ttagchoosecolora
      • ttagchoosefonta
      • ttaglogfonta
    • utslvclmenu
      • tcustommenu
        • getactionlinkclass
        • handleneeded
        • sinit
        • dispatch
        • handleallocated
        • destroyhandle
        • createmenu
        • createhandle
        • recycling
        • removefromparent
        • indexof
        • getitembyindex
        • setmenuiteminfo
        • insertitem
        • removeitembyindex
        • recyclingallitems
        • removeitem
        • setchangedpublish
        • menuchanged
      • tcustompopupmenu
      • tcustommainmenu
      • tmenuactionlink
        • assignclient
    • utslvclpage
      • tcustomtabsheet
      • tcustompagecontrol
        • getsheetrect
        • getpageid
        • settabtext
        • settabindex
    • utslvclstdctl
      • tcustomclipboard
        • create
      • tcustomtimer
        • timeout
        • start
        • stop
        • recycling
        • _timeproc_
        • sinit
      • tcustombtn
        • click
        • dosetfocus
        • dokillfocus
      • tcustomcheckbtn
      • tcustomradiobtn
      • tvirtualcalender
      • tcustomlabel
        • canvasdrawaligntext
      • tcustomedit
        • setsel
      • tcustompassword
      • tcustomlistboxbase
        • paintidx
        • getidxrect
        • insureidxinclient
        • getclientidxs
      • tlistdrawevent
      • tcustomlistbox
        • paintidx
        • getcurrentselection
        • setcurrentselection
        • getitemselectedstate
        • setitemselectedstate
        • appenditem
        • appenditems
        • insertitem
        • insertitems
        • deleteitem
        • deleteitems
        • deleteselecteditems
        • getselectedindexes
        • getitem
        • getitemtext
        • checklistitem
      • tcustomcomboboxbase
        • createalist
        • showdropdown
        • setlistboxrect
      • tcustomcombobox
        • appenditem
        • appenditems
        • insertitem
        • deleteitem
        • clean
        • getitems
        • getitemcount
        • getitemtext
        • getcurrentitemtext
      • tcustomtoolbutton
        • getrect
        • getactionlinkclass
      • tcustomtoolbar
        • addbutton
        • setbtnindex
        • insertbutton
        • deletebutton
        • getitemrect
        • incpaintlock
        • decpaintlock
        • calcheightfixwidth
        • calcwidthfixheight
        • indexofbtn
      • tcustomstatusbar
        • additem
        • deleteitem
        • setitemtext
      • tcustomspinedit
      • tcustomprogressbar
        • increasebystep
        • increasebyspecifiedincrement
      • tcustomipaddr
        • cleanaddr
        • setrange
    • utslvcltree
      • tcustomtreectlnode
        • paint
        • mouseup
        • getnodebyindex
        • appendnodestr
        • insertnodestr
        • getindex
        • ancestorisexpand
        • appendnode
        • hasnode
        • deletenode
        • deletechildnode
        • deletenodebyindex
        • deletechildren
        • getlastshownode
        • insertnodes
        • insertnode
        • expand
        • unexpand
        • getshownodes
        • toarray
      • tcustomtreectl
        • ttreeselchngedevent
        • setsel
        • nodeinlist
        • mouseup
    • uvclthreadworker
      • runthreadworkerclient
      • tworkerclient
      • tcustomthreadworker
        • operator []
        • operator [1]
        • postmessage
    • uvcpropertytypespersistence
      • ttmfparserbase
      • ttmfparsertoken
        • cchar
        • cback
        • delct
        • gettokens
        • pstring
        • phexnumber
        • pnumber
      • ttmfparser
        • samplevalue
        • gettree
      • tpropertytype
        • edittype
        • formatedit
        • unformatedit
        • formattmf
        • tmftonode
        • readtmf
        • lazyproperty
        • ifcomponent
      • tpropertynatural
        • formattmf
      • tpropertycolor
        • formattmf
      • tpropertybool
        • formatedit
        • formattmf
      • tpropertyaction
        • ifcomponent
      • tpropertyimagesdata
        • formattmf
      • tpropertybitmap
        • formattmf
      • tpropertyicon
        • formattmf
      • tpropertyalign
        • lazyproperty
      • tpropertystrings
        • formattmf
    • uwindowsinterface


tvclib
# tsl界面库帮助
## 文件说明
- tslvcl.tsf是界面库接口
- cstructurelib.tsf 库中包含内存管理接口
- Lpseudointerface.tsl 为底层伪接口
- tgdiplusflat.tsf 为gdiplusflat.h导出函数,以后可能移动到其他库下
- parserch.tsf 为c头文件解析相关函数,不需要使用

内容:
  • tslvcl
  • cstructurelib
  • utslvclfackinterface
  • parserch
  • getmsgd_crc32
  • iofileseparator
  • tcomponent
  • tcontrol
  • tcustomcontrol
  • tcustomscrollcontrol
  • tcustomsplitter
  • tgdiplusflat
  • tgraphiccontrol
  • tuieventbase
  • twincontrol
  • utslmemo
  • utslvclaction
  • utslvclauxiliary
  • utslvclbase
  • utslvclconstant
  • utslvclcoolbar
  • utslvcldlg
  • utslvclevent
  • utslvclgdi
  • utslvclgrid
  • utslvclmemstruct
  • utslvclmenu
  • utslvclpage
  • utslvclstdctl
  • utslvcltree
  • uvclthreadworker
  • uvcpropertytypespersistence
  • uwindowsinterface


cstructurelib

tvclib/cstructurelib

定义:unit cstructurelib;
uses:
  • parserch

说明:
内存对象工具
成员:
name | type
memoryalignmentcalculate | function
readstringfromptr | function
writestringtoptr | function
readbytesfromptr | function
writebytestoptr | function
parserctypestr | function
dealcppcomment | function
csstotslarray | function
csstotslarray2 | function
csstotslarray3 | function
cstructtotslclass | function
tslarraytocstructcalc | function
ctypedefine | function
tmemoryclass | class
ctslctrans | class
tslcstructureobj | class
tcbytearray | class
tcstring | class
tcstructwithcharptr | class


getmsgd_crc32

tvclib/getmsgd_crc32

定义: getmsgd_crc32(s);
说明:
获得字符串的信息指纹
参数:
name | type | describe
s | string | 字符串

返回值:
type | describe
string | 8位长度的信息指纹


iofileseparator

tvclib/iofileseparator

定义: iofileseparator();
说明:
返回文件系统的目录分割符
返回值:
type | describe
string | linux 下/ windows下\


parserch

tvclib/parserch

定义:unit parserch;
说明:
c头文件解析对外 接口
成员:
name | type
pcstruct | function
parserctokens | function


tcomponent

tvclib/tcomponent

定义:type tcomponent= class(tsluibase);
uses:
  • utslvclauxiliary
  • uvcpropertytypespersistence
  • utslvclbase

说明:
可视化组件基类
成员函数:
function | private
notification | public
setdesigning | public
isdescendant | public
setowner | public
executeaction | public
updateaction | public
destroycomponents | public
freenotification | public
insertcomponent | public
removecomponent | public
getpublishproperties | public
getpublishevents | public
getchangedpublish | public
setchangedpublish | public
setpublish | public

propeties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tcontrol

tvclib/tcontrol

定义:type tcontrol= class(tcomponent);
uses:
  • utslvclauxiliary
  • utslvclmemstruct
  • utslvclevent
  • utslvclgdi
  • utslvclaction
  • utslvclmenu

说明:
界面控件基类
成员变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度

成员函数:
function | private
paintstruct | public
messagecreater | protected
controlappended | protected
controldeleted | protected
mousedown | public
mouseup | public
contextmenu | public
notification | public
getclientrect | public
docncommand | public
docnnotify | public
domousewheel | public
getactionlinkclass | protected
recycling | public
getboundsrect | public
setboundsrect | public
getbounds | public
dispatch | public
wndproc | public
perform | public

propeties:
name | private | read | type | write | describe
action | public | getaction | taction | setaction | action对象
anchors | public | fanchors | array of tanchorkind member | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | falign | member of talign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | getunalignbounds | array of integer | setunalignbounds | 去除自动对齐时的范围
parentfont | public | fparentfont | bool | setparentfont |
parentcolor | public | fparentcolor | bool | setparentcolor |
caption | public | gettext | string | settext | 控件标题
enabled | public | getenabled | bool | setenabled | 控件是否有效
cursor | public | getcursor | tcursor 通过 member of tsystemcursor 设置 | setcursor | 系统鼠标
font | public | getcontrolfont | font | setcontrolfont |
onmousewheel | public | fonmousewheel | function[tcontrol,tmmousewheel] | fonmousewheel | 滚动回调函数
onsize | public | fonsize | eventhandler | fonsize |
onmove | public | fonmove | eventhandler | fonmove |
onmousemove | public | fonmousemove | function[tcontrol,tmmouse] | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | fonpopupmenu | function[tcontrol,tmmouse] | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | fonmousedown | function[tcontrol,tmmouse] | fonmousedown | 鼠标按下回调函数
onmouseup | public | fonmouseup | function[tcontrol,tmmouse] | fonmouseup | 鼠标松开回调函数
onclick | public | fonclick | function[tcontrol,tmmouse] | fonclick | 鼠标点击回调函数
onrclick | public | fonrclick | eventhandler | fonrclick |
ondblclick | public | fondblclick | function[tcontrol,tmmouse] | fondblclick | 鼠标双击回调函数
parent | public | fparent | tcontrol | preparesetparent | 父控件
popupmenu | public | fpopupmenu | tpopupmenu | fpopupmenu | 弹出菜单
visible | public | fvisible | bool | setvisible | 是否可见
clientrect | public | getclientrect | array of integer |  | 客户区矩形array(left,top,right,bottom)
height | public | fheight | integer | setheight | 高度
width | public | fwidth | integer | setwidth | 宽度
left | public | fleft | integer | setleft | 左边
top | public | ftop | integer | settop | 上方位置
border | public | fborder | bool | setborder |
boundsrect | public | getboundsrect | array of integer | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | getzorder | integer | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | fcontrolstate | tcontrolstate | fcontrolstate |
color | public | getcolor | integer | setcolor | 背景色
bkbitmap | public | fbkbitmap | tbitmap | setbitmap |
controls | public | fcontrols | tfplist of tcontrol |  | 子组件
canvas | public | fcanvas | tcanvas |  | 画布对象

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tcustomcontrol

tvclib/tcustomcontrol

定义:type tcustomcontrol= class(twincontrol);
uses:
  • utslvclauxiliary
  • utslvclgdi

说明:
自绘制窗口控件
propeties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomscrollcontrol

tvclib/tcustomscrollcontrol

定义:type tcustomscrollcontrol= class(tcustomcontrol);
uses:
  • utslvclmemstruct

说明:
带滚动条的窗口类带滚动条的自绘制窗口
成员函数:
function | private
getxscrolldelta | protected
getyscrolldelta | protected
getclientxcapacity | protected
getclientycapacity | protected
getclientxcount | protected
getclientycount | protected
positionchanged | protected

propeties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomsplitter

tvclib/tcustomsplitter

定义:type tcustomsplitter= class(tgraphiccontrol);
说明:
调整分割控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • realsettext
  • paint
  • invalidaterect
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tgraphiccontrol]:bool | fonpaint | fonpaint | 绘制回调,返回true不执行默认绘制
transparent | public | bool | ftransparent | settransparent |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tgdiplusflat

tvclib/tgdiplusflat

定义:type tgdiplusflat= class();
说明:
gdi+ 的c接口函数


tgraphiccontrol

tvclib/tgraphiccontrol

定义:type tgraphiccontrol= class(tcontrol);
uses:
  • utslvclauxiliary
  • utslvclgdi

说明:
自绘制控件
成员函数:
function | private
realsettext | protected
paint | protected
invalidaterect | public

propeties:
name | private | type | read | write | describe
onpaint | public | function[tgraphiccontrol]:bool | fonpaint | fonpaint | 绘制回调,返回true不执行默认绘制
transparent | public | bool | ftransparent | settransparent |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | write | describe
action | public | getaction | taction | setaction | action对象
anchors | public | fanchors | array of tanchorkind member | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | falign | member of talign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | getunalignbounds | array of integer | setunalignbounds | 去除自动对齐时的范围
parentfont | public | fparentfont | bool | setparentfont |
parentcolor | public | fparentcolor | bool | setparentcolor |
caption | public | gettext | string | settext | 控件标题
enabled | public | getenabled | bool | setenabled | 控件是否有效
cursor | public | getcursor | tcursor 通过 member of tsystemcursor 设置 | setcursor | 系统鼠标
font | public | getcontrolfont | font | setcontrolfont |
onmousewheel | public | fonmousewheel | function[tcontrol,tmmousewheel] | fonmousewheel | 滚动回调函数
onsize | public | fonsize | eventhandler | fonsize |
onmove | public | fonmove | eventhandler | fonmove |
onmousemove | public | fonmousemove | function[tcontrol,tmmouse] | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | fonpopupmenu | function[tcontrol,tmmouse] | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | fonmousedown | function[tcontrol,tmmouse] | fonmousedown | 鼠标按下回调函数
onmouseup | public | fonmouseup | function[tcontrol,tmmouse] | fonmouseup | 鼠标松开回调函数
onclick | public | fonclick | function[tcontrol,tmmouse] | fonclick | 鼠标点击回调函数
onrclick | public | fonrclick | eventhandler | fonrclick |
ondblclick | public | fondblclick | function[tcontrol,tmmouse] | fondblclick | 鼠标双击回调函数
parent | public | fparent | tcontrol | preparesetparent | 父控件
popupmenu | public | fpopupmenu | tpopupmenu | fpopupmenu | 弹出菜单
visible | public | fvisible | bool | setvisible | 是否可见
clientrect | public | getclientrect | array of integer |  | 客户区矩形array(left,top,right,bottom)
height | public | fheight | integer | setheight | 高度
width | public | fwidth | integer | setwidth | 宽度
left | public | fleft | integer | setleft | 左边
top | public | ftop | integer | settop | 上方位置
border | public | fborder | bool | setborder |
boundsrect | public | getboundsrect | array of integer | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | getzorder | integer | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | fcontrolstate | tcontrolstate | fcontrolstate |
color | public | getcolor | integer | setcolor | 背景色
bkbitmap | public | fbkbitmap | tbitmap | setbitmap |
controls | public | fcontrols | tfplist of tcontrol |  | 子组件
canvas | public | fcanvas | tcanvas |  | 画布对象
owner | public | fowner | tcomponent |  | 所有者
componentcreated | public | fcomponentcreated | bool |  | 样式结合
componentstate | public | fcomponentstate |  | setcomponentstate | 状态集合
componentstyle | public | fcomponentstyle |  |  | 样式结合
name | public | fname | string | setname |
ondestroy | public | fondestroy | eventhandler | fondestroy |
onnotification | public | fonnotification | eventhandler | fonnotification |


tslvcl

tvclib/tslvcl

定义:unit tslvcl;
uses:
  • utslvclconstant
  • utslvclbase
  • utslvclauxiliary
  • cstructurelib
  • utslvclmemstruct
  • utslvclevent
  • uvcpropertytypespersistence
  • utslvclgdi
  • utslvclaction
  • utslvclmenu
  • utslvclstdctl
  • utslvclpage
  • utslvcldlg
  • utslvclgrid
  • utslvcltree
  • utslvclcoolbar

说明:
tsl语言可视化组件库库,支持windows以及gtk(linux)
成员:
name | type
initializeapplication | function
registercomponenttype | function
getanddispatchmessagea | function
exitmessageloop | function
notifycomponent | function
tslcstructure | function
calldatafunction | function
checktslcode | function
copyusedtsldlltonewdir | function
messageboxa | function
_timeproc_ | function
_twinproc_ | function
remotetslcallback | function
tapplication | class
tlabel | class
tsyscontrol | class
twincontrolwraper | class
tscrollingwincontrol | class
tpanel | class
ttray | class
tvcform | class
tform | class
tpanelform | class
tbtn | class
tcheckbtn | class
tradiobtn | class
tedit | class
tpassword | class
tmemo | class
tgroupbox | class
tlistbox | class
tcolorbox | class
tcolorcombobox | class
tcombobox | class
ttoolbutton | class
ttoolbar | class
tstatusbar | class
tcoolbar | class
tsplitter | class
ttreectlnode | class
ttreenode | class
ttreectl | class
ttreeview | class
ttabsheet | class
tpagecontrol | class
tpairsplitterside | class
tpairsplitter | class
ttlvnactiveevent | class
tgridbase | class
tdrawgrid | class
tlistview | class
tprogressbar | class
tmonthcalendar | class
tdatetimepicker | class
ttimepicker | class
tipaddr | class
tspinedit | class
tapplicationwindow | class
timagelistdrawstyle | class
timagelistcreateflags | class
tcontrolimagelist | class
ttimer | class
taction | class
tmessageboxadlg | class
tcolorchooseadlg | class
tfontchooseadlg | class
tsavefileadlg | class
topenfileadlg | class
tfolderchooseadlg | class
tmenu | class
tpopupmenu | class
tmainmenu | class
tclipboard | class
tthreadworker | class
tregkey | class
twinenviroment | class
tquotations | class
tlogincontrol | class
tinifileexta | class
tcreateprocessa | class
tmyarraya | class
tmyarrayb | class


tuieventbase

tvclib/tuieventbase

定义:type tuieventbase= class(tsluiconst);
uses:
  • utslvclauxiliary
  • utslvclconstant

说明:
消息基类
成员变量:
name | type | private | describe
message | integer|any | public | 消息id
wparam | pointer | public | 消息wparam
lparam | pointer | public | 消息lparam
hwnd | pointer | public | 窗口句柄

成员函数:
function | private
create | public
hilparam | public
lolparam | public
hiwparam | public
lowparam | public
hilparamsigned | public
lolparamsigned | public
hiwparamsigned | public
lowparamsigned | public

propeties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender

继承的变量:
name | private | static | type | describe
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


twincontrol

tvclib/twincontrol

定义:type twincontrol= class(tcontrol);
uses:
  • utslvclauxiliary
  • utslvclmemstruct
  • utslvclbase
  • utslvclevent
  • utslvclgdi
  • uvclthreadworker
  • utslvclaction
  • utslvclmenu
  • utslvclstdctl

说明:
窗口控件
成员函数:
function | private
sinit | protected
initializewnd | protected
createparams | protected
realsettext | protected
createwndclass | protected
hitcontrol | protected
captionheight | public
wmgetminmaxinfo | public
getclientrect | public
wmerasebkgnd | public
wmnotify | public
keyup | public
keydown | public
keypress | public
dosetfocus | public
dokillfocus | public
clienttowindow | public
show | public
endmodal | public
updatewindow | public
movecontrolorder | public
invalidaterect | public
createwnd | public
handleallocated | public
destroyhandle | public
handleneeded | public
setbounds | public
mainwndproc | public
designingsizer | public
designingclick | public
designingmove | public
docontrolalign | public
docontrolanchor | public
wnddefaulthandler | public
defaulthandler | public
broadcast | public
_send_ | public

propeties:
name | private | type | read | write | describe
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | write | describe
action | public | getaction | taction | setaction | action对象
anchors | public | fanchors | array of tanchorkind member | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | falign | member of talign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | getunalignbounds | array of integer | setunalignbounds | 去除自动对齐时的范围
parentfont | public | fparentfont | bool | setparentfont |
parentcolor | public | fparentcolor | bool | setparentcolor |
caption | public | gettext | string | settext | 控件标题
enabled | public | getenabled | bool | setenabled | 控件是否有效
cursor | public | getcursor | tcursor 通过 member of tsystemcursor 设置 | setcursor | 系统鼠标
font | public | getcontrolfont | font | setcontrolfont |
onmousewheel | public | fonmousewheel | function[tcontrol,tmmousewheel] | fonmousewheel | 滚动回调函数
onsize | public | fonsize | eventhandler | fonsize |
onmove | public | fonmove | eventhandler | fonmove |
onmousemove | public | fonmousemove | function[tcontrol,tmmouse] | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | fonpopupmenu | function[tcontrol,tmmouse] | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | fonmousedown | function[tcontrol,tmmouse] | fonmousedown | 鼠标按下回调函数
onmouseup | public | fonmouseup | function[tcontrol,tmmouse] | fonmouseup | 鼠标松开回调函数
onclick | public | fonclick | function[tcontrol,tmmouse] | fonclick | 鼠标点击回调函数
onrclick | public | fonrclick | eventhandler | fonrclick |
ondblclick | public | fondblclick | function[tcontrol,tmmouse] | fondblclick | 鼠标双击回调函数
parent | public | fparent | tcontrol | preparesetparent | 父控件
popupmenu | public | fpopupmenu | tpopupmenu | fpopupmenu | 弹出菜单
visible | public | fvisible | bool | setvisible | 是否可见
clientrect | public | getclientrect | array of integer |  | 客户区矩形array(left,top,right,bottom)
height | public | fheight | integer | setheight | 高度
width | public | fwidth | integer | setwidth | 宽度
left | public | fleft | integer | setleft | 左边
top | public | ftop | integer | settop | 上方位置
border | public | fborder | bool | setborder |
boundsrect | public | getboundsrect | array of integer | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | getzorder | integer | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | fcontrolstate | tcontrolstate | fcontrolstate |
color | public | getcolor | integer | setcolor | 背景色
bkbitmap | public | fbkbitmap | tbitmap | setbitmap |
controls | public | fcontrols | tfplist of tcontrol |  | 子组件
canvas | public | fcanvas | tcanvas |  | 画布对象
owner | public | fowner | tcomponent |  | 所有者
componentcreated | public | fcomponentcreated | bool |  | 样式结合
componentstate | public | fcomponentstate |  | setcomponentstate | 状态集合
componentstyle | public | fcomponentstyle |  |  | 样式结合
name | public | fname | string | setname |
ondestroy | public | fondestroy | eventhandler | fondestroy |
onnotification | public | fonnotification | eventhandler | fonnotification |


utslmemo

tvclib/utslmemo

定义:unit utslmemo;
uses:
  • utslvclauxiliary
  • utslvclgdi
  • utslvclstdctl

说明:
文本控件库
成员:
name | type
tcustommemocmd | class
tcustommemo | class
tsyncompletion | class
tcustomsynhighlighter | class
tsyncustommemo | class


utslvclaction

tvclib/utslvclaction

定义:unit utslvclaction;
uses:
  • utslvclauxiliary
  • utslvclbase

说明:
action 接口库
成员:
name | type
tbasicaction | class
tcustomaction | class
tcustomactionlist | class
tbasicactionlink | class
tactionlink | class
tcontrolactionlink | class


utslvclauxiliary

tvclib/utslvclauxiliary

定义:unit utslvclauxiliary;
说明:
tslvcl 辅助库
成员:
name | type
includestate | function
excludestate | function
makelong | function
makeposition | function
getbitsfrominteger | function
unsignedtosigned | function
signedtounsigned | function
lowuperdword | function
formattsldata | function
gettemppath | function
pointinrect | function
intersectrect | function
bitcombination | function
tsltohexformatstr | function
hexformatstrtotsl | function
deleteallfiles | function
createdirwithfilename | function
tbytedataop | class
tarray1dlk | class
tfplist | class
tstrindexarray | class
tnumindexarray | class
tarraytreeclass | class
tnode | class
ttire | class
tinifileexter | class
tcanvsrgnclipautosave | class


utslvclbase

tvclib/utslvclbase

定义:unit utslvclbase;
uses:
  • utslvclconstant
  • utslvclmemstruct
  • utslvclauxiliary

成员:
name | type
tswin32api | class
tsluibase | class


utslvclconstant

tvclib/utslvclconstant

定义:unit utslvclconstant;
说明:
tsl接口常量库
成员:
name | type
constant | class
tenumeration | class
talign | class
tanchorkind | class
tmousebutton | class
tshiftstateenum | class
talignstyle9 | class
talignstyleh3 | class
tsyscursor | class
tmbbtnstyle | class
tmbiconstyle | class
trasteroperationconst | class
tsystembitmap | class
tsystemcursor | class
tmacroconst | class
tconstant | class
tsluiconst | class
_winuserdef_ | class
_tvclmsageid_ | class


utslvclcoolbar

tvclib/utslvclcoolbar

定义:unit utslvclcoolbar;
uses:
  • utslvclauxiliary
  • utslvclgdi

说明:
coolbar库,提供coolbar 支持
成员:
name | type
tcustomcoolbar | class


utslvcldlg

tvclib/utslvcldlg

定义:unit utslvcldlg;
uses:
  • cstructurelib
  • utslvclauxiliary
  • utslvclmemstruct
  • utslvclbase
  • utslvclgdi
  • utslvclstdctl

成员:
name | type
tcommdlg | class
tcustommsgadlg | class
tcustomcolordlg | class
tcustomfontdlg | class
tcustomfolderdlg | class
tcustomfsdlg | class


utslvclevent

tvclib/utslvclevent

定义:unit utslvclevent;
uses:
  • cstructurelib
  • utslvclconstant
  • utslvclmemstruct
  • utslvclauxiliary

说明:
消息相关对象相关类型
成员:
name | type
tmnotify | class
tmmenuselect | class
tmkey | class
ttagedrawitem | class
tgridmdrawitem | class
tsiftstate | class
tmmousewheel | class
tmmouse | class
tmstylechang | class


底层伪接口

tvclib/utslvclfackinterface

定义:unit utslvclfackinterface;
别名:底层伪接口
说明:
该文件提供底层接口的说明无具体实现
该单元中的类型和函数可以直接使用
成员:
name | type
getsenderdatabyid | function
gettslvariableptr | function
getctypesize | function
getwinprocptr | function
aefclassobj_ | class


utslvclgdi

tvclib/utslvclgdi

定义:unit utslvclgdi;
uses:
  • cstructurelib
  • utslvclmemstruct
  • utslvclauxiliary
  • utslvclbase

说明:
gdi 对象库
成员:
name | type
gettextwidthandheightwidthfont | function
getgdipstatus | function
tcustomfont | class
tfontcontrol | class
trgn | class
trgnellip | class
trgnrect | class
trgnroundrect | class
trgnpoly | class
tcustomimage | class
tpicturebase | class
tcustombitmap | class
tcustomicon | class
tcustomcursor | class
tcustomimagelist | class
tcustomcontrolimagelist | class
tcustomcanvas | class


utslvclgrid

tvclib/utslvclgrid

定义:unit utslvclgrid;
uses:
  • utslvclauxiliary
  • utslvclmemstruct
  • utslvclgdi

说明:
表格控件相关
成员:
name | type
tcustomgridctl | class
tgriddrawcellevent | class


utslvclmemstruct

tvclib/utslvclmemstruct

定义:unit utslvclmemstruct;
uses:
  • cstructurelib
  • utslvclauxiliary

说明:
接口内存管理类
成员:
name | type
ttagmsg | class
tcrect | class
tpaintstruct | class
tbrowseinfoa | class
tbrowseinfoa_ | class
ttagchoosecolora | class
ttagchoosefonta | class
ttaglogfonta | class


utslvclmenu

tvclib/utslvclmenu

定义:unit utslvclmenu;
uses:
  • utslvclauxiliary
  • cstructurelib
  • utslvclgdi
  • utslvclaction

说明:
菜单相关
成员:
name | type
tcustommenu | class
tcustompopupmenu | class
tcustommainmenu | class
tmenuactionlink | class


utslvclpage

tvclib/utslvclpage

定义:unit utslvclpage;
uses:
  • utslvclauxiliary
  • utslvclbase
  • utslvclgdi

成员:
name | type
tcustomtabsheet | class
tcustompagecontrol | class


utslvclstdctl

tvclib/utslvclstdctl

定义:unit utslvclstdctl;
uses:
  • utslvclauxiliary
  • utslvclbase
  • utslvclgdi
  • utslvclaction
  • utslvclmenu

说明:
标准控件库
成员:
name | type
tcustomclipboard | class
tcustomtimer | class
tcustombtn | class
tcustomcheckbtn | class
tcustomradiobtn | class
tvirtualcalender | class
tcustomlabel | class
tcustomedit | class
tcustompassword | class
tcustomlistboxbase | class
tlistdrawevent | class
tcustomlistbox | class
tcustomcomboboxbase | class
tcustomcombobox | class
tcustomtoolbutton | class
tcustomtoolbar | class
tcustomstatusbar | class
tcustomspinedit | class
tcustomprogressbar | class
tcustomipaddr | class


utslvcltree

tvclib/utslvcltree

定义:unit utslvcltree;
uses:
  • utslvclauxiliary
  • utslvclbase
  • utslvclgdi

说明:
树控件相关
成员:
name | type
tcustomtreectlnode | class
tcustomtreectl | class


uvclthreadworker

tvclib/uvclthreadworker

定义:unit uvclthreadworker;
uses:
  • cstructurelib

说明:
支持工作线程
注意:工作线程中仅仅支持运算,不支持窗口的操作,
成员:
name | type
runthreadworkerclient | function
tworkerclient | class
tcustomthreadworker | class


uvcpropertytypespersistence

tvclib/uvcpropertytypespersistence

定义:unit uvcpropertytypespersistence;
uses:
  • utslvclauxiliary

说明:
可视控件属性处理库
成员:
name | type
ttmfparserbase | class
ttmfparsertoken | class
ttmfparser | class
tpropertytype | class
tpropertynatural | class
tpropertycolor | class
tpropertybool | class
tpropertyaction | class
tpropertyimagesdata | class
tpropertybitmap | class
tpropertyicon | class
tpropertyalign | class
tpropertystrings | class


uwindowsinterface

tvclib/uwindowsinterface

定义:unit uwindowsinterface;
uses:
  • cstructurelib

说明:
windows平台相关接口


csstotslarray

tvclib/cstructurelib/csstotslarray

定义: csstotslarray(csstr,tname);
说明:
将c的结构体字符串形式转换为tsl数组
参数:
name | type | describe
csstr |  |
tname | string | 名称,返回值

返回值:
type | describe
array | 结构定义

转换cstruct结构到tslarray-1
s := "
typedef struct tagWINDOWPOS {
HWND hwnd;
HWND hwndInsertAfter;
int x;
int y;
int cx;
int cy;
UINT flags;
} WINDOWPOS, *LPWINDOWPOS, *PWINDOWPOS;

";
return csstotslarray(s);


csstotslarray2

tvclib/cstructurelib/csstotslarray2

定义: csstotslarray2(csstr,iv);
说明:
将c的结构体字符串形式转换为tsl数组
参数:
name | type | describe
csstr |  |
iv | array | 初始值

返回值:
type | describe
array | 结构定义

转换cstruct结构到tslarray-2
s := "
typedef struct _SYSTEMTIME {
WORD wYear;
WORD wMonth;
WORD wDayOfWeek;
WORD wDay;
WORD wHour;
WORD wMinute;
WORD wSecond;
WORD wMilliseconds;
} SYSTEMTIME, *PSYSTEMTIME;
";
return csstotslarray2(s);


csstotslarray3

tvclib/cstructurelib/csstotslarray3

定义: csstotslarray3(ret,iv);
说明:
对c结构定义,初始值
参数:
name | type | describe
ret | array | 结构定义
iv | array | 初始值

返回值:
type | describe
array | 结构定义


cstructtotslclass

tvclib/cstructurelib/cstructtotslclass

定义: cstructtotslclass(data,name,fs);
说明:
将数组结构转换为对象
参数:
name
data
name
fs


ctslctrans

tvclib/cstructurelib/ctslctrans

定义:type ctslctrans= class(tmemoryclass);
说明:
旧的内存管理类,不支持**类型
成员函数:
function | private
operator [1] | public
operator [] | public
create | public
_getptr2_ | public
_getptr_ | public
_setcptr_ | public
_size_ | public
arraynumberchek | public
_getvalue_ | public
_getvalueaddr_ | public
_getvalueaddr2_ | public
_getdata_ | public
copytostring | public
copyfromstring | public

继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool

范例--内存管理--1
sa := array(("f","int",2),
("a","char[3]","cd"),
("b","user",(("c","char[5]","ab"),
("d","int",5))),
("c","user*",(("c","char[5]","ab"),
("d","int",5),
("e","char*","abcd")))

);
data := tslarraytocstructcalc(sa);
o := new ctslctrans(data);
return echo o._size_(),"****",
o._getvalue_("c")._size_(),"***",
o._getvalue_("b")._size_,"***",o._getvalue_("c")._getvalue_("e");


ctypedefine

tvclib/cstructurelib/ctypedefine

定义: ctypedefine(name,stc,alim,f);
说明:
结构体定义
参数:
name | type | describe
name | string | 名称
stc | array | 内存分布
alim | integer | 对其方式
f |  |

返回值:
type | describe
tcstruct |


dealcppcomment

tvclib/cstructurelib/dealcppcomment

定义: dealcppcomment(strs);
说明:
删除c语言注释
参数:
name | type | describe
strs | string | c结构体字符串

返回值:
type | describe
string |


memoryalignmentcalculate

tvclib/cstructurelib/memoryalignmentcalculate

定义: memoryalignmentcalculate(data,baselen,ssize,pack);
说明:
结构体排布计算
参数:
name | type | describe
data | array | 结构体信息数组,参考 cstructurelib中 tslarraytocstructcalc
baselen | integer | 基准位置默认为0
ssize | integer | 大小
pack | integer | 对其方式 windows 默认8 linux 默认4


parserctypestr

tvclib/cstructurelib/parserctypestr

定义: parserctypestr(ts,t,s,n);
说明:
类型解析
参数:
name | type | describe
ts | string | 类型字符串 如 "char[100]"
t | string | 类型
s | integer | 数组长度
n | string | 名称


readbytesfromptr

tvclib/cstructurelib/readbytesfromptr

定义: readbytesfromptr(ptr,l);
说明:
读取一个指向数组指针的值
参数:
name | type | describe
ptr | pointer | 指针
l | integer | 长度

返回值:
type | describe
array of integer | 字符串


readstringfromptr

tvclib/cstructurelib/readstringfromptr

定义: readstringfromptr(ptr);
说明:
读取一个指向\0字符串指针的值
参数:
name | type | describe
ptr | pointer | 指针

返回值:
type | describe
string | 字符串


tcbytearray

tvclib/cstructurelib/tcbytearray

定义:type tcbytearray= class();
说明:
byte数组内存管理类
成员变量:
name | private | type | describe
reallen | public | integer | 实际内存长度
len | public | integer | 数组占用长度
obj | public | tslcstructureobj | 内存对象

成员函数:
function | private
create | public
reset | public
occupancy | public
length | public
_getptr_ | public
setv | public
getv | public
ptr | public


tcstring

tvclib/cstructurelib/tcstring

定义:type tcstring= class(tcbytearray);
说明:
字符串内存管理类
成员函数:
function | private
getv | public
setv | public

propeties:
name | private | read | write | type | describe
endzero | public | _flag | _flag | bool | 默认为false字符串以\0结束

继承的变量:
name | private | type | describe
reallen | public | integer | 实际内存长度
len | public | integer | 数组占用长度
obj | public | tslcstructureobj | 内存对象

继承的函数:
  • create
  • reset
  • occupancy
  • length
  • _getptr_
  • setv
  • getv
  • ptr


tcstructwithcharptr

tvclib/cstructurelib/tcstructwithcharptr

定义:type tcstructwithcharptr= class(ctslctrans);
说明:
内存结构体分配管理类
成员函数:
function | private
create | public
operator [1] | public
operator [] | public
_setvalue_ | public
_getvalue_ | public
_getdata_ | public
setstringi | protected

继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


tmemoryclass

tvclib/cstructurelib/tmemoryclass

定义:type tmemoryclass= class();
说明:
存对象分配,释放类
成员变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

成员函数:
function | private
getpointersize | public
opblocks | public
tmalloc | public
tfree | public
trealloc | public
mtool | public


tslarraytocstructcalc

tvclib/cstructurelib/tslarraytocstructcalc

定义: tslarraytocstructcalc(data,alim,bsi,ssize);
说明:
计算内存对其长度
参数:
name | type | describe
data | array | 数据 tsl数据结构 二维数组 每行为c 结构体的一个数据 0 列为 字符串类型的变量名字 1 列为 变量类型 ,字符串 (包括 short,short[n],intptr,intptr[n],int,int[n],double,double[n],char[n],byte,byte[n] n为数组大小) 当类型为char*的时候需要分配内存空间, 第2列为string值 或者是整数 string的长度 2 列为 值
alim | integer | 对其方式
bsi | integer | 基地址,默认为0
ssize | array | 结构体大小

返回值:
type | describe
array | 返回值在参数data 增加下面字段 3 列为 相对偏移 4 列为 大小 5 列为 名字 6 列为 如果为数组表示个数


tslcstructureobj

tvclib/cstructurelib/tslcstructureobj

定义:type tslcstructureobj= class(ctslctrans);
说明:
tsl数据结构和内存交互接口类封装
成员函数:
function | private
create | public

继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool

范例--内存结构
sc := array(("a","int",1),("b","double",2)("c","intptr",1234));
//兼容c中的 co = new struct{int a = 1; double b = 2.0; intptr = 1234}
co := new tslcstructureobj(MemoryAlignmentCalculate(sc));
co._setvalue_("a",5); //设置成员 a的值
echo co._getvalue_("b");//获得成员 b 的值
echo co._size_();//获得内存大小
echo co._getptr_() ;//对象对应的内存指针


writebytestoptr

tvclib/cstructurelib/writebytestoptr

定义: writebytestoptr(ptr,bytes);
说明:
向一个指针写入字节数据
参数:
name | type | describe
ptr | pointer | 指针
bytes | array of integer | 数据


writestringtoptr

tvclib/cstructurelib/writestringtoptr

定义: writestringtoptr(ptr,str);
说明:
向一个指针写入\0结尾的字符串
参数:
name | type | describe
ptr | pointer | 指针
str | string | 字符串


_getdata_

tvclib/cstructurelib/ctslctrans/_getdata_

定义: public _getdata_();virtual;
说明:
获得所有数据
返回值:
type | describe
array |


_getptr2_

tvclib/cstructurelib/ctslctrans/_getptr2_

定义: public _getptr2_();
说明:
获得内存指针


_getptr_

tvclib/cstructurelib/ctslctrans/_getptr_

定义: public _getptr_();
说明:
获得内存指针


_getvalue_

tvclib/cstructurelib/ctslctrans/_getvalue_

定义: public _getvalue_(v);virtual;
说明:
根据索引v获得对应值
参数:
name | describe
v | 索引


_getvalueaddr2_

tvclib/cstructurelib/ctslctrans/_getvalueaddr2_

定义: public _getvalueaddr2_(i);
说明:
读取值对应地址的值作为地址
参数:
name | describe
i | 索引


_getvalueaddr_

tvclib/cstructurelib/ctslctrans/_getvalueaddr_

定义: public _getvalueaddr_(i);
说明:
获得值对应的内存地址
参数:
name | describe
i | 索引


_setcptr_

tvclib/cstructurelib/ctslctrans/_setcptr_

定义: public _setcptr_(ptr);
说明:
设置对象地址
参数:
name
ptr


_size_

tvclib/cstructurelib/ctslctrans/_size_

定义: public _size_();
说明:
获得内存大小


arraynumberchek

tvclib/cstructurelib/ctslctrans/arraynumberchek

定义: public arraynumberchek(v);
说明:
数字数组检查
参数:
name | type
v | array


copyfromstring

tvclib/cstructurelib/ctslctrans/copyfromstring

定义: public copyfromstring(s);
说明:
将字符串拷贝到内存
参数:
name | type
s | string


copytostring

tvclib/cstructurelib/ctslctrans/copytostring

定义: public copytostring();
说明:
将内存数据转换为字符串
返回值:
type | describe
string |


create

tvclib/cstructurelib/ctslctrans/create

定义: public create(data,ptr,ifset);
说明:
构造
参数:
name | type | describe
data | array | 计算好的内存分布
ptr | integer | 内存指针
ifset | integer | 递归构造时使用


operator [1]

tvclib/cstructurelib/ctslctrans/operator [1]

定义: public operator [1](index,v);
说明:
设置成员
参数:
name | type | describe
index | tslobj | 下标
v | tslobj | 值


operator []

tvclib/cstructurelib/ctslctrans/operator []

定义: public operator [](index);
说明:
获取成员
参数:
name | type | describe
index | tslobj | 下标

返回值:
type | describe
tslobj | 返回值


_getptr_

tvclib/cstructurelib/tcbytearray/_getptr_

定义: public _getptr_();
说明:
返回数组内存指针


create

tvclib/cstructurelib/tcbytearray/create

定义: public create(n);
说明:
构造
参数:
name | type | describe
n | integer|array of integer | 字符串长度 预分配


getv

tvclib/cstructurelib/tcbytearray/getv

定义: public getv();
说明:
返回byte数组
返回值:
type | describe
array of byte | 返回的数组


length

tvclib/cstructurelib/tcbytearray/length

定义: public length(n);
说明:
设置长度 或者获取数组的占用长度
参数:
name | type | describe
n | integer|nil | nil为获取长度,数字为设置长度


occupancy

tvclib/cstructurelib/tcbytearray/occupancy

定义: public occupancy();
说明:
获取内存占用
返回值:
type | describe
integer | 占用大小


ptr

tvclib/cstructurelib/tcbytearray/ptr

定义: public ptr();
说明:
返回内存指针


reset

tvclib/cstructurelib/tcbytearray/reset

定义: public reset(n);
说明:
重新设置
参数:
name | type | describe
n | array of byte | 设置字的数组


setv

tvclib/cstructurelib/tcbytearray/setv

定义: public setv(n);virtual;
说明:
设置byte数组
参数:
name | type | describe
n | array of byte | 数组


getv

tvclib/cstructurelib/tcstring/getv

定义: public getv(n);
说明:
返回字符串
参数:
name | type | describe
n | integer | 获取字符串的长度

返回值:
type | describe
string | 字符串


setv

tvclib/cstructurelib/tcstring/setv

定义: public setv(v);override;
说明:
设置字符串
参数:
name | type | describe
v | string | 字符串


_getdata_

tvclib/cstructurelib/tcstructwithcharptr/_getdata_

定义: public _getdata_();override;
说明:
获得结构体的值
返回值:
type | describe
array | tsl数据


_getvalue_

tvclib/cstructurelib/tcstructwithcharptr/_getvalue_

定义: public _getvalue_(id,n);override;
说明:
获取成员值
参数:
name | type | describe
id | string | 成员id
n | integer | 如果为字符串获取字符串的长度,不送入默认为\0结尾

返回值:
type | describe
obj | tsl数据


_setvalue_

tvclib/cstructurelib/tcstructwithcharptr/_setvalue_

定义: public _setvalue_(id,v);override;
说明:
设置成员值
参数:
name | type | describe
id | string | 成员id
v | string|integer | 设置的值


create

tvclib/cstructurelib/tcstructwithcharptr/create

定义: public create(stc,strn1,strn2);
说明:
构造内存对象
参数:
name | type | describe
stc | array | 内存分配结构描述
strn1 |  |
strn2 |  |


operator [1]

tvclib/cstructurelib/tcstructwithcharptr/operator [1]

定义: public operator [1](index,v);
说明:
设置成员
参数:
name | type | describe
index | tslobj | 下标
v | tslobj | 值


operator []

tvclib/cstructurelib/tcstructwithcharptr/operator []

定义: public operator [](index);
说明:
获取成员
参数:
name | type | describe
index | tslobj | 下标

返回值:
type | describe
tslobj | 返回值


setstringi

tvclib/cstructurelib/tcstructwithcharptr/setstringi

定义: protected setstringi(i,v,n);
说明:
字符串对象分配
参数:
name | type | describe
i | string | 字符串对象的id
v | string | 字符串对象
n | string | 字符串所在字段描述


getpointersize

tvclib/cstructurelib/tmemoryclass/getpointersize

定义: public class getpointersize();
说明:
获得指针字节数


mtool

tvclib/cstructurelib/tmemoryclass/mtool

定义: public class mtool();
说明:
获取底层操作工具
返回值:
type | describe
aefclassobj_ | 内存底层管理工具


opblocks

tvclib/cstructurelib/tmemoryclass/opblocks

定义: public opblocks(p,f,v);
说明:
内存存储操作
参数:
name | type | describe
p | integer | 内存指针
f | integer | 操作码 0 获取 1 设置 2 删除
v |  |


tfree

tvclib/cstructurelib/tmemoryclass/tfree

定义: public tfree(p);
说明:
释放内存
参数:
name | type | describe
p | integer | 指针


tmalloc

tvclib/cstructurelib/tmemoryclass/tmalloc

定义: public tmalloc(n,f);
说明:
内存分配
参数:
name | type | describe
n |  |
f | integer | 操作码 0 获取 1 设置 2 删除


trealloc

tvclib/cstructurelib/tmemoryclass/trealloc

定义: public trealloc(p,n,f);
说明:
重分配
参数:
name | type | describe
p | integer | 指针
n | integer | 大小
f | integer | 操作码 0 获取 1 设置 2 删除


create

tvclib/cstructurelib/tslcstructureobj/create

定义: public create(data,ptr);
说明:
内存对象构造
参数:
name | type | describe
data | array | 内存结构,使用 MemoryAlignmentCalculate 产生
ptr | integer|nil | 内存指针,如果不给定,自动分配,如果给定从内存读取


parserctokens

tvclib/parserch/parserctokens

定义: parserctokens(str);
说明:
c分词
参数:
name
str


pcstruct

tvclib/parserch/pcstruct

定义: pcstruct(s,f);
说明:
解析c结构体字符串到tsl结构化数据
参数:
name | type | describe
s | string | c结构体字符串
f | bool | true 转换为小写

返回值:
type | describe
array | tag字段为名称 field 为字段信息 n : 名称 t : 类型 一个数组如果 array(unsigned,int) l : 如果为数组 数组的长度 p : 如果为指针,指针的*个数 nick 别名


destroycomponents

tvclib/tcomponent/destroycomponents

定义: public destroycomponents();
说明:
删除子项


executeaction

tvclib/tcomponent/executeaction

定义: public executeaction(act);virtual;
说明:
执行action
参数:
name | type
act | tbasicaction


freenotification

tvclib/tcomponent/freenotification

定义: public freenotification(acomponent);
说明:
关联对象,在释放的时候相互通知
参数:
name | type | describe
acomponent | tcomponent | 对象


getchangedpublish

tvclib/tcomponent/getchangedpublish

定义: public getchangedpublish(f);virtual;
说明:
获取修改过的publish,设计器使用
参数:
name
f


getpublishevents

tvclib/tcomponent/getpublishevents

定义: public getpublishevents();virtual;
说明:
获得event值,设计器使用
返回值:
type | describe
array |


getpublishproperties

tvclib/tcomponent/getpublishproperties

定义: public getpublishproperties();virtual;
说明:
获得properties,设计器使用


insertcomponent

tvclib/tcomponent/insertcomponent

定义: public insertcomponent(acomponent);virtual;
说明:
插入节点
参数:
name
acomponent


isdescendant

tvclib/tcomponent/isdescendant

定义: public isdescendant(cd);
说明:
判断节点是否为其子节点
参数:
name | type | describe
cd | tcomponent | 等判断节点

返回值:
type | describe
bool | true 为子节点 false 非子节点


notification

tvclib/tcomponent/notification

定义: public notification(acomponent,operation);virtual;
说明:
通知处理
参数:
name | type | describe
acomponent | tcomponent | 改变的对象
operation | member of toperation | 通知码


removecomponent

tvclib/tcomponent/removecomponent

定义: public removecomponent(acomponent);
说明:
移除子节点
参数:
name
acomponent


setchangedpublish

tvclib/tcomponent/setchangedpublish

定义: public setchangedpublish(n,v,pp);virtual;
说明:
设计器相关函数
参数:
name
n
v
pp


setdesigning

tvclib/tcomponent/setdesigning

定义: public setdesigning(value,setchildren);virtual;
说明:
设计器使用方法,设置为设计状态,或者解除设置状态
参数:
name | type | describe
value | bool | 状态值
setchildren | bool | 是否修改子控件状态


setowner

tvclib/tcomponent/setowner

定义: public setowner(aowner);
说明:
设置所有者,注意只能成功设置一次,之后设置无效
参数:
name | type | describe
aowner | tcomponent | 所有者


setpublish

tvclib/tcomponent/setpublish

定义: public setpublish(n,v,pp);virtual;
说明:
修改单个值,设计器使用
参数:
name | type | describe
n | string | 名称
v | any | 值
pp |  |


updateaction

tvclib/tcomponent/updateaction

定义: public updateaction(act);virtual;
说明:
更新action
参数:
name | type
act | tbasicaction


contextmenu

tvclib/tcontrol/contextmenu

定义: public contextmenu(o,e);virtual;
说明:
右键菜单
参数:
name | type | describe
o | twincontrol | 控件自身
e | tuieventbase | 消息


controlappended

tvclib/tcontrol/controlappended

定义: protected controlappended(acontrol);virtual;
说明:
子控件添加
参数:
name
acontrol


controldeleted

tvclib/tcontrol/controldeleted

定义: protected controldeleted(acontrol);virtual;
说明:
子控件删除
参数:
name
acontrol


dispatch

tvclib/tcontrol/dispatch

定义: public dispatch(o,e);virtual;
说明:
消息分发函数
参数:
name | describe | type
o | 控件自身 |
e | 消息类及其子类 | tuieventbase


docncommand

tvclib/tcontrol/docncommand

定义: public docncommand(o,e);virtual;
说明:
通知消息
参数:
name | type | describe
o | tcontrol | 控件自身
e | tuieventbase | 消息


docnnotify

tvclib/tcontrol/docnnotify

定义: public docnnotify(o,e);virtual;
参数:
name
o
e


domousewheel

tvclib/tcontrol/domousewheel

定义: public domousewheel(o,e);virtual;
说明:
鼠标滚动消息
参数:
name | type | describe
o | twincontrol | 控件自身
e | tmmousewheel | 滚动消息


getactionlinkclass

tvclib/tcontrol/getactionlinkclass

定义: protected getactionlinkclass();virtual;
说明:
返回actionlinkclass
返回值:
type | describe
tcontrolactionlink class |


getbounds

tvclib/tcontrol/getbounds

定义: public getbounds();virtual;
说明:
获取控件范围
返回值:
type | describe
array of integer | array(aLeft, aTop, aWidth, aHeight: integer)


getboundsrect

tvclib/tcontrol/getboundsrect

定义: public getboundsrect();
说明:
获取矩形范围


getclientrect

tvclib/tcontrol/getclientrect

定义: public getclientrect();virtual;
说明:
获取客户区
返回值:
type | describe
array of integer | 左上右下


messagecreater

tvclib/tcontrol/messagecreater

定义: protected messagecreater(hwnd,message,wparam,lparam);virtual;
说明:
根据消息参数构造消息对象;
参数:
name
hwnd
message
wparam
lparam


mousedown

tvclib/tcontrol/mousedown

定义: public mousedown(o,e);virtual;
说明:
鼠标按下消息
参数:
name | type | describe
o | twincontrol | 控件自身
e | tmmouse | 消息


mouseup

tvclib/tcontrol/mouseup

定义: public mouseup(o,e);virtual;
说明:
鼠标松开消息
参数:
name | type | describe
o | twincontrol | 控件自身
e | tmmouse | 消息


notification

tvclib/tcontrol/notification

定义: public notification(acomponent,operation);override;
说明:
通知消息处理
参数:
name | type
acomponent | tcomponent
operation | toperation


paintstruct

tvclib/tcontrol/paintstruct

定义: public paintstruct();
说明:
获取绘制消息结对象
返回值:
type | describe
tpaintstruct | 包含绘制


perform

tvclib/tcontrol/perform

定义: public perform(e);
说明:
消息通知执行
参数:
name | type
e | tuieventbase


recycling

tvclib/tcontrol/recycling

定义: public recycling();override;
说明:
资源回收,子类请override该方法然后在destroy中调用


setboundsrect

tvclib/tcontrol/setboundsrect

定义: public setboundsrect(rect);
说明:
设置矩形范围
参数:
name
rect


wndproc

tvclib/tcontrol/wndproc

定义: public wndproc(themessage);virtual;
说明:
消息循环
参数:
name
themessage


getclientxcapacity

tvclib/tcustomscrollcontrol/getclientxcapacity

定义: protected getclientxcapacity();virtual;
说明:
客户区x容量


getclientxcount

tvclib/tcustomscrollcontrol/getclientxcount

定义: protected getclientxcount();virtual;
说明:
客户区x数量


getclientycapacity

tvclib/tcustomscrollcontrol/getclientycapacity

定义: protected getclientycapacity();virtual;
说明:
客户区y容量


getclientycount

tvclib/tcustomscrollcontrol/getclientycount

定义: protected getclientycount();virtual;
说明:
客户区y数量


getxscrolldelta

tvclib/tcustomscrollcontrol/getxscrolldelta

定义: protected getxscrolldelta();virtual;
说明:
获得x间隔


getyscrolldelta

tvclib/tcustomscrollcontrol/getyscrolldelta

定义: protected getyscrolldelta();virtual;
说明:
获得y间隔


positionchanged

tvclib/tcustomscrollcontrol/positionchanged

定义: protected positionchanged();virtual;
说明:
基准点改变回调


invalidaterect

tvclib/tgraphiccontrol/invalidaterect

定义: public invalidaterect(rec,f);
说明:
设置窗口区域无效
参数:
name | type | describe
rec | array | 无效区域,nil表示窗口整体无效,array(左上右下)
f | bool | 是否重画


paint

tvclib/tgraphiccontrol/paint

定义: protected paint();virtual;
说明:
控件绘制调用 ,使用Canvas属性和PAINTSTRUCT结构体 绘制控件


realsettext

tvclib/tgraphiccontrol/realsettext

定义: protected realsettext(s);override;
说明:
修改标题
参数:
name
s


_timeproc_

tvclib/tslvcl/_timeproc_

定义: _timeproc_(hwnd,message,wparam,lparam);
说明:
消息分发预处理函数被底层调用
参数:
name | type | describe
hwnd | integer | 窗口句柄
message | integer | 消息id
wparam | integer | 消息参数1
lparam | integer | 消息参数2


_twinproc_

tvclib/tslvcl/_twinproc_

定义: _twinproc_(hwnd,message,wparam,lparam);
说明:
消息分发预处理函数被底层调用
参数:
name | type | describe
hwnd | integer | 窗口句柄
message | integer | 消息id
wparam | integer | 消息参数1
lparam | integer | 消息参数2


calldatafunction

tvclib/tslvcl/calldatafunction

定义: calldatafunction();
说明:
执行函数句柄,默认第一个参数为函数句柄,后面的参数为该句柄的参数


checktslcode

tvclib/tslvcl/checktslcode

定义: checktslcode(code,err);
说明:
tsl语法检查
参数:
name | type | describe
code | string | tsl代码
err | string | 错误信息

返回值:
type | describe
bool | 成功返回true


copyusedtsldlltonewdir

tvclib/tslvcl/copyusedtsldlltonewdir

定义: copyusedtsldlltonewdir(p);
说明:
拷贝当前的tsl目录中使用的dll到指定目录
参数:
name
p


exitmessageloop

tvclib/tslvcl/exitmessageloop

定义: exitmessageloop();


getanddispatchmessagea

tvclib/tslvcl/getanddispatchmessagea

定义: getanddispatchmessagea(hwnd,minm,maxm);
说明:
获得和分发消息
参数:
name | type | describe
hwnd | pointer | 窗口句柄 默认为0
minm | integer | 最小消息值 默认为空
maxm | integer | 最大消息值 默认为空

返回值:
type | describe
integer | 0表示WM_QUIT ,-1表示错误,其他返回大于0


initializeapplication

tvclib/tslvcl/initializeapplication

定义: initializeapplication();
说明:
初始化application
返回值:
type | describe
tapplication | 窗口程序管理对象


messageboxa

tvclib/tslvcl/messageboxa

定义: messageboxa(txt,title,flag,hd);
说明:
提示对话框
参数:
name | type | describe
txt | string | 文本
title | string | 标题
flag | integer | 按钮类型
hd |  |

返回值:
type | describe
integer | 值


notifycomponent

tvclib/tslvcl/notifycomponent

定义: notifycomponent(sender,act,tocomponent);
说明:
通知节点AOwner有节点Acomponent 发生了改变,通知码为act
参数:
name | type | describe
sender |  |
act | member of toperation | 通知码
tocomponent |  |


registercomponenttype

tvclib/tslvcl/registercomponenttype

定义: registercomponenttype(n,typ);
说明:
注册component组件
参数:
name
n
typ


remotetslcallback

tvclib/tslvcl/remotetslcallback

定义: remotetslcallback(data);
说明:
行情订阅回调
参数:
name
data


taction

tvclib/tslvcl/taction

定义:type taction= class(tcustomaction);
说明:
action / command 类 对外接口,参考 TCustomAction 类
继承的函数:
  • assignto
  • create

继承的properties:
name | private | type | read | write
caption | public | string | fcaption | setcaption
checked | public | bool | fchecked | setchecked
enabled | public | bool | fenabled | setenabled
visible | public | bool | fvisible | setvisible
shortcut | public | string | getshortcut | setshortcut


tapplication

tvclib/tslvcl/tapplication

定义:type tapplication= class(tcomponent);
说明:
application 窗口
成员函数:
function | private
wmactivateapp | public
initialize | public
createform | public
run | public
showerrormessage | public
closemainform | public

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tapplicationwindow

tvclib/tslvcl/tapplicationwindow

定义:type tapplicationwindow= class(twincontrol);
说明:
application窗口类
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tbtn

tvclib/tslvcl/tbtn

定义:type tbtn= class(tcustombtn);
说明:
普通按钮
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • click
  • dosetfocus
  • dokillfocus
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
textpos | public | member of talignstyle9 | ftextposition | settextposition | 文本位置
pushlike | public | bool | fpushlike | setpushlike | 是否为普通按钮外观
multiline | public | bool | fmultiline | setmultiline | 文本是否为多行显示
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcheckbtn

tvclib/tslvcl/tcheckbtn

定义:type tcheckbtn= class(tcustomcheckbtn);
说明:
复选框
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • click
  • dosetfocus
  • dokillfocus
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
checked | public | integer | fcheckstate | setchecked | 勾选状态： 0：未选中。 1：选中。 @param(leftText)(bool)文本是否在左
lefttext | public | bool | flefttext | setlefttext |
textpos | public | member of talignstyle9 | ftextposition | settextposition | 文本位置
pushlike | public | bool | fpushlike | setpushlike | 是否为普通按钮外观
multiline | public | bool | fmultiline | setmultiline | 文本是否为多行显示
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tclipboard

tvclib/tslvcl/tclipboard

定义:type tclipboard= class(tcustomclipboard);
说明:
剪切板类
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • create
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tcolorbox

tvclib/tslvcl/tcolorbox

定义:type tcolorbox= class(tcustomlistbox);
说明:
color box 控件
成员函数:
function | private
getcolor | public
getcolorname | public
addcolor | public
appendcolors | public

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • paintidx
  • getcurrentselection
  • setcurrentselection
  • getitemselectedstate
  • setitemselectedstate
  • appenditem
  • appenditems
  • insertitem
  • insertitems
  • deleteitem
  • deleteitems
  • deleteselecteditems
  • getselectedindexes
  • getitem
  • getitemtext
  • checklistitem
  • paintidx
  • getidxrect
  • insureidxinclient
  • getclientidxs
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
itemheight | public | integer | getyscrolldelta | setitemheight |
itemcount | public | integer | getitemcount | setitemcount |
multisel | public | bool | fmultisel | setmultisel |
checkbox | public | bool | fcheckbox | setcheckbox |
selbkcolor | public | color | fselbkcolor | setselbkcolor |
onselchanged | public | eventhandler | fselectionchange | fselectionchange |
ondrawlist | public | eventhandler | fondrawlist | fondrawlist |
items | public | strings | getdata | setdata |
itemindex | public | tsl | getcurrentselection | setcurrentselection |
ownerdraw | public | bool | fownerdraw | setownerdraw |
itemcount | public | integer | getitemcount | setitemcount | 项数量
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcolorchooseadlg

tvclib/tslvcl/tcolorchooseadlg

定义:type tcolorchooseadlg= class(tcustomcolordlg);
说明:
颜色选择器
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | write | type | describe
customcolors | public | getcustomcolors | setcustomcolors | array of integer | 自定义颜色
result | public | getresult | setresult | color |
chooseok | public | fchooseok |  | bool | 是否执行成功
wndowner | public | fwndowner | fwndowner | twincontrol | 所属窗口
caption | public | fcaption | setcaption | string |
owner | public | fowner |  | tcomponent | 所有者
componentcreated | public | fcomponentcreated |  | bool | 样式结合
componentstate | public | fcomponentstate | setcomponentstate |  | 状态集合
componentstyle | public | fcomponentstyle |  |  | 样式结合
name | public | fname | setname | string |
ondestroy | public | fondestroy | fondestroy | eventhandler |
onnotification | public | fonnotification | fonnotification | eventhandler |


tcolorcombobox

tvclib/tslvcl/tcolorcombobox

定义:type tcolorcombobox= class(tcustomcomboboxbase);
说明:
Tcolorcombobox 是一种颜色选择的combobox
成员函数:
function | private
addcolor | public
appendcolors | public
clean | public
getcurrentcolor | public
getcolorname | public
getcolorvalue | public

继承的变量:
name | private | type | describe | static
flistbox | protected | twincontrol | 弹出框 |
fleft | protected | integer | 左边 |
ftop | protected | integer | 上边 |
fwidth | protected | integer | 宽度 |
fheight | protected | integer | 高度 |
_wapi | public | tswin32api | win32宏定义,以及api接口 | static
_tag | public | any | 调用者使用的成员变量 |
alnone | public | constant | 不对齐 | static
altop | public | constant | 上 | static
albottom | public | constant | 下 | static
alleft | public | constant | 左对齐 | static
alright | public | constant | 右对齐 | static
alclient | public | constant | 占满 | static
aktop | public | constant | 上 | static
akleft | public | constant | 左 | static
akright | public | constant | 右 | static
akbottom | public | constant | 下 | static
mbleft | public | constant | 左键 | static
mbright | public | constant | 右键 | static
mbmiddle | public | constant | 中间按键 | static
ssshift | public | constant | shift | static
ssalt | public | constant | alt | static
ssctrl | public | constant | ctl | static
ssdouble | public | constant | 双击 | static
al9_default | public | constant | 默认 | static
al9_topleft | public | constant | 顶部 | static
al9_center | public | constant | 居 | static
al3_left | public | constant | 左 | static
al3_right | public | constant | 右 | static
al3_center | public | constant | 居中 | static
idc_arrow | public | constant | 类型 | static

继承的函数:
  • createalist
  • showdropdown
  • setlistboxrect
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
itemindex | public | integer | getitemindex | setitemindex | 设置当前项序号
onselchanged | public | function[tcombobox,tuieventbase] | fonselchanged | fonselchanged | 当前选项改变回调
ondropdown | public | function[tcombobox,tuieventbase] | fondropdown | fondropdown | 下拉框展开回调
oncloseup | public | function[tcombobox,tuieventbase] | foncloseup | foncloseup | 下拉框关闭回调
dropdowncount | public | integer | fmaxlistitemshow | setmaxlistitemshow | 下拉列表项数
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcombobox

tvclib/tslvcl/tcombobox

定义:type tcombobox= class(tcustomcombobox);
说明:
comboBox下拉框
继承的变量:
name | private | type | describe | static
flistbox | protected | twincontrol | 弹出框 |
fleft | protected | integer | 左边 |
ftop | protected | integer | 上边 |
fwidth | protected | integer | 宽度 |
fheight | protected | integer | 高度 |
_wapi | public | tswin32api | win32宏定义,以及api接口 | static
_tag | public | any | 调用者使用的成员变量 |
alnone | public | constant | 不对齐 | static
altop | public | constant | 上 | static
albottom | public | constant | 下 | static
alleft | public | constant | 左对齐 | static
alright | public | constant | 右对齐 | static
alclient | public | constant | 占满 | static
aktop | public | constant | 上 | static
akleft | public | constant | 左 | static
akright | public | constant | 右 | static
akbottom | public | constant | 下 | static
mbleft | public | constant | 左键 | static
mbright | public | constant | 右键 | static
mbmiddle | public | constant | 中间按键 | static
ssshift | public | constant | shift | static
ssalt | public | constant | alt | static
ssctrl | public | constant | ctl | static
ssdouble | public | constant | 双击 | static
al9_default | public | constant | 默认 | static
al9_topleft | public | constant | 顶部 | static
al9_center | public | constant | 居 | static
al3_left | public | constant | 左 | static
al3_right | public | constant | 右 | static
al3_center | public | constant | 居中 | static
idc_arrow | public | constant | 类型 | static

继承的函数:
  • appenditem
  • appenditems
  • insertitem
  • deleteitem
  • clean
  • getitems
  • getitemcount
  • getitemtext
  • getcurrentitemtext
  • createalist
  • showdropdown
  • setlistboxrect
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
readonly | public | bool | freadonly | setreadonly |
multisel | public | bool | fmultisel | setmultisel |
checkbox | public | bool | fcheckbox | setcheckbox |
items | public | strings | getitems | setitems |
oneditchanged | public | function[tcombobox,tuieventbase] | foneditchanged | foneditchanged | 文本被改变回调,文本显示后调用
oneditupdate | public | eventhandler | foneditupdate | foneditupdate |
itemindex | public | integer | getitemindex | setitemindex | 设置当前项序号
onselchanged | public | function[tcombobox,tuieventbase] | fonselchanged | fonselchanged | 当前选项改变回调
ondropdown | public | function[tcombobox,tuieventbase] | fondropdown | fondropdown | 下拉框展开回调
oncloseup | public | function[tcombobox,tuieventbase] | foncloseup | foncloseup | 下拉框关闭回调
dropdowncount | public | integer | fmaxlistitemshow | setmaxlistitemshow | 下拉列表项数
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcontrolimagelist

tvclib/tslvcl/tcontrolimagelist

定义:type tcontrolimagelist= class(tcustomcontrolimagelist);
说明:
控件imagleit
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • handlechanged
  • deletecontrol
  • recycling
  • change
  • sethandle
  • handleallocated
  • destroyhandle
  • addbmp
  • addicon
  • draw
  • removeimge
  • replaceimge
  • geticon
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | write | type | describe
handle | public | handleneeded | sethandle | himagelis | imagelist句柄
autodestroy | public | fautodestroy | fautodestroy | bool | 是否销毁句柄
imagecount | public | fimagecount |  | integer | 图标数量
height | public | fheight | setheight | integer |
width | public | fwidth | setwidth | integer |
imgheight | public | fheight | setheight | integer |
imgwidth | public | fwidth | setwidth | integer |
onchange | public | fonchange | fonchange | function[tcustomimagelist] | 改变时的回调
bkcolor | public | fbkcolor | setbkcolor | colorref |
images | public | getimages | setimages | imagesdata |
owner | public | fowner |  | tcomponent | 所有者
componentcreated | public | fcomponentcreated |  | bool | 样式结合
componentstate | public | fcomponentstate | setcomponentstate |  | 状态集合
componentstyle | public | fcomponentstyle |  |  | 样式结合
name | public | fname | setname | string |
ondestroy | public | fondestroy | fondestroy | eventhandler |
onnotification | public | fonnotification | fonnotification | eventhandler |


tcoolbar

tvclib/tslvcl/tcoolbar

定义:type tcoolbar= class(tcustomcoolbar);
说明:
coolbar控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autosize | public | bool | fautosize | setautosize |
arrange | public | lazystr | getarrange | setarrange |
dragbtncolor | public | color | fdragbtncolor | fdragbtncolor |
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcreateprocessa

tvclib/tslvcl/tcreateprocessa

定义:type tcreateprocessa= class();
说明:
进程构造对象
成员函数:
function | private
doonecho | public
createprocesswaitread | public
createprocesswaitreadblockthread | public

propeties:
name | private | read | write | type | describe
onecho | public | fonecho | fonecho | function[tcreateprocessa,s:string] | 程序


tdatetimepicker

tvclib/tslvcl/tdatetimepicker

定义:type tdatetimepicker= class(tthreeentry);
说明:
日期选择控件
成员函数:
function | private
showdropdown | public
getdate | public
setdate | public

propeties:
name | private | type | read | write
onselectchange | public | eventhandler | fonselectchange | fonselectchange
onselchanged | public | eventhandler | fonselectchange | fonselectchange


tdrawgrid

tvclib/tslvcl/tdrawgrid

定义:type tdrawgrid= class(tgridbase);
说明:
自绘制网格
propeties:
name | private | read | write | type | describe
ondodrawsubitem | public | fondodrawsubitem | fondodrawsubitem | function[tdrawgrid,tgridmdrawitem] | 子项绘制

继承的函数:
  • clickedgriditem
  • rclickedgriditem
  • getsubitemrect
  • getitemrect
  • hittestitem
  • deletecolumn
  • insertcolumn
  • deleteallcolumns
  • deleteallitems
  • clean

继承的properties:
name | private | type | read | write
gridline | public | bool | fgridline | setgridline
columnheader | public | bool | fcolumheader | setcolumheader
itemcount | public | integer | getitemcount | setitemcount
oncolumnclick | public | eventhandler | foncolumnclick | foncolumnclick
columns | public | statusitems | getcolumns | setcolumns


tedit

tvclib/tslvcl/tedit

定义:type tedit= class(tcustomedit);
说明:
单行文本编辑框类
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • setsel
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
text | public | string | getentrytext | setentrytext |
onmaxtext | public | fpointer | fonmaxtext | fonmaxtext | 达到文本最大回调
onupdate | public | fpointer | fonupdate | fonupdate | 文本更新回调
onchange | public | fpointer | fonchange | fonchange | 文本改变回调
readonly | public | bool | getreadonly | setreadonly | 只读
limitlength | public | integer | getlimitlength | setlimitlength |
linewrap | public | bool | getlinewrap | setlinewrap | 自动换行,默认为false不自动换行
placeholder | public | string | getplaceholder | setplaceholder |
border | public | bool | getborder | setborder |
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tfolderchooseadlg

tvclib/tslvcl/tfolderchooseadlg

定义:type tfolderchooseadlg= class(tcustomfolderdlg);
说明:
文件夹路径选择对话框
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | write | type | describe
rootfolder | public | frootstr | setrootfold | directory |
folder | public | ffolder |  | string | 文件夹路径
editbox | public | feditbox | seteditbox | bool |
chooseok | public | fchooseok |  | bool | 是否执行成功
wndowner | public | fwndowner | fwndowner | twincontrol | 所属窗口
caption | public | fcaption | setcaption | string |
owner | public | fowner |  | tcomponent | 所有者
componentcreated | public | fcomponentcreated |  | bool | 样式结合
componentstate | public | fcomponentstate | setcomponentstate |  | 状态集合
componentstyle | public | fcomponentstyle |  |  | 样式结合
name | public | fname | setname | string |
ondestroy | public | fondestroy | fondestroy | eventhandler |
onnotification | public | fonnotification | fonnotification | eventhandler |


tfontchooseadlg

tvclib/tslvcl/tfontchooseadlg

定义:type tfontchooseadlg= class(tcustomfontdlg);
说明:
字体选择对话框
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
fontinfo | public | array | getfontinfo | setfontinfo | 字体信息数组
chooseok | public | bool | fchooseok |  | 是否执行成功
wndowner | public | twincontrol | fwndowner | fwndowner | 所属窗口
caption | public | string | fcaption | setcaption |
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tform

tvclib/tslvcl/tform

定义:type tform= class(tvcform);
说明:
可能和web全局重名不建议使用
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • menubarheight
  • wmsyscommand
  • wmcommand
  • notification
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onminimize | public | function[self,tuieventbase] | fonminimize | fonminimize | 主菜单
mainmenu | public | tmainmenu | fmainmenu | setmainmenu | 主菜单
minmaxbox | public | bool | fmaxminbox | setmaxminbox |
borderstyle | public | tformborderstyle | fformborderstyle | setformborderstyle |
formicon | public | ticon | getformicon | setformicon |
tray | public | ttray | ftray | settray |
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tgridbase

tvclib/tslvcl/tgridbase

定义:type tgridbase= class(tgridctl);
说明:
表格基础类
成员函数:
function | private
clickedgriditem | protected
rclickedgriditem | protected
getsubitemrect | public
getitemrect | public
hittestitem | public
deletecolumn | public
insertcolumn | public
deleteallcolumns | public
deleteallitems | public
clean | public

propeties:
name | private | type | read | write
gridline | public | bool | fgridline | setgridline
columnheader | public | bool | fcolumheader | setcolumheader
itemcount | public | integer | getitemcount | setitemcount
oncolumnclick | public | eventhandler | foncolumnclick | foncolumnclick
columns | public | statusitems | getcolumns | setcolumns


tgroupbox

tvclib/tslvcl/tgroupbox

定义:type tgroupbox= class(tcustomgroupbox);
说明:
groupbox


timagelistcreateflags

tvclib/tslvcl/timagelistcreateflags

定义:type timagelistcreateflags= class();
说明:
imagelist 构造的参数


timagelistdrawstyle

tvclib/tslvcl/timagelistdrawstyle

定义:type timagelistdrawstyle= class();
说明:
imagelist 绘制的样式选择


tinifileexta

tvclib/tslvcl/tinifileexta

定义:type tinifileexta= class(tinifileexter);
说明:
ini文件读写封装
成员函数:
function | private
create | public

继承的函数:
  • create
  • readsection
  • readsections
  • readsectionvalues
  • renamesection
  • renamekey
  • readsectionvalues2
  • readsectionvalues3
  • readkey
  • writekey
  • erasesection


tipaddr

tvclib/tslvcl/tipaddr

定义:type tipaddr= class(tcustomipaddr);
说明:
ip控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • cleanaddr
  • setrange
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
hasport | public | bool | fhasport | sethasport |
ipaddr | public | string | getaddress | setaddress | ip地址
onaddrchanged | public | function[tipaddr,tuieventbase] | faddrchange | faddrchange | id地址变化回调
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tlabel

tvclib/tslvcl/tlabel

定义:type tlabel= class(tcustomlabel);
说明:
标签控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • canvasdrawaligntext
  • realsettext
  • paint
  • invalidaterect
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
textalign | public | member of talignstyle9 | ftextalign | settextalign | 文字对齐
onpaint | public | function[tgraphiccontrol]:bool | fonpaint | fonpaint | 绘制回调,返回true不执行默认绘制
transparent | public | bool | ftransparent | settransparent |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tlistbox

tvclib/tslvcl/tlistbox

定义:type tlistbox= class(tcustomlistbox);
说明:
listbox控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • paintidx
  • getcurrentselection
  • setcurrentselection
  • getitemselectedstate
  • setitemselectedstate
  • appenditem
  • appenditems
  • insertitem
  • insertitems
  • deleteitem
  • deleteitems
  • deleteselecteditems
  • getselectedindexes
  • getitem
  • getitemtext
  • checklistitem
  • paintidx
  • getidxrect
  • insureidxinclient
  • getclientidxs
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
itemheight | public | integer | getyscrolldelta | setitemheight |
itemcount | public | integer | getitemcount | setitemcount |
multisel | public | bool | fmultisel | setmultisel |
checkbox | public | bool | fcheckbox | setcheckbox |
selbkcolor | public | color | fselbkcolor | setselbkcolor |
onselchanged | public | eventhandler | fselectionchange | fselectionchange |
ondrawlist | public | eventhandler | fondrawlist | fondrawlist |
items | public | strings | getdata | setdata |
itemindex | public | tsl | getcurrentselection | setcurrentselection |
ownerdraw | public | bool | fownerdraw | setownerdraw |
itemcount | public | integer | getitemcount | setitemcount | 项数量
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tlistview

tvclib/tslvcl/tlistview

定义:type tlistview= class(tdrawgrid);
说明:
listview控件
成员函数:
function | private
menus | public
deleteallitems | public
griddrawitem | public
setselectedvalue | public
clickedgriditem | protected
rclickedgriditem | protected
moveup | public
movedown | public
deletebyid | public
finditemid | public
deletebyvalue | public
deleteselect | public
checkitem | public
insertitem | public
appenditem | public
setsubitem | public
setsubitembyindex | public
getitem | public
setitem | public
appenditems | public
dodrawsubitem | public
setselectedbyvalue | public
columnasbool | public
unselected | public

propeties:
name | private | read | write | type | describe
onselchanged | public | fselectedchanged | fselectedchanged | function[tlistview] | 选中改变回调
selectedid | public | fselected | setselected | integer | 当前选中的序号,<0表示没有选中项
prevselectedid | public | fprevselectedid |  | integer | 选择切换前面的选中id
selectedvalue | public | getselected |  | any | 选中项的值
selbkcolor | public | fselbkcolor | fselbkcolor | integer | 颜色rgb值
mouseonbkcolor | public | fmouseonbkcolor | fmouseonbkcolor | integer | 颜色rgb值
listvalues | public | getlistvalues |  | array | 数据
oncheckitem | public | foncheckitem | foncheckitem | function[any]:bool | 添加数据时的检测的回调

继承的函数:
  • clickedgriditem
  • rclickedgriditem
  • getsubitemrect
  • getitemrect
  • hittestitem
  • deletecolumn
  • insertcolumn
  • deleteallcolumns
  • deleteallitems
  • clean

继承的properties:
name | private | read | write | type | describe
ondodrawsubitem | public | fondodrawsubitem | fondodrawsubitem | function[tdrawgrid,tgridmdrawitem] | 子项绘制
gridline | public | fgridline | setgridline | bool |
columnheader | public | fcolumheader | setcolumheader | bool |
itemcount | public | getitemcount | setitemcount | integer |
oncolumnclick | public | foncolumnclick | foncolumnclick | eventhandler |
columns | public | getcolumns | setcolumns | statusitems |


tlogincontrol

tvclib/tslvcl/tlogincontrol

定义:type tlogincontrol= class(tpanel);
说明:
登陆控件
成员函数:
function | private
getloginstatus | public

propeties:
name | private | type | read | write | describe
port | public | string | getport | setport | 端口号
ip | public | string | getip | setip | 天软服务器
usrname | public | string | getusrname | setusrname | 天软用户名
onlogined | public | function[tlogincontrol,tuieventbase] | fonlogined | fonlogined | 登陆回调

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tmainmenu

tvclib/tslvcl/tmainmenu

定义:type tmainmenu= class(tcustommainmenu);
说明:
主窗口菜单
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getactionlinkclass
  • handleneeded
  • sinit
  • dispatch
  • handleallocated
  • destroyhandle
  • createmenu
  • createhandle
  • recycling
  • removefromparent
  • indexof
  • getitembyindex
  • setmenuiteminfo
  • insertitem
  • removeitembyindex
  • recyclingallitems
  • removeitem
  • setchangedpublish
  • menuchanged
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe | index
hwnd | public |  | fwndhandle | setwndhandle | 窗口句柄 |
action | public | taction | getaction | setaction | action对象 |
caption | public | string | fcaption | setcaption | 菜单显示文字 |
enabled | public | bool | fenabled | setenabled |  |
itemcount | public | integer | getitemcount |  | 菜单子项个数 |
handle | public | pointer | handleneeded |  | 菜单句柄 |
parent | public | tcustommenu|nil | fparent | setparentforproperty | 添加父节点,如果非tmenu,从父节点移除 |
command | public | integer | fcommand |  | 菜单id |
bitmap | public | tbitmap | fbitmap | setbitmap |  |
onclick | public | function[tcustommenu,tuieventbase] | fonclick | fonclick | 菜单点击回调函数 |
tseparator | public | bool | getmenutype | setmenutype |  | 0x800
townerdraw | public | bool | getmenutype | setmenutype |  | 0x100
checked | public | bool | fchecked | setchecked |  |
ondrawitem | public | function[tcustommenu,tmdrawitem] | fondrawitem | fondrawitem | 自绘制菜单回调函数 |
onmeasureitem | public | function[tcustommenu,tmmeasureitem] | fonmeasureitem | fonmeasureitem | 自绘制菜单高度宽度设置回调函数 |
onselect | public | function[tcustommenu,tmmenuselect] | fonselect | fonselect | 菜单被鼠标选中回调函数 |
oninitmenupopup | public | function[tcustommenu,tuieventbase] | foninitmenupopup | foninitmenupopup | 进入菜单循环菜单回调函数 |
onrbuttonup | public | function[tcustommenu,tuieventbase] | fonrbuttonup | fonrbuttonup | 菜单右击回调函数 |
owner | public | tcomponent | fowner |  | 所有者 |
componentcreated | public | bool | fcomponentcreated |  | 样式结合 |
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合 |
componentstyle | public |  | fcomponentstyle |  | 样式结合 |
name | public | string | fname | setname |  |
ondestroy | public | eventhandler | fondestroy | fondestroy |  |
onnotification | public | eventhandler | fonnotification | fonnotification |  |


tmemo

tvclib/tslvcl/tmemo

定义:type tmemo= class(tsynmemonorm);
uses:
  • utslmemo

说明:
多行文本控件
propeties:
name | private | read | write | type | describe
onupdate | public | fonchange | fonchange | fpointer | 文本更新回调
onchange | public | fonchange | fonchange | fpointer | 文本改变回调
linewrap | public | flinewrap | flinewrap | bool | 自动换行,默认为false不自动换行


tmenu

tvclib/tslvcl/tmenu

定义:type tmenu= class(tcustommenu);
说明:
菜单
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getactionlinkclass
  • handleneeded
  • sinit
  • dispatch
  • handleallocated
  • destroyhandle
  • createmenu
  • createhandle
  • recycling
  • removefromparent
  • indexof
  • getitembyindex
  • setmenuiteminfo
  • insertitem
  • removeitembyindex
  • recyclingallitems
  • removeitem
  • setchangedpublish
  • menuchanged
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe | index
action | public | taction | getaction | setaction | action对象 |
caption | public | string | fcaption | setcaption | 菜单显示文字 |
enabled | public | bool | fenabled | setenabled |  |
itemcount | public | integer | getitemcount |  | 菜单子项个数 |
handle | public | pointer | handleneeded |  | 菜单句柄 |
parent | public | tcustommenu|nil | fparent | setparentforproperty | 添加父节点,如果非tmenu,从父节点移除 |
command | public | integer | fcommand |  | 菜单id |
bitmap | public | tbitmap | fbitmap | setbitmap |  |
onclick | public | function[tcustommenu,tuieventbase] | fonclick | fonclick | 菜单点击回调函数 |
tseparator | public | bool | getmenutype | setmenutype |  | 0x800
townerdraw | public | bool | getmenutype | setmenutype |  | 0x100
checked | public | bool | fchecked | setchecked |  |
ondrawitem | public | function[tcustommenu,tmdrawitem] | fondrawitem | fondrawitem | 自绘制菜单回调函数 |
onmeasureitem | public | function[tcustommenu,tmmeasureitem] | fonmeasureitem | fonmeasureitem | 自绘制菜单高度宽度设置回调函数 |
onselect | public | function[tcustommenu,tmmenuselect] | fonselect | fonselect | 菜单被鼠标选中回调函数 |
oninitmenupopup | public | function[tcustommenu,tuieventbase] | foninitmenupopup | foninitmenupopup | 进入菜单循环菜单回调函数 |
onrbuttonup | public | function[tcustommenu,tuieventbase] | fonrbuttonup | fonrbuttonup | 菜单右击回调函数 |
owner | public | tcomponent | fowner |  | 所有者 |
componentcreated | public | bool | fcomponentcreated |  | 样式结合 |
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合 |
componentstyle | public |  | fcomponentstyle |  | 样式结合 |
name | public | string | fname | setname |  |
ondestroy | public | eventhandler | fondestroy | fondestroy |  |
onnotification | public | eventhandler | fonnotification | fonnotification |  |


tmessageboxadlg

tvclib/tslvcl/tmessageboxadlg

定义:type tmessageboxadlg= class(tcustommsgadlg);
说明:
消息提示框
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
mbtext | public | string | fmbtext | setmbtext | 字符串
mbbtnstyle | public | tmbbtnstyle | fbtnval | setmbbtnstyle | 按钮样式
mbiconstyle | public | tmbiconstyle | ficonval | setmbiconstyle | 图标样式
chooseok | public | bool | fchooseok |  | 是否执行成功
wndowner | public | twincontrol | fwndowner | fwndowner | 所属窗口
caption | public | string | fcaption | setcaption |
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tmonthcalendar

tvclib/tslvcl/tmonthcalendar

定义:type tmonthcalendar= class(tcustomcontrol);
说明:
月历控件
该控件的函数可能的返回值：
array等期望的数据/1：成功。
-1：一般是函数参数格式不正确。
nil：该项属性在控件种类正确、窗口未创建、无默认值的情况下未设置过或被重置过。
0：失败，可能的原因：
1.参数格式正确但不适用于控件的当前状态，如对多选月历设置当前选择项时项数超过其最大多选项数限制。
2.控件类型错误，如对单选月历调用设置其最大多选项数限制的函数。
3.要求控件创建后才可调用的函数在控件创建之前被调用。
4.未知错误。
成员函数:
function | private
getcurrentselection | public
setcurrentselection | public

propeties:
name | private | read | write | type | describe
todaybutton | public | getnotodaybutton | setnotodaybutton | bool | 月历显示“今日”按钮（默认开启）
onselect | public | fonselect | fonselect | eventhandler |
onselchanged | public | fonselectchange | fonselectchange | function[tmonthcalendar,tuieventbase] | 选择日期改变

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tmyarraya

tvclib/tslvcl/tmyarraya

定义:type tmyarraya= class(tstrindexarray);
说明:
数组类型忽略字符串下标的大小写
继承的函数:
  • deleteindex
  • size
  • toarray
  • indexnames
  • haveindex
  • trueindex


tmyarrayb

tvclib/tslvcl/tmyarrayb

定义:type tmyarrayb= class(tnumindexarray);
说明:
数字下标数组对象
继承的函数:
  • create
  • operator [1]
  • operator []
  • length
  • push
  • pop
  • splice
  • shift
  • unshift
  • swap

继承的properties:
name | private | read | type | describe
data | public | fdata | array | 数据


topenfileadlg

tvclib/tslvcl/topenfileadlg

定义:type topenfileadlg= class(tcustomfsdlg);
说明:
打开文件对话框类
继承的变量:
name | private | type | describe | static
ffiletag | protected | ttagofna | openfile 对象 |
_wapi | public | tswin32api | win32宏定义,以及api接口 | static
_tag | public | any | 调用者使用的成员变量 |
alnone | public | constant | 不对齐 | static
altop | public | constant | 上 | static
albottom | public | constant | 下 | static
alleft | public | constant | 左对齐 | static
alright | public | constant | 右对齐 | static
alclient | public | constant | 占满 | static
aktop | public | constant | 上 | static
akleft | public | constant | 左 | static
akright | public | constant | 右 | static
akbottom | public | constant | 下 | static
mbleft | public | constant | 左键 | static
mbright | public | constant | 右键 | static
mbmiddle | public | constant | 中间按键 | static
ssshift | public | constant | shift | static
ssalt | public | constant | alt | static
ssctrl | public | constant | ctl | static
ssdouble | public | constant | 双击 | static
al9_default | public | constant | 默认 | static
al9_topleft | public | constant | 顶部 | static
al9_center | public | constant | 居 | static
al3_left | public | constant | 左 | static
al3_right | public | constant | 右 | static
al3_center | public | constant | 居中 | static
idc_arrow | public | constant | 类型 | static

继承的函数:
  • getselecteditemname
  • choosedlg
  • getresults
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
filter | public | array | ffilter | setfilter | array("所有文件":"*.*","tsl流文件":"*.stm")
filename | public | string | getresult |  | 文件名,不成功返回上一次的结果。
defaultfileextension | public | string | getdefaultfileextension | setdefaultfileextension | 默认扩展名，当文件名输入框中未指定扩展名且未选择保存类型时将使用该扩展名，用于保存对话框。
initialdir | public | string | getinitialdir | setinitialdir | 默认打开路径
showhidden | public | bool | fisshowhidden | setshowhidden | 是否强制显示隐藏文件。
multiselected | public | bool | fismultiselected | setmultiselected | 可多选，用于打开对话框。
overwriteprompt | public | bool | fisoverwriteprompt | setoverwriteprompt | 开启覆盖保存提醒，用于保存对话框。
linkfilepath | public | bool | fislinkfilepath | setlinkfilepath | 若所选为快捷方式文件则返回该文件本身路径；默认返回其指向文件的路径。
filemustexist | public | bool | fisfilemustexist | setfilemustexist | 若在文件名输入框中输入不存在的文件名则提示文件名不存在；默认则不提示而直接返回路径，用于打开对话框。
createprompt | public | bool | fiscreateprompt | setcreateprompt | 若在文件名输入框中输入不存在的文件名则提示是否创建；默认则不提示而直接返回路径，用于打开对话框。
chooseok | public | bool | fchooseok |  | 是否执行成功
wndowner | public | twincontrol | fwndowner | fwndowner | 所属窗口
caption | public | string | fcaption | setcaption |
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tpagecontrol

tvclib/tslvcl/tpagecontrol

定义:type tpagecontrol= class(tcustompagecontrol);
说明:
page控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getsheetrect
  • getpageid
  • settabtext
  • settabindex
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
cursel | public | integer | fcurrentid | setcursel | 当前选中序号
onselchanged | public | eventhandler | fonselchanged | fonselchanged |
onselchanging | public | function[tcustompagecontrol,tuieventbase] | fonselchanging | fonselchanging | 标签正在切换
tabcount | public | integer | gettabcount |  | page数量
tabposition | public | tabalign | ftabposition | settabposition |
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tpairsplitter

tvclib/tslvcl/tpairsplitter

定义:type tpairsplitter= class(tcustomcontrol);
说明:
分割控件
成员函数:
function | private
docontrolalign | public

propeties:
name | private | type | read | write | describe
position | public | integer | getposition | setposition | 分割线位置
splittertype | public | menuber of tpairsplittertype | fsplittertype | setsplittertype | 分割线位置

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tpairsplitterside

tvclib/tslvcl/tpairsplitterside

定义:type tpairsplitterside= class(tcustomcontrol);
说明:
分开控件side窗口
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tpanel

tvclib/tslvcl/tpanel

定义:type tpanel= class(tscrollingwincontrol);
说明:
面板控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tpanelform

tvclib/tslvcl/tpanelform

定义:type tpanelform= class(tpanel);
说明:
面板窗口 ,在设计器中使用
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tpassword

tvclib/tslvcl/tpassword

定义:type tpassword= class(tcustompassword);
说明:
密码编辑框类
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • setsel
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
passwordchar | public | string | getpasswordchar | setpasswordchar |
text | public | string | getentrytext | setentrytext |
onmaxtext | public | fpointer | fonmaxtext | fonmaxtext | 达到文本最大回调
onupdate | public | fpointer | fonupdate | fonupdate | 文本更新回调
onchange | public | fpointer | fonchange | fonchange | 文本改变回调
readonly | public | bool | getreadonly | setreadonly | 只读
limitlength | public | integer | getlimitlength | setlimitlength |
linewrap | public | bool | getlinewrap | setlinewrap | 自动换行,默认为false不自动换行
placeholder | public | string | getplaceholder | setplaceholder |
border | public | bool | getborder | setborder |
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tpopupmenu

tvclib/tslvcl/tpopupmenu

定义:type tpopupmenu= class(tcustompopupmenu);
说明:
弹出菜单
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getactionlinkclass
  • handleneeded
  • sinit
  • dispatch
  • handleallocated
  • destroyhandle
  • createmenu
  • createhandle
  • recycling
  • removefromparent
  • indexof
  • getitembyindex
  • setmenuiteminfo
  • insertitem
  • removeitembyindex
  • recyclingallitems
  • removeitem
  • setchangedpublish
  • menuchanged
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe | index
action | public | taction | getaction | setaction | action对象 |
caption | public | string | fcaption | setcaption | 菜单显示文字 |
enabled | public | bool | fenabled | setenabled |  |
itemcount | public | integer | getitemcount |  | 菜单子项个数 |
handle | public | pointer | handleneeded |  | 菜单句柄 |
parent | public | tcustommenu|nil | fparent | setparentforproperty | 添加父节点,如果非tmenu,从父节点移除 |
command | public | integer | fcommand |  | 菜单id |
bitmap | public | tbitmap | fbitmap | setbitmap |  |
onclick | public | function[tcustommenu,tuieventbase] | fonclick | fonclick | 菜单点击回调函数 |
tseparator | public | bool | getmenutype | setmenutype |  | 0x800
townerdraw | public | bool | getmenutype | setmenutype |  | 0x100
checked | public | bool | fchecked | setchecked |  |
ondrawitem | public | function[tcustommenu,tmdrawitem] | fondrawitem | fondrawitem | 自绘制菜单回调函数 |
onmeasureitem | public | function[tcustommenu,tmmeasureitem] | fonmeasureitem | fonmeasureitem | 自绘制菜单高度宽度设置回调函数 |
onselect | public | function[tcustommenu,tmmenuselect] | fonselect | fonselect | 菜单被鼠标选中回调函数 |
oninitmenupopup | public | function[tcustommenu,tuieventbase] | foninitmenupopup | foninitmenupopup | 进入菜单循环菜单回调函数 |
onrbuttonup | public | function[tcustommenu,tuieventbase] | fonrbuttonup | fonrbuttonup | 菜单右击回调函数 |
owner | public | tcomponent | fowner |  | 所有者 |
componentcreated | public | bool | fcomponentcreated |  | 样式结合 |
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合 |
componentstyle | public |  | fcomponentstyle |  | 样式结合 |
name | public | string | fname | setname |  |
ondestroy | public | eventhandler | fondestroy | fondestroy |  |
onnotification | public | eventhandler | fonnotification | fonnotification |  |


tprogressbar

tvclib/tslvcl/tprogressbar

定义:type tprogressbar= class(tcustomprogressbar);
说明:
进度栏
进度栏是显示任务进行完成度的控件。进度栏的上下限是进度条位置可移动的
范围，可以通过range属性获取、修改，其默认值是array(0,100)。进度条的位置可以通过
position属性获取、修改。进度栏的步增量是其每次调用increaseByStep函数进度条
位置移动的量，可以通过step属性获取、修改，其默认值是10.
进度条默认是分段离散的，可通过修改smooth成员设置其为平滑连续的。默认是
水平从左到右移动，可通过修改vertical成员来设置其为垂直从底部到顶部移动。
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • increasebystep
  • increasebyspecifiedincrement
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
smooth | public | bool | fsmooth | setsmooth | 进度条平滑移动
vertical | public | bool | fvertical | setvertical | 进度条垂直移动
range | public | array of integer | frange | setrangea | 进度栏的上下限
position | public | integer | fposition | setposition | 进度条的位置
stepincrement | public | integer | fstep | setstep | 进度栏的步增量
barcolor | public | color | fbarcolor | setindicatorbarcolor |
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tquotations

tvclib/tslvcl/tquotations

定义:type tquotations= class(tcomponent);
说明:
行情订阅以及远程执行类
成员函数:
function | private
remotecallback | protected
remoteexecute | public
marketsubscription | public
dispatch | public
echodata | public
errormessage | public
result | public

propeties:
name | private | type | read | write | describe
oncallback | public | function[tquotations] | foncallback | foncallback | 执行回调
ids | public | array of stockid | fids | fids | 证券代码数组 array("SZ000001","SZ000002")
subs | public | array of string | fsubs | fsubs | 订阅字段数组 array("StockName", "date","price", "open")
globalvariable | public | tsldata | fglobalvariable | fglobalvariable |
script | public | text | fscript | fscript |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tradiobtn

tvclib/tslvcl/tradiobtn

定义:type tradiobtn= class(tcustomradiobtn);
说明:
radiobtn单选按钮控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • click
  • dosetfocus
  • dokillfocus
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
checked | public | integer | fcheckstate | setchecked | 勾选状态： 0：未选中。 1：选中。 @param(leftText)(bool)文本是否在左
lefttext | public | bool | flefttext | setlefttext |
textpos | public | member of talignstyle9 | ftextposition | settextposition | 文本位置
pushlike | public | bool | fpushlike | setpushlike | 是否为普通按钮外观
multiline | public | bool | fmultiline | setmultiline | 文本是否为多行显示
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tregkey

tvclib/tslvcl/tregkey

定义:type tregkey= class();
说明:
windows注册表操作类
成员函数:
function | private
getregkeyroot | public
getregkeyuser | public
getregkeymachine | public
getenviromentkey | public
environmentpath | public
openkeya | public
getvaluea | public
setvaluestringa | public
deletevaluea | public
deletekeya | public
deletetreea | public
getvaluenames | public
getsubkeynames | public
sinit | public

propeties:
name | private | read | write | type | describe
handle | public | fhandle | sethandle | pointer | regkey句柄


tsavefileadlg

tvclib/tslvcl/tsavefileadlg

定义:type tsavefileadlg= class(tcustomfsdlg);
说明:
保存文件,获得文件名
继承的变量:
name | private | type | describe | static
ffiletag | protected | ttagofna | openfile 对象 |
_wapi | public | tswin32api | win32宏定义,以及api接口 | static
_tag | public | any | 调用者使用的成员变量 |
alnone | public | constant | 不对齐 | static
altop | public | constant | 上 | static
albottom | public | constant | 下 | static
alleft | public | constant | 左对齐 | static
alright | public | constant | 右对齐 | static
alclient | public | constant | 占满 | static
aktop | public | constant | 上 | static
akleft | public | constant | 左 | static
akright | public | constant | 右 | static
akbottom | public | constant | 下 | static
mbleft | public | constant | 左键 | static
mbright | public | constant | 右键 | static
mbmiddle | public | constant | 中间按键 | static
ssshift | public | constant | shift | static
ssalt | public | constant | alt | static
ssctrl | public | constant | ctl | static
ssdouble | public | constant | 双击 | static
al9_default | public | constant | 默认 | static
al9_topleft | public | constant | 顶部 | static
al9_center | public | constant | 居 | static
al3_left | public | constant | 左 | static
al3_right | public | constant | 右 | static
al3_center | public | constant | 居中 | static
idc_arrow | public | constant | 类型 | static

继承的函数:
  • getselecteditemname
  • choosedlg
  • getresults
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
filter | public | array | ffilter | setfilter | array("所有文件":"*.*","tsl流文件":"*.stm")
filename | public | string | getresult |  | 文件名,不成功返回上一次的结果。
defaultfileextension | public | string | getdefaultfileextension | setdefaultfileextension | 默认扩展名，当文件名输入框中未指定扩展名且未选择保存类型时将使用该扩展名，用于保存对话框。
initialdir | public | string | getinitialdir | setinitialdir | 默认打开路径
showhidden | public | bool | fisshowhidden | setshowhidden | 是否强制显示隐藏文件。
multiselected | public | bool | fismultiselected | setmultiselected | 可多选，用于打开对话框。
overwriteprompt | public | bool | fisoverwriteprompt | setoverwriteprompt | 开启覆盖保存提醒，用于保存对话框。
linkfilepath | public | bool | fislinkfilepath | setlinkfilepath | 若所选为快捷方式文件则返回该文件本身路径；默认返回其指向文件的路径。
filemustexist | public | bool | fisfilemustexist | setfilemustexist | 若在文件名输入框中输入不存在的文件名则提示文件名不存在；默认则不提示而直接返回路径，用于打开对话框。
createprompt | public | bool | fiscreateprompt | setcreateprompt | 若在文件名输入框中输入不存在的文件名则提示是否创建；默认则不提示而直接返回路径，用于打开对话框。
chooseok | public | bool | fchooseok |  | 是否执行成功
wndowner | public | twincontrol | fwndowner | fwndowner | 所属窗口
caption | public | string | fcaption | setcaption |
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tscrollingwincontrol

tvclib/tslvcl/tscrollingwincontrol

定义:type tscrollingwincontrol= class(tcustomscrollcontrol);
说明:
滚动条窗口
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tslcstructure

tvclib/tslvcl/tslcstructure

定义: tslcstructure(data,dsize,pack,ptr);
说明:
结构体排布计算
参数:
name | type | describe
data | array | 结构体信息数组,参考 cstructurelib中 tslarraytocstructcalc
dsize |  |
pack | integer | 对其方式 忽略
ptr |  |

返回值:
type | describe
tslcstructureobj | 内存分布对象


tspinedit

tvclib/tslvcl/tspinedit

定义:type tspinedit= class(tcustomspinedit);
说明:
spinedit控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onincrease | public | function[tcustomspinedit,tuieventbase] | fonincrease | fonincrease | 增加时的回调
ondecrease | public | function[tcustomspinedit,tuieventbase] | fondecrease | fondecrease | 减少时的回调
increment | public | integer | fincrement | setincrement | 增长间隔
minvalue | public | integer | fminvalue | setminvalue | 下界
maxvalue | public | integer | fmaxvalue | setmaxvalue | 上界
value | public | integer | getvalue | setvalue | 值
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tsplitter

tvclib/tslvcl/tsplitter

定义:type tsplitter= class(tcustomsplitter);
说明:
splitter 控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • realsettext
  • paint
  • invalidaterect
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tgraphiccontrol]:bool | fonpaint | fonpaint | 绘制回调,返回true不执行默认绘制
transparent | public | bool | ftransparent | settransparent |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tstatusbar

tvclib/tslvcl/tstatusbar

定义:type tstatusbar= class(tcustomstatusbar);
说明:
状态栏
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • additem
  • deleteitem
  • setitemtext
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
items | public | array | fitems | setitems | 设置项 ,二维数组包括 text ,width 两个字段 array(("text":"abc","width":200),("text":"part2","width":0.4))
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tsyscontrol

tvclib/tslvcl/tsyscontrol

定义:type tsyscontrol= class(twincontrol);
说明:
系统绘制窗口,屏蔽绘制和背景处理,加快速度
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


ttabsheet

tvclib/tslvcl/ttabsheet

定义:type ttabsheet= class(tcustomtabsheet);
说明:
page控件页面
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tthreadworker

tvclib/tslvcl/tthreadworker

定义:type tthreadworker= class(tcustomthreadworker);
uses:
  • uvclthreadworker

说明:
工作线程
继承的函数:
  • operator []
  • operator [1]
  • postmessage

继承的properties:
name | private | read | write | type | describe
onmessage | public | getonmessage | setonmessage | function[tthreadworker,data] | 消息回调
onerror | public | getonerror | setonerror | function[tthreadworker,d] | 子线程启动
onstart | public | getonstart | setonstart | function[tthreadworker] | 子线程启动


ttimepicker

tvclib/tslvcl/ttimepicker

定义:type ttimepicker= class(tthreeentry);
成员函数:
function | private
gettime | public
settime | public

propeties:
name | private | read | write | type
onselchanged | public | fonselectchange | fonselectchange | eventhandler


ttimer

tvclib/tslvcl/ttimer

定义:type ttimer= class(tcustomtimer);
说明:
定时器类,间隔是以毫秒为最小单位
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • timeout
  • start
  • stop
  • recycling
  • _timeproc_
  • sinit
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
interval | public | integer | finterval | setinterval | 设置运行间隔
ontimer | public | funtion[self,tuieventbase] | fontimer | fontimer | 定时调度
enabled | public | bool | fstart | setenabled | 是否已经启动
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


ttlvnactiveevent

tvclib/tslvcl/ttlvnactiveevent

定义:type ttlvnactiveevent= class(tuieventbase);
说明:
listview active 通知消息
继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


ttoolbar

tvclib/tslvcl/ttoolbar

定义:type ttoolbar= class(tcustomtoolbar);
说明:
工具栏控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • addbutton
  • setbtnindex
  • insertbutton
  • deletebutton
  • getitemrect
  • incpaintlock
  • decpaintlock
  • calcheightfixwidth
  • calcwidthfixheight
  • indexofbtn
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
mainmenu | public | tmainmenu | fmainmenu | setmainmenu |
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


ttoolbutton

tvclib/tslvcl/ttoolbutton

定义:type ttoolbutton= class(tcustomtoolbutton);
说明:
工具栏项
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getrect
  • getactionlinkclass
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onclick | public | function[o:ttoolbutton;e:tuieventbase] | fonclick | fonclick | 点击消息
caption | public | string | fcaption | setcaption | 标题
imageid | public | integer | fimageid | setimageid | 图标id
enabled | public | bool | fenabled | setenabled | 是否有效
visible | public | bool | fvisible | setvisible | 是否可见
action | public | taction | getaction | setaction |
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu |
stylesep | public | bool | getstylesep | setstylesep |
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


ttray

tvclib/tslvcl/ttray

定义:type ttray= class(tcomponent);
说明:
托盘类
成员函数:
function | private
notification | public

propeties:
name | private | read | write | type
caption | public | fcaption | setcaption | string
onclick | public | fonclick | fonclick | eventhandler
onmousemove | public | fonmousemove | fonmousemove | eventhandler
icon | public | ficon | seticon | ticon
popupmenu | public | fpopupmenu | fpopupmenu | tpopupmenu

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


ttreectl

tvclib/tslvcl/ttreectl

定义:type ttreectl= class(tcustomtreectl);
说明:
树控件
继承的函数:
  • setsel
  • nodeinlist
  • mouseup

继承的properties:
name | private | read | type | write
checkbox | public | fcheckbox | bool | setcheckbox
hasline | public | fhasline | bool | sethasline
onselchanged | public | fonselchanged | eventhandler | fonselchanged
onselchanging | public | fonselchanging | eventhandler | fonselchanging


ttreectlnode

tvclib/tslvcl/ttreectlnode

定义:type ttreectlnode= class(tcustomtreectlnode);
说明:
树结点
继承的函数:
  • paint
  • mouseup
  • getnodebyindex
  • appendnodestr
  • insertnodestr
  • getindex
  • ancestorisexpand
  • appendnode
  • hasnode
  • deletenode
  • deletechildnode
  • deletenodebyindex
  • deletechildren
  • getlastshownode
  • insertnodes
  • insertnode
  • expand
  • unexpand
  • getshownodes
  • toarray

继承的properties:
name | private | read | write | type | describe
visible | public | fvisible | setvisible | bool | 可见
itemcount | public | getitemcount |  | integer | 子节点数量
hierarchy | public | fhierarchy |  | integer | 层级
expanded | public | getexpanded |  | bool | 是否展开
parent | public | fparent | setparent | tcustomtreectlnode | 父节点
checked | public | fchecked | setchecked | bool | 是否勾选
lastchild | public | getlstchild |  | tcustomtreectlnode | 最后一个子节点
dirtype | public | fdirtype | fdirtype | bool | 目录类型
mousecanchecked | public | fmousecanchecked | fmousecanchecked | bool | 能否使用鼠标点击勾选
modifychildrenchecked | public | fmodifychildrenchecked | fmodifychildrenchecked | bool | 勾选的时候是否修改自己的勾选状态


ttreenode

tvclib/tslvcl/ttreenode

定义:type ttreenode= class(ttreectlnode);
说明:
tree控件节点
成员函数:
function | private
getsibling | public
insertsibling | public
moveup | public
movedown | public
insertnode | public
getnodebyposition | public
getnodecount | public

继承的函数:
  • paint
  • mouseup
  • getnodebyindex
  • appendnodestr
  • insertnodestr
  • getindex
  • ancestorisexpand
  • appendnode
  • hasnode
  • deletenode
  • deletechildnode
  • deletenodebyindex
  • deletechildren
  • getlastshownode
  • insertnodes
  • insertnode
  • expand
  • unexpand
  • getshownodes
  • toarray

继承的properties:
name | private | read | write | type | describe
visible | public | fvisible | setvisible | bool | 可见
itemcount | public | getitemcount |  | integer | 子节点数量
hierarchy | public | fhierarchy |  | integer | 层级
expanded | public | getexpanded |  | bool | 是否展开
parent | public | fparent | setparent | tcustomtreectlnode | 父节点
checked | public | fchecked | setchecked | bool | 是否勾选
lastchild | public | getlstchild |  | tcustomtreectlnode | 最后一个子节点
dirtype | public | fdirtype | fdirtype | bool | 目录类型
mousecanchecked | public | fmousecanchecked | fmousecanchecked | bool | 能否使用鼠标点击勾选
modifychildrenchecked | public | fmodifychildrenchecked | fmodifychildrenchecked | bool | 勾选的时候是否修改自己的勾选状态


ttreeview

tvclib/tslvcl/ttreeview

定义:type ttreeview= class(ttreectl);
说明:
tree控件
成员函数:
function | private
expand | public
collapse | public
switchcollapse | public
insertnodes | public
insertnode | public
deleteitem | public
getitemcount | public
clean | public

propeties:
name | private | read | type | describe | write
rootitem | public | getrootnode | ttreenode | 根节点 |
lazyitems | public | getlazyitems | array | 结构化数据数组 | setlazyitems

继承的函数:
  • setsel
  • nodeinlist
  • mouseup

继承的properties:
name | private | read | type | write
checkbox | public | fcheckbox | bool | setcheckbox
hasline | public | fhasline | bool | sethasline
onselchanged | public | fonselchanged | eventhandler | fonselchanged
onselchanging | public | fonselchanging | eventhandler | fonselchanging


tvcform

tvclib/tslvcl/tvcform

定义:type tvcform= class(tscrollingwincontrol);
说明:
主窗口类
成员函数:
function | private
menubarheight | public
wmsyscommand | public
wmcommand | public
notification | public

propeties:
name | private | type | read | write | describe
onminimize | public | function[self,tuieventbase] | fonminimize | fonminimize | 主菜单
mainmenu | public | tmainmenu | fmainmenu | setmainmenu | 主菜单
minmaxbox | public | bool | fmaxminbox | setmaxminbox |
borderstyle | public | tformborderstyle | fformborderstyle | setformborderstyle |
formicon | public | ticon | getformicon | setformicon |
tray | public | ttray | ftray | settray |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


twincontrolwraper

tvclib/tslvcl/twincontrolwraper

定义:type twincontrolwraper= class(twincontrol);
说明:
包裹window句柄类,继承该类,根据CreateWnd 注释的提示重写该函数
实现其他窗口库(必须含有句柄)和tslvcl库的对象兼容
成员函数:
function | private
wraphandle | protected
createwnd | public

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


twinenviroment

tvclib/tslvcl/twinenviroment

定义:type twinenviroment= class();
说明:
windows环境变量操作
成员函数:
function | private
getpaths | public
appendpath | public
removepath | public


closemainform

tvclib/tslvcl/tapplication/closemainform

定义: public closemainform();
说明:
关闭主窗口


createform

tvclib/tslvcl/tapplication/createform

定义: public createform(classname,varable);
说明:
构造主窗口
参数:
name | type | describe
classname | class of tvcform | 主窗口类
varable |  | tsl变量返回ClassName 构造的窗口对象


initialize

tvclib/tslvcl/tapplication/initialize

定义: public initialize();
说明:
初始化


run

tvclib/tslvcl/tapplication/run

定义: public run();
说明:
运行主循环


showerrormessage

tvclib/tslvcl/tapplication/showerrormessage

定义: public showerrormessage(msg);
说明:
错误提示信息
参数:
name
msg


wmactivateapp

tvclib/tslvcl/tapplication/wmactivateapp

定义: public wmactivateapp(o,e);virtual;
说明:
active处理
参数:
name
o
e


addcolor

tvclib/tslvcl/tcolorbox/addcolor

定义: public addcolor(name,clr);
说明:
在列表框尾部增加指定的颜色
参数:
name | type | describe
name | string | 指定颜色名
clr | tcolor | 指定颜色值


appendcolors

tvclib/tslvcl/tcolorbox/appendcolors

定义: public appendcolors(d);
参数:
name | type | describe
d | array | 包括"value" 和 "color" 两个字段


getcolor

tvclib/tslvcl/tcolorbox/getcolor

定义: public getcolor(n);
说明:
获取指定下标颜色的值
参数:
name | type | describe
n | integer | 指定下标

返回值:
type | describe
tcolor | 颜色值


getcolorname

tvclib/tslvcl/tcolorbox/getcolorname

定义: public getcolorname(n);
说明:
获取指定下标颜色的名字
参数:
name | type | describe
n | integer | 指定下标

返回值:
type | describe
string | 颜色值


addcolor

tvclib/tslvcl/tcolorcombobox/addcolor

定义: public addcolor(name,clr);
说明:
添加颜色
参数:
name
name
clr


appendcolors

tvclib/tslvcl/tcolorcombobox/appendcolors

定义: public appendcolors(d);
参数:
name | type | describe
d | array | 包括"value" 和 "color" 两个字段


clean

tvclib/tslvcl/tcolorcombobox/clean

定义: public clean();
说明:
清空颜色值


getcolorname

tvclib/tslvcl/tcolorcombobox/getcolorname

定义: public getcolorname(id);
说明:
获取颜色
参数:
name | type | describe
id | integer | 序号id

返回值:
type | describe
string | 返回颜色名称


getcolorvalue

tvclib/tslvcl/tcolorcombobox/getcolorvalue

定义: public getcolorvalue(id);
说明:
获取颜色值
参数:
name | type | describe
id | integer | 序号id

返回值:
type | describe
integer | 返回颜色值


getcurrentcolor

tvclib/tslvcl/tcolorcombobox/getcurrentcolor

定义: public getcurrentcolor();
说明:
获得被选中的颜色名称
返回值:
type | describe
integer | 颜色


createprocesswaitread

tvclib/tslvcl/tcreateprocessa/createprocesswaitread

定义: public createprocesswaitread(exe,cmd,hd,exitwithparent);
说明:
执行代码,非阻塞当前线程
参数:
name | type | describe
exe | string | 程序
cmd | string | 命令行
hd | pointer | 句柄,返回
exitwithparent |  |

返回值:
type | describe
integer | 进程退出码


createprocesswaitreadblockthread

tvclib/tslvcl/tcreateprocessa/createprocesswaitreadblockthread

定义: public createprocesswaitreadblockthread(exe,cmd);
说明:
阻塞当前线程等待输出
参数:
name | type | describe
exe | string | 程序
cmd | string | 命令行

返回值:
type | describe
integer | 进程退出码


doonecho

tvclib/tslvcl/tcreateprocessa/doonecho

定义: public doonecho(o,s);virtual;
说明:
打印
参数:
name
o
s


getdate

tvclib/tslvcl/tdatetimepicker/getdate

定义: public getdate();
说明:
获得日期
返回值:
type | describe
array | array(y,m,d)


setdate

tvclib/tslvcl/tdatetimepicker/setdate

定义: public setdate(y,m,d);
说明:
获得日期
参数:
name | type | describe
y | integer | 年
m | integer | 月
d | integer | 日


showdropdown

tvclib/tslvcl/tdatetimepicker/showdropdown

定义: public showdropdown(f);virtual;
说明:
设置弹出框的显示区域
参数:
name
f


clean

tvclib/tslvcl/tgridbase/clean

定义: public clean();
说明:
清空所有项目以及表头


clickedgriditem

tvclib/tslvcl/tgridbase/clickedgriditem

定义: protected clickedgriditem(o,e);virtual;
说明:
点击时处理
参数:
name
o
e


deleteallcolumns

tvclib/tslvcl/tgridbase/deleteallcolumns

定义: public deleteallcolumns();virtual;
说明:
删除所有列


deleteallitems

tvclib/tslvcl/tgridbase/deleteallitems

定义: public deleteallitems();virtual;
说明:
清空内容


deletecolumn

tvclib/tslvcl/tgridbase/deletecolumn

定义: public deletecolumn(i);virtual;
说明:
删除某列
参数:
name
i


getitemrect

tvclib/tslvcl/tgridbase/getitemrect

定义: public getitemrect(id);override;
说明:
获得行的区域
参数:
name
id

返回值:
type | describe
array | array(左,上,右,下);


getsubitemrect

tvclib/tslvcl/tgridbase/getsubitemrect

定义: public getsubitemrect(i,j);override;
说明:
获得子项的区域
参数:
name
i
j

返回值:
type | describe
array | array(左,上,右,下);


hittestitem

tvclib/tslvcl/tgridbase/hittestitem

定义: public hittestitem(x,y);
说明:
位置命中 测试
参数:
name
x
y


insertcolumn

tvclib/tslvcl/tgridbase/insertcolumn

定义: public insertcolumn(txt,wd,idx);virtual;
说明:
插入列
参数:
name | type | describe
txt | string | 标题
wd | integer | 宽度
idx | integer | 插入在序号之前


rclickedgriditem

tvclib/tslvcl/tgridbase/rclickedgriditem

定义: protected rclickedgriditem(o,e);virtual;
说明:
点击时处理
参数:
name
o
e


create

tvclib/tslvcl/tinifileexta/create

定义: public create(al,fname);
说明:
构造函数
参数:
name | type | describe
al | string | 别名
fname |  |


appenditem

tvclib/tslvcl/tlistview/appenditem

定义: public appenditem(v);virtual;
说明:
追加项
参数:
name
v


appenditems

tvclib/tslvcl/tlistview/appenditems

定义: public appenditems(arr);
参数:
name | type | describe
arr | array | 项数组


checkitem

tvclib/tslvcl/tlistview/checkitem

定义: public checkitem(v);virtual;
说明:
检查项目
参数:
name
v


clickedgriditem

tvclib/tslvcl/tlistview/clickedgriditem

定义: protected clickedgriditem(o,e);override;
说明:
点击时处理
参数:
name
o
e


columnasbool

tvclib/tslvcl/tlistview/columnasbool

定义: public columnasbool(n,f,ce);
参数:
name | type | describe
n | integer | 列号
f | bool | 取消或者设置,默认为true
ce | bool | 是否可以编辑


deleteallitems

tvclib/tslvcl/tlistview/deleteallitems

定义: public deleteallitems();override;
说明:
清空内容


deletebyid

tvclib/tslvcl/tlistview/deletebyid

定义: public deletebyid(id);
说明:
根据 序号删除项目
参数:
name
id


deletebyvalue

tvclib/tslvcl/tlistview/deletebyvalue

定义: public deletebyvalue(v);virtual;
说明:
根据 值删除
参数:
name
v


deleteselect

tvclib/tslvcl/tlistview/deleteselect

定义: public deleteselect();
说明:
删除选中项


dodrawsubitem

tvclib/tslvcl/tlistview/dodrawsubitem

定义: public dodrawsubitem(o,e);override;
说明:
绘制子项
参数:
name
o
e


finditemid

tvclib/tslvcl/tlistview/finditemid

定义: public finditemid(v);virtual;
说明:
根据类容查找序号
参数:
name
v

返回值:
type | describe
integer | 序号 ,没找到返回 -1


getitem

tvclib/tslvcl/tlistview/getitem

定义: public getitem(idx);
说明:
获得项
参数:
name | type | describe
idx | integer | 序号


griddrawitem

tvclib/tslvcl/tlistview/griddrawitem

定义: public griddrawitem(id);
说明:
绘制第id项
参数:
name
id


insertitem

tvclib/tslvcl/tlistview/insertitem

定义: public insertitem(v,id);virtual;
说明:
在序号id处面插入项目
参数:
name | describe | type
v | 待插入的项目 |
id | 插入位置 | integer


menus

tvclib/tslvcl/tlistview/menus

定义: public menus();virtual;
说明:
返回菜单数组
返回值:
type | describe
array | array(("type":"menu","caption":"删除") ,("type":"menu","caption":"添加"))


movedown

tvclib/tslvcl/tlistview/movedown

定义: public movedown();
说明:
选中项下移


moveup

tvclib/tslvcl/tlistview/moveup

定义: public moveup();
说明:
选中项上移


rclickedgriditem

tvclib/tslvcl/tlistview/rclickedgriditem

定义: protected rclickedgriditem(o,e);override;
说明:
点击时处理
参数:
name
o
e


setitem

tvclib/tslvcl/tlistview/setitem

定义: public setitem(idx,v);virtual;
说明:
修改值
参数:
name | type | describe
idx | integer | 序号
v | any | 任何数据


setselectedbyvalue

tvclib/tslvcl/tlistview/setselectedbyvalue

定义: public setselectedbyvalue(v);virtual;
说明:
通过值确定选中项
参数:
name
v


setselectedvalue

tvclib/tslvcl/tlistview/setselectedvalue

定义: public setselectedvalue(v);
说明:
设置选中项目
参数:
name
v


setsubitem

tvclib/tslvcl/tlistview/setsubitem

定义: public setsubitem(idx,subid,v);
说明:
设置子项
参数:
name | type | describe
idx |  |
subid | string|integer | 下标
v | any | 值


setsubitembyindex

tvclib/tslvcl/tlistview/setsubitembyindex

定义: public setsubitembyindex(idx,subidx,v);
说明:
通过序号设置子项
参数:
name | type | describe
idx |  |
subidx |  |
v | any | 值


unselected

tvclib/tslvcl/tlistview/unselected

定义: public unselected();
说明:
取消选择


getloginstatus

tvclib/tslvcl/tlogincontrol/getloginstatus

定义: public getloginstatus();
说明:
获得登陆状态
返回值:
type | describe
bool | true 已经登陆 false 未登陆


getcurrentselection

tvclib/tslvcl/tmonthcalendar/getcurrentselection

定义: public getcurrentselection();
说明:
获取当前选择的日期，该函数仅能用于单选的月历控件
返回值:
type | describe
array/integer/nil | array:成功;0:失败;nil:未设置过此项。 array(2019,2,1)


setcurrentselection

tvclib/tslvcl/tmonthcalendar/setcurrentselection

定义: public setcurrentselection(y,m,d);
说明:
设置当前选择日期，该函数仅能用于单选的月历控件
参数:
name | type | describe
y | integer | 年
m | integer | 月
d | integer | 日

返回值:
type | describe
integer | 1:成功;0:失败;-1:出错


docontrolalign

tvclib/tslvcl/tpairsplitter/docontrolalign

定义: public docontrolalign();override;
说明:
对齐调整


dispatch

tvclib/tslvcl/tquotations/dispatch

定义: public class dispatch(dt);
说明:
消息分发
参数:
name
dt


echodata

tvclib/tslvcl/tquotations/echodata

定义: public echodata();
说明:
获取echo 的信息
返回值:
type | describe
string|nil | 非echo 类型返回nil


errormessage

tvclib/tslvcl/tquotations/errormessage

定义: public errormessage();
说明:
获取错误的信息
返回值:
type | describe
string|nil | 无错误返回nil


marketsubscription

tvclib/tslvcl/tquotations/marketsubscription

定义: public marketsubscription();
说明:
构造行情订阅
返回值:
type | describe
integer | channel


remotecallback

tvclib/tslvcl/tquotations/remotecallback

定义: protected remotecallback(d);virtual;
说明:
回调执行
参数:
name
d


remoteexecute

tvclib/tslvcl/tquotations/remoteexecute

定义: public remoteexecute();
说明:
远程执行代码
返回值:
type | describe
integer | channel


result

tvclib/tslvcl/tquotations/result

定义: public result();
说明:
获取执行结果


deletekeya

tvclib/tslvcl/tregkey/deletekeya

定义: public deletekeya(vn);
说明:
key
参数:
name | type | describe
vn | string | key


deletetreea

tvclib/tslvcl/tregkey/deletetreea

定义: public deletetreea(vn);
说明:
删除目录
参数:
name | type | describe
vn | string | 目录名


deletevaluea

tvclib/tslvcl/tregkey/deletevaluea

定义: public deletevaluea(vn);
说明:
删除value
参数:
name | type | describe
vn | string | value 名字


environmentpath

tvclib/tslvcl/tregkey/environmentpath

定义: public class environmentpath(k2);
说明:
获得环境路径的所有值
参数:
name
k2

返回值:
type | describe
array of string | 环境路径数组


getenviromentkey

tvclib/tslvcl/tregkey/getenviromentkey

定义: public class getenviromentkey();
说明:
获得环境变量的key
返回值:
type | describe
tregkey|integer | 如果成功返回 key 对象


getregkeymachine

tvclib/tslvcl/tregkey/getregkeymachine

定义: public class getregkeymachine();
说明:
获得HKEY_LOCAL_MACHINE的key
返回值:
type | describe
tregkey|integer | 如果成功返回 key 对象


getregkeyroot

tvclib/tslvcl/tregkey/getregkeyroot

定义: public class getregkeyroot();
说明:
获得HKEY_CLASSES_ROOT的key
返回值:
type | describe
tregkey|integer | 如果成功返回 key 对象


getregkeyuser

tvclib/tslvcl/tregkey/getregkeyuser

定义: public class getregkeyuser();
说明:
获得HKEY_CURRENT_USER的key
返回值:
type | describe
tregkey|integer | 如果成功返回 key 对象


getsubkeynames

tvclib/tslvcl/tregkey/getsubkeynames

定义: public getsubkeynames();
说明:
获得子项的名称
返回值:
type | describe
array of string | 所有名称


getvaluea

tvclib/tslvcl/tregkey/getvaluea

定义: public getvaluea(vn,vt);
说明:
获得value值
参数:
name | type | describe
vn | string | value 名字
vt | integer | 类型

返回值:
type | describe
string | 值


getvaluenames

tvclib/tslvcl/tregkey/getvaluenames

定义: public getvaluenames();
说明:
获得value的名称
返回值:
type | describe
array of string | 所有名称


openkeya

tvclib/tslvcl/tregkey/openkeya

定义: public openkeya(vn);
说明:
打开或者新建 key
参数:
name | type | describe
vn | string | value 名字

返回值:
type | describe
tregkey | 值


setvaluestringa

tvclib/tslvcl/tregkey/setvaluestringa

定义: public setvaluestringa(vn,v);
说明:
设置value值
参数:
name | type | describe
vn | string | value 名字,nil为默认值
v | string | 值


sinit

tvclib/tslvcl/tregkey/sinit

定义: public class sinit();override;
说明:
初始化


gettime

tvclib/tslvcl/ttimepicker/gettime

定义: public gettime();override;
说明:
获取控件当前选择的时间
返回值:
type | describe
array |


settime

tvclib/tslvcl/ttimepicker/settime

定义: public settime(h,m,s);override;
说明:
设置控件当前选择的时间
参数:
name | type | describe
h | integer | 时，24小时制
m | integer | 分
s | integer | 秒


notification

tvclib/tslvcl/ttray/notification

定义: public notification(acomponent,operation);override;
说明:
通知消息处理
参数:
name | type
acomponent | tcomponent
operation | toperation


getnodebyposition

tvclib/tslvcl/ttreenode/getnodebyposition

定义: public getnodebyposition(id);
参数:
name
id


getnodecount

tvclib/tslvcl/ttreenode/getnodecount

定义: public getnodecount();
说明:
获得当前节点下所有节点数量
返回值:
type | describe
integer |


getsibling

tvclib/tslvcl/ttreenode/getsibling

定义: public getsibling(id);
说明:
获得兄弟节点
参数:
name | type | describe
id | integer | 序号,自己的位置为0


insertnode

tvclib/tslvcl/ttreenode/insertnode

定义: public insertnode(node,bnode);override;
参数:
name | type | describe
node | ttreenode | 待插入节点
bnode | ttreenode|tvi_first|tvi_last | 基准节点


insertsibling

tvclib/tslvcl/ttreenode/insertsibling

定义: public insertsibling(node,ifprev);
说明:
插入兄弟节点
参数:
name | type | describe
node | ttreenode | 待插入节点
ifprev | bool |


movedown

tvclib/tslvcl/ttreenode/movedown

定义: public movedown();virtual;
说明:
节点下移


moveup

tvclib/tslvcl/ttreenode/moveup

定义: public moveup();virtual;
说明:
节点上移
返回值:
type | describe
bool | 是否移动成功


clean

tvclib/tslvcl/ttreeview/clean

定义: public clean();override;
说明:
删除节点并销毁


collapse

tvclib/tslvcl/ttreeview/collapse

定义: public collapse(item);
说明:
收拢节点
参数:
name | type | describe
item | ttreenode | ;


deleteitem

tvclib/tslvcl/ttreeview/deleteitem

定义: public deleteitem(node);
说明:
删除 节点,但是节点不会销毁,请用node.recycling 销毁
参数:
name | type
node | ttreenode


expand

tvclib/tslvcl/ttreeview/expand

定义: public expand(item);
说明:
展开节点
参数:
name | type | describe
item | ttreenode | ;


getitemcount

tvclib/tslvcl/ttreeview/getitemcount

定义: public getitemcount();
说明:
获得item的数量
返回值:
type | describe
integer | 数量


insertnode

tvclib/tslvcl/ttreeview/insertnode

定义: public insertnode(iteminfo,pnode,bnode);
说明:
插入单个节点
参数:
name | type | describe
iteminfo | array | array("type":"treenode","caption":"","imgid":id,"nodes":array()) 节点信息 nodes字段为子节点信息
pnode | ttreenode | 父节点
bnode | ttreenode | 前一个节点


insertnodes

tvclib/tslvcl/ttreeview/insertnodes

定义: public insertnodes(iteminfos,pnode,bnode);
说明:
批量插入节点
参数:
name
iteminfos
pnode
bnode


switchcollapse

tvclib/tslvcl/ttreeview/switchcollapse

定义: public switchcollapse(item);
说明:
切换收拢或者展
参数:
name | type | describe
item | ttreenode | ;


menubarheight

tvclib/tslvcl/tvcform/menubarheight

定义: public class menubarheight();
说明:
获得菜单栏的高度
返回值:
type | describe
integer | 高度


notification

tvclib/tslvcl/tvcform/notification

定义: public notification(acomponent,operation);override;
说明:
通知消息处理
参数:
name | type
acomponent | tcomponent
operation | toperation


wmcommand

tvclib/tslvcl/tvcform/wmcommand

定义: public wmcommand(o,e);override;
说明:
command 消息处理
参数:
name
o
e


wmsyscommand

tvclib/tslvcl/tvcform/wmsyscommand

定义: public wmsyscommand(o,e);override;
说明:
系统菜单消息处理
参数:
name
o
e


createwnd

tvclib/tslvcl/twincontrolwraper/createwnd

定义: public createwnd();override;
说明:
重写该函数构造句柄 包括三部分
//************获得构造参数*************************
CreateParams(p); //构造参数函数
tcc := p.Caption; //标题
stl := p.style;
x := p.x; //下边
y := p.y; //上边
w := p.width;//宽度
h := p.height; //高度
phandle := p.WndParent; //父窗口句柄
//***********构造句柄******************
//****************************************
//***********包裹句柄*************************
WrapHandle(thandle); //包裹句柄
//************初始化*************************
InitializeWnd(); //初始化
ControlCreateWnd(); //构造子窗口句柄


wraphandle

tvclib/tslvcl/twincontrolwraper/wraphandle

定义: protected wraphandle(h);
说明:
包裹句柄,重写 CreateWnd中调用
参数:
name
h


appendpath

tvclib/tslvcl/twinenviroment/appendpath

定义: public appendpath(p);
说明:
追加环境路径
参数:
name | type | describe
p | string | 路径

返回值:
type | describe
bool | true 成功 false 失败


getpaths

tvclib/tslvcl/twinenviroment/getpaths

定义: public getpaths();
说明:
获得环境路径
返回值:
type | describe
array of string | 路径


removepath

tvclib/tslvcl/twinenviroment/removepath

定义: public removepath(p);
说明:
移除环境路径
参数:
name | type | describe
p | string | 路径

返回值:
type | describe
bool | true 成功 false 失败


create

tvclib/tuieventbase/create

定义: public create(m,w,l,h);virtual;
说明:
消息构造
参数:
name | type | describe
m | integer | 消息id
w | pointer | 消息wparam
l | pointer | 消息lparam
h | pointer | 窗口句柄


hilparam

tvclib/tuieventbase/hilparam

定义: public hilparam();
说明:
高字节


hilparamsigned

tvclib/tuieventbase/hilparamsigned

定义: public hilparamsigned();
说明:
高字作为符号数


hiwparam

tvclib/tuieventbase/hiwparam

定义: public hiwparam();
说明:
高字节


hiwparamsigned

tvclib/tuieventbase/hiwparamsigned

定义: public hiwparamsigned();
说明:
高字作为符号数


lolparam

tvclib/tuieventbase/lolparam

定义: public lolparam();
说明:
低字节


lolparamsigned

tvclib/tuieventbase/lolparamsigned

定义: public lolparamsigned();
说明:
低字作为符号数


lowparam

tvclib/tuieventbase/lowparam

定义: public lowparam();
说明:
低字节


lowparamsigned

tvclib/tuieventbase/lowparamsigned

定义: public lowparamsigned();
说明:
低字作为符号数


_send_

tvclib/twincontrol/_send_

定义: public _send_(msg,wparam,lparam,f,d);virtual;
说明:
发送消息给窗口
参数:
name | type | describe
msg | integer | 消息号
wparam | integer | wparam
lparam | integer | lparam
f |  |
d |  |

返回值:
type | describe
pointer |


broadcast

tvclib/twincontrol/broadcast

定义: public broadcast(e);
说明:
广播消息
参数:
name | type
e | tuieventbase


captionheight

tvclib/twincontrol/captionheight

定义: public class captionheight();
说明:
caption的高度
返回值:
type | describe
integer | 高度


clienttowindow

tvclib/twincontrol/clienttowindow

定义: public clienttowindow(x,y);
说明:
客户区坐标到窗口坐标的转换
参数:
name
x
y


createparams

tvclib/twincontrol/createparams

定义: protected createparams(p);virtual;
说明:
构架窗口句柄使用
参数:
name | type | describe
p | var tcreateparams | 变参返回


createwnd

tvclib/twincontrol/createwnd

定义: public createwnd();virtual;
说明:
构建窗口句柄


createwndclass

tvclib/twincontrol/createwndclass

定义: protected createwndclass(p);
说明:
注册窗口类
参数:
name | type | describe
p | tcreateparams | 注册窗口类


defaulthandler

tvclib/twincontrol/defaulthandler

定义: public defaulthandler(e);override;
说明:
执行默认句柄
参数:
name | type
e | tuieventbase


designingclick

tvclib/twincontrol/designingclick

定义: public designingclick();virtual;
说明:
设计模式下面是否可以响应原有的点击消息
返回值:
type | describe
bool |


designingmove

tvclib/twincontrol/designingmove

定义: public designingmove();virtual;
说明:
设计模式下面是否可以移动
返回值:
type | describe
bool |


designingsizer

tvclib/twincontrol/designingsizer

定义: public designingsizer();virtual;
说明:
设计模式下面是否可以调整大小
返回值:
type | describe
bool |


destroyhandle

tvclib/twincontrol/destroyhandle

定义: public destroyhandle();virtual;
说明:
析构窗口句柄


docontrolalign

tvclib/twincontrol/docontrolalign

定义: public docontrolalign();override;
说明:
控件对齐


docontrolanchor

tvclib/twincontrol/docontrolanchor

定义: public docontrolanchor();override;
说明:
控件锚定调整


dokillfocus

tvclib/twincontrol/dokillfocus

定义: public dokillfocus(o,e);virtual;
说明:
控件失去焦点
参数:
name | type | describe
o | twincontrol | 控件自身
e |  |


dosetfocus

tvclib/twincontrol/dosetfocus

定义: public dosetfocus(o,e);virtual;
说明:
控件获得焦点
参数:
name | type | describe
o | twincontrol | 控件自身
e |  |


endmodal

tvclib/twincontrol/endmodal

定义: public endmodal(endc);virtual;
说明:
关闭模态窗口
参数:
name | type | describe
endc | any | 为非nil 将作为EndModalCode


getclientrect

tvclib/twincontrol/getclientrect

定义: public getclientrect();override;
说明:
获得客户区大小
返回值:
type | describe
array of integer | 客户区矩形


handleallocated

tvclib/twincontrol/handleallocated

定义: public handleallocated();
说明:
构建窗口句柄是否构造


handleneeded

tvclib/twincontrol/handleneeded

定义: public handleneeded();virtual;
说明:
构建窗口句柄,以及子控件句柄
返回值:
type | describe
pointer | 窗口句柄


hitcontrol

tvclib/twincontrol/hitcontrol

定义: protected hitcontrol(p);
说明:
命中控件
参数:
name
p


initializewnd

tvclib/twincontrol/initializewnd

定义: protected initializewnd();virtual;
说明:
窗口句柄初始化,在该函数设置窗口句柄的一些信息


invalidaterect

tvclib/twincontrol/invalidaterect

定义: public invalidaterect(rec,f);virtual;
说明:
设置窗口区域无效
参数:
name | type | describe
rec | array | 无效区域,nil表示窗口整体无效,array(左上右下)
f | bool | 是否重画


keydown

tvclib/twincontrol/keydown

定义: public keydown(o,e);virtual;
说明:
key 按下
参数:
name | type | describe
o | twincontrol | 控件自身
e |  |


keypress

tvclib/twincontrol/keypress

定义: public keypress(o,e);virtual;
说明:
char 消息处理
参数:
name | type | describe
o | twincontrol | 控件自身
e |  |


keyup

tvclib/twincontrol/keyup

定义: public keyup(o,e);virtual;
说明:
key 松开
参数:
name | type | describe
o | twincontrol | 控件自身
e |  |


mainwndproc

tvclib/twincontrol/mainwndproc

定义: public mainwndproc(hwnd,message,wparam,lparam);virtual;
说明:
窗口主循环
参数:
name
hwnd
message
wparam
lparam


movecontrolorder

tvclib/twincontrol/movecontrolorder

定义: public movecontrolorder(acomponent,n);
说明:
移动控件的层
参数:
name | type | describe
acomponent | tcontrol | 控件
n | integer | 次序


realsettext

tvclib/twincontrol/realsettext

定义: protected realsettext(value);override;
说明:
设置标题
参数:
name | type | describe
value | string | 标题


setbounds

tvclib/twincontrol/setbounds

定义: public setbounds(aleft,atop,awidth,aheight);override;
说明:
设置窗口矩形区域
参数:
name | type
aleft | integer
atop | integer
awidth | integer
aheight | integer


show

tvclib/twincontrol/show

定义: public show(sw);
说明:
显示窗口
参数:
name | type | describe
sw | nil | 空


sinit

tvclib/twincontrol/sinit

定义: protected class sinit();override;
说明:
初始化


updatewindow

tvclib/twincontrol/updatewindow

定义: public updatewindow();
说明:
刷新窗口客户区
返回值:
type | describe
integer | 非0 成功


wmerasebkgnd

tvclib/twincontrol/wmerasebkgnd

定义: public wmerasebkgnd(o,e);override;
说明:
背景绘制
参数:
name
o
e


wmgetminmaxinfo

tvclib/twincontrol/wmgetminmaxinfo

定义: public wmgetminmaxinfo(o,e);virtual;
说明:
最小窗口设置
参数:
name
o
e


wmnotify

tvclib/twincontrol/wmnotify

定义: public wmnotify(o,e);virtual;
说明:
子控件通知父控件
参数:
name | type | describe
o |  |
e | tmnotify | 通知消息


wnddefaulthandler

tvclib/twincontrol/wnddefaulthandler

定义: public wnddefaulthandler(e);
说明:
win32默认消息处理函数
参数:
name | type
e | tuieventbase


tcustommemo

tvclib/utslmemo/tcustommemo

定义:type tcustommemo= class(tcustomscrollcontrol,tcustommemocmd);
说明:
带滚动条的编辑控件
成员函数:
function | private
executecommand | public

propeties:
name | private | type | read | write | describe
readonly | public | bool | freadonly | setreadolny | 是否只读
text | public | string | getmemotext | setmemotext | 文本
charsinwindow | public | integer | fcharsinwindow |  |
linesinwindow | public | integer | flinesinwindow |  |
blockbegin | public | tpoint | getblockbegin | setblockbegin |
blockend | public | tpoint | getblockend | setblockend |
caretx | public | integer | fcaretx | setcaretx | 光标x坐标
carety | public | integer | fcarety | setcarety | 光标y坐标
caretxy | public | tpoint | getcaretxy | setcaretxy |
seltext | public | string | getseltext | setseltextexternal | 选中的字符串
linetext | public | string | getlinetext | setlinetext | 当前行字符串
guttercharcnt | public | integer | fguttercharcount | setguttercharcnt | 行号的宽度
autogutterwidth | public | bool | fautogutterwidth | setautogutterwidth |
currentlinecolor | public | color | fcurrentlinecolor | setcurrentlinecolor |
guttercolor | public | color | fguttercolor | setguttercolor |
selectbkcolor | public | color | fselectbkcolor | setselectbkcolor |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型
ecgotoxy | public | static |  | 跳转光标到指定位置,对应参数为 array(y,x)
ecselgotoxy | public | static |  | 选中文本到指定位置,对应参数为 array(y,x)
eccopy | public | static |  | 复制选中文本到剪切板,无对应参数
ecpaste | public | static |  | 粘贴剪切板文本,无对应参数
ecstring | public | static |  | 插入字符串,对应参数为 字符串

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustommemocmd

tvclib/utslmemo/tcustommemocmd

定义:type tcustommemocmd= class();
说明:
编辑器控件操作码类
成员变量:
name | private | static | describe
ecgotoxy | public | static | 跳转光标到指定位置,对应参数为 array(y,x)
ecselgotoxy | public | static | 选中文本到指定位置,对应参数为 array(y,x)
eccopy | public | static | 复制选中文本到剪切板,无对应参数
ecpaste | public | static | 粘贴剪切板文本,无对应参数
ecstring | public | static | 插入字符串,对应参数为 字符串


tcustomsynhighlighter

tvclib/utslmemo/tcustomsynhighlighter

定义:type tcustomsynhighlighter= class(tsynhighlighter);
说明:
通用的语法高亮类
支持单行注释,块注释,配对,字符串定义,关键字,符号
成员函数:
function | private
executecommand | public

propeties:
name | private | type | read | write
keywordcolor | public | color | fkeywordcolor | fkeywordcolor
stringcolor | public | color | fstringcolor | fstringcolor
annotationcolor | public | color | fannotationcolor | fannotationcolor
symcolor | public | color | fsymcolor | fsymcolor
ignorecase | public | bool | fignorecase | setignorecase


tsyncompletion

tvclib/utslmemo/tsyncompletion

定义:type tsyncompletion= class(tsyncompletionlist);
说明:
语法提示自动完成


tsyncustommemo

tvclib/utslmemo/tsyncustommemo

定义:type tsyncustommemo= class(tcustommemo);
说明:
语法编辑器
propeties:
name | private | type | read | write
highlighter | public | thighlighter | fhighlighter | sethighlighter

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型
ecgotoxy | public | static |  | 跳转光标到指定位置,对应参数为 array(y,x)
ecselgotoxy | public | static |  | 选中文本到指定位置,对应参数为 array(y,x)
eccopy | public | static |  | 复制选中文本到剪切板,无对应参数
ecpaste | public | static |  | 粘贴剪切板文本,无对应参数
ecstring | public | static |  | 插入字符串,对应参数为 字符串

继承的函数:
  • executecommand
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
readonly | public | bool | freadonly | setreadolny | 是否只读
text | public | string | getmemotext | setmemotext | 文本
charsinwindow | public | integer | fcharsinwindow |  |
linesinwindow | public | integer | flinesinwindow |  |
blockbegin | public | tpoint | getblockbegin | setblockbegin |
blockend | public | tpoint | getblockend | setblockend |
caretx | public | integer | fcaretx | setcaretx | 光标x坐标
carety | public | integer | fcarety | setcarety | 光标y坐标
caretxy | public | tpoint | getcaretxy | setcaretxy |
seltext | public | string | getseltext | setseltextexternal | 选中的字符串
linetext | public | string | getlinetext | setlinetext | 当前行字符串
guttercharcnt | public | integer | fguttercharcount | setguttercharcnt | 行号的宽度
autogutterwidth | public | bool | fautogutterwidth | setautogutterwidth |
currentlinecolor | public | color | fcurrentlinecolor | setcurrentlinecolor |
guttercolor | public | color | fguttercolor | setguttercolor |
selectbkcolor | public | color | fselectbkcolor | setselectbkcolor |
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


executecommand

tvclib/utslmemo/tcustommemo/executecommand

定义: public executecommand(cmd,data);override;
说明:
执行操作
参数:
name | type | describe
cmd | tcustommemocmd | 操作码
data | any | 操作码对应的数据


executecommand

tvclib/utslmemo/tcustomsynhighlighter/executecommand

定义: public executecommand(cmd,pm);override;
说明:
对外接口
参数:
name | type | describe
cmd | string | 命令
pm | array | 参数


tactionlink

tvclib/utslvclaction/tactionlink

定义:type tactionlink= class(tbasicactionlink);
说明:
action与控件连接类
继承的变量:
name | private | type | static | describe
faction | public | tbasicaction |  |
_wapi | public | tswin32api | static | win32宏定义,以及api接口
_tag | public | any |  | 调用者使用的成员变量
alnone | public | constant | static | 不对齐
altop | public | constant | static | 上
albottom | public | constant | static | 下
alleft | public | constant | static | 左对齐
alright | public | constant | static | 右对齐
alclient | public | constant | static | 占满
aktop | public | constant | static | 上
akleft | public | constant | static | 左
akright | public | constant | static | 右
akbottom | public | constant | static | 下
mbleft | public | constant | static | 左键
mbright | public | constant | static | 右键
mbmiddle | public | constant | static | 中间按键
ssshift | public | constant | static | shift
ssalt | public | constant | static | alt
ssctrl | public | constant | static | ctl
ssdouble | public | constant | static | 双击
al9_default | public | constant | static | 默认
al9_topleft | public | constant | static | 顶部
al9_center | public | constant | static | 居
al3_left | public | constant | static | 左
al3_right | public | constant | static | 右
al3_center | public | constant | static | 居中
idc_arrow | public | constant | static | 类型

继承的函数:
  • execute
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
action | public | taction | faction | setaction | action对象
onchange | public | function[sender:tcomponent] | fonchange | fonchange | 改变的回调


tbasicaction

tvclib/utslvclaction/tbasicaction

定义:type tbasicaction= class(tcomponent);
成员变量:
name | type | private | describe
fclients | tfplist of tactionlink | protected | 关联的组件

propeties:
name | private | type | read | write | describe
actioncomponent | public | tcomponent | factioncomponent | setactioncomponent |
onexecute | public | fpointer | fonexecute | setonexecute | 执行回调
onupdate | public | fpointer | fonupdate | fonupdate | 更新回调
onchange | public | fpointer | fonchange | fonchange | 改变回调

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tbasicactionlink

tvclib/utslvclaction/tbasicactionlink

定义:type tbasicactionlink= class(tsluibase);
说明:
基础action component关联类
成员变量:
name | private | type
faction | public | tbasicaction

成员函数:
function | private
execute | public

propeties:
name | private | type | read | write | describe
action | public | taction | faction | setaction | action对象
onchange | public | function[sender:tcomponent] | fonchange | fonchange | 改变的回调

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tcontrolactionlink

tvclib/utslvclaction/tcontrolactionlink

定义:type tcontrolactionlink= class(tactionlink);
说明:
关联tcontrol 和 taction 类
成员变量:
name | type | private
fclient | tcontrol | protected

成员函数:
function | private
assignclient | protected

继承的变量:
name | private | type | static | describe
faction | public | tbasicaction |  |
_wapi | public | tswin32api | static | win32宏定义,以及api接口
_tag | public | any |  | 调用者使用的成员变量
alnone | public | constant | static | 不对齐
altop | public | constant | static | 上
albottom | public | constant | static | 下
alleft | public | constant | static | 左对齐
alright | public | constant | static | 右对齐
alclient | public | constant | static | 占满
aktop | public | constant | static | 上
akleft | public | constant | static | 左
akright | public | constant | static | 右
akbottom | public | constant | static | 下
mbleft | public | constant | static | 左键
mbright | public | constant | static | 右键
mbmiddle | public | constant | static | 中间按键
ssshift | public | constant | static | shift
ssalt | public | constant | static | alt
ssctrl | public | constant | static | ctl
ssdouble | public | constant | static | 双击
al9_default | public | constant | static | 默认
al9_topleft | public | constant | static | 顶部
al9_center | public | constant | static | 居
al3_left | public | constant | static | 左
al3_right | public | constant | static | 右
al3_center | public | constant | static | 居中
idc_arrow | public | constant | static | 类型

继承的函数:
  • execute
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
action | public | taction | faction | setaction | action对象
onchange | public | function[sender:tcomponent] | fonchange | fonchange | 改变的回调


tcustomaction

tvclib/utslvclaction/tcustomaction

定义:type tcustomaction= class(tcontainedaction);
说明:
action类
成员函数:
function | private
assignto | protected
create | public

propeties:
name | private | type | read | write
caption | public | string | fcaption | setcaption
checked | public | bool | fchecked | setchecked
enabled | public | bool | fenabled | setenabled
visible | public | bool | fvisible | setvisible
shortcut | public | string | getshortcut | setshortcut


tcustomactionlist

tvclib/utslvclaction/tcustomactionlist

定义:type tcustomactionlist= class(tcomponent);
说明:
actionlist
成员函数:
function | private
deleteaction | public
addaction | public

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


execute

tvclib/utslvclaction/tbasicactionlink/execute

定义: public execute(acomponent);virtual;
说明:
执行
参数:
name | type
acomponent | tcomponent


assignclient

tvclib/utslvclaction/tcontrolactionlink/assignclient

定义: protected assignclient(aclient);override;
说明:
赋值control
参数:
name | type
aclient | tcontrol


assignto

tvclib/utslvclaction/tcustomaction/assignto

定义: protected assignto(dest);override;
说明:
赋值
参数:
name | type
dest | tpersistent


create

tvclib/utslvclaction/tcustomaction/create

定义: public create(aowner);override;
说明:
构造
参数:
name | type
aowner | tcomponent


addaction

tvclib/utslvclaction/tcustomactionlist/addaction

定义: public addaction(v);
说明:
删除Action
参数:
name | type
v | tbasicaction


deleteaction

tvclib/utslvclaction/tcustomactionlist/deleteaction

定义: public deleteaction(v);
说明:
删除
参数:
name | type
v | tbasicaction


bitcombination

tvclib/utslvclauxiliary/bitcombination

定义: bitcombination(s,v,f);
说明:
bit位组合
参数:
name | type | describe
s | integer | 原有值
v | integer | 追加或者删除
f | integer | 0 为 or ,1 为 and ;2 表示 删除 v的值


createdirwithfilename

tvclib/utslvclauxiliary/createdirwithfilename

定义: createdirwithfilename(fname);
说明:
根据文件全名构造目录
参数:
name
fname


deleteallfiles

tvclib/utslvclauxiliary/deleteallfiles

定义: deleteallfiles(path);
说明:
删除指定路径的文件或者文件夹
参数:
name
path


excludestate

tvclib/utslvclauxiliary/excludestate

定义: excludestate(u,s);
说明:
状态缩减
参数:
name
u
s


formattsldata

tvclib/utslvclauxiliary/formattsldata

定义: formattsldata(d,sj,tn);
说明:
格式化tsl数据
参数:
name | type | describe
d | any | tsl数据
sj | string | 空格距离
tn | nil | 空参数

返回值:
type | describe
string | 格式化后的字符串


getbitsfrominteger

tvclib/utslvclauxiliary/getbitsfrominteger

定义: getbitsfrominteger(n,b,e);
说明:
获取数字的位数并转换为整数
参数:
name | type | describe
n | integer | 数字
b | integer | 开始位
e | integer | 截止位

返回值:
type | describe
integer |


gettemppath

tvclib/utslvclauxiliary/gettemppath

定义: gettemppath();
说明:
获取windows临时目录
返回值:
type | describe
string | 目录;


hexformatstrtotsl

tvclib/utslvclauxiliary/hexformatstrtotsl

定义: hexformatstrtotsl(d);
说明:
将带有换行符的16进制字符串转换为tsl数据
参数:
name
d

返回值:
type | describe
any | tsl数据类型


includestate

tvclib/utslvclauxiliary/includestate

定义: includestate(u,s);
说明:
状态扩展
参数:
name
u
s


intersectrect

tvclib/utslvclauxiliary/intersectrect

定义: intersectrect(rec1,rec2,irec);
说明:
计算矩形的交集
参数:
name | type | describe
rec1 | array of integer | 矩形区域
rec2 | array of integer | 矩形区域
irec | var array of integer | 重叠的区域

返回值:
type | describe
bool |


lowuperdword

tvclib/utslvclauxiliary/lowuperdword

定义: lowuperdword(value_,lvalue,uvalue,ptrl);
说明:
高低位获取
参数:
name | type | describe
value_ | integer | 整数
lvalue | integer | 低位
uvalue | integer | 高位
ptrl | integer | 长度 默认为 8


makelong

tvclib/utslvclauxiliary/makelong

定义: makelong(low,high,ptrl);
说明:
合并高低为
参数:
name | type | describe
low | integer | 低位
high | integer | 高位
ptrl | integer | 长度 默认为 8

返回值:
type | describe
integer | 整数


makeposition

tvclib/utslvclauxiliary/makeposition

定义: makeposition(x,y);
说明:
将x,y构造为一个int类型
参数:
name
x
y

返回值:
type | describe
integer |


pointinrect

tvclib/utslvclauxiliary/pointinrect

定义: pointinrect(p,rec);
说明:
判断点是否在矩形中
参数:
name | type | describe
p | array of integer | 点 array(x,y)
rec | array of integer | 矩形区域

返回值:
type | describe
bool |


signedtounsigned

tvclib/utslvclauxiliary/signedtounsigned

定义: signedtounsigned(v,n);
说明:
符号数转换为无符号数
参数:
name | type | describe
v | integer | 数字
n | integer | 有效位数

返回值:
type | describe
integer |


tarray1dlk

tvclib/utslvclauxiliary/tarray1dlk

定义:type tarray1dlk= class();
说明:
一维链表类
成员变量:
name | private | type | describe
_data | protected | array | 数据

成员函数:
function | private
setdata | public
clean | public
create | public
append | public
geti | public
seti | public
deli | public
delis | public
insertbefor | public
insertafter | public
findvid | public
getprev | public
getnext | public
ergodic | public
data | public
replace | public
len | public
setorder | public
swap | public

propeties:
name | private | read | write | type | describe
comparevalue | public | fcomparevalue | fcomparevalue | fpointer | 回调函数 function(v1,v2)begin return v1 = v2 ; end


tarraytreeclass

tvclib/utslvclauxiliary/tarraytreeclass

定义:type tarraytreeclass= class();
说明:
树形类
成员函数:
function | private
create | public
addcomponent | public
recycle | public
toarray | public
totree | public
treearraytoarray | public
totreearray | public

转换范例
%%
d := array(("id":1,"pid":5,"caption":"jd1"),
("id":4,"pid":2,"caption":"jd2"),
("id":2,"pid":1,"caption":"jd3"),
("id":3,"pid":2,"caption":"jd4"),
("id":5,"pid":7,"caption":"jd5"),
);
dt := class(TArrayTreeClass).ToTreeArray(d,array("id":"id","pid":"pid","sub":"sub"));
return dt;


tbytedataop

tvclib/utslvclauxiliary/tbytedataop

定义:type tbytedataop= class();
说明:
位操作封装
成员函数:
function | private
bytesasint | public
intasbytes | public
shortstoint | public
inttoshorts | public
strasbytes | public
bytesasstr | public

范例:byte数组转整数
oa := new TByteDataOP();
echo tostn(oa.bytesasint(array(1,1,1,1)));
范例:整数转byte数组
oa := new TByteDataOP();
echo tostn(oa.intasbytes(235);


tcanvsrgnclipautosave

tvclib/utslvclauxiliary/tcanvsrgnclipautosave

定义:type tcanvsrgnclipautosave= class();
成员函数:
function | private
create | public


tfplist

tvclib/utslvclauxiliary/tfplist

定义:type tfplist= class(tarray1dlk);
说明:
list类
成员函数:
function | private
indexof | public
operator [] | public
add | public
remove | public
last | public
count | public

继承的变量:
name | private | type | describe
_data | protected | array | 数据

继承的函数:
  • setdata
  • clean
  • create
  • append
  • geti
  • seti
  • deli
  • delis
  • insertbefor
  • insertafter
  • findvid
  • getprev
  • getnext
  • ergodic
  • data
  • replace
  • len
  • setorder
  • swap

继承的properties:
name | private | read | write | type | describe
comparevalue | public | fcomparevalue | fcomparevalue | fpointer | 回调函数 function(v1,v2)begin return v1 = v2 ; end


tinifileexter

tvclib/utslvclauxiliary/tinifileexter

定义:type tinifileexter= class();
说明:
ini文件读写封装
成员函数:
function | private
create | public
readsection | public
readsections | public
readsectionvalues | public
renamesection | public
renamekey | public
readsectionvalues2 | public
readsectionvalues3 | public
readkey | public
writekey | public
erasesection | public


tnode

tvclib/utslvclauxiliary/tnode

定义:type tnode= class();
说明:
树结点
成员函数:
function | private
getnodebyindex | public
getindex | public
appendnode | public
hasnode | public
deletenode | public
deletechildnode | public
deletenodebyindex | public
deletechildren | public
insertnodes | public
insertnode | public

propeties:
name | private | read | type | describe | write
nodecount | public | getnodecount | integer | 子节点数量 |
expanded | public | fexpanded | bool | 是否展开 | setexpand
parent | public | fparent | tnode | 父节点 | setparent


tnumindexarray

tvclib/utslvclauxiliary/tnumindexarray

定义:type tnumindexarray= class();
说明:
数字下标数组对象
成员函数:
function | private
create | public
operator [1] | public
operator [] | public
length | public
push | public
pop | public
splice | public
shift | public
unshift | public
swap | public

propeties:
name | private | read | type | describe
data | public | fdata | array | 数据


tsltohexformatstr

tvclib/utslvclauxiliary/tsltohexformatstr

定义: tsltohexformatstr(tsl);
说明:
将tsl类型转换为16进制字符串,每行长度为64,用\r\n分割
参数:
name | type | describe
tsl | any | tsl基础类型

返回值:
type | describe
string | 字符串形式的16进制


tstrindexarray

tvclib/utslvclauxiliary/tstrindexarray

定义:type tstrindexarray= class();
说明:
数组类型忽略字符串下标的大小写
成员函数:
function | private
deleteindex | public
size | public
toarray | public
indexnames | public
haveindex | public
trueindex | public


ttire

tvclib/utslvclauxiliary/ttire

定义:type ttire= class();
说明:
tire树


unsignedtosigned

tvclib/utslvclauxiliary/unsignedtosigned

定义: unsignedtosigned(v,n);
说明:
无符号数转换为符号数
参数:
name | type | describe
v | integer | 数字
n | integer | 有效位数

返回值:
type | describe
integer |


append

tvclib/utslvclauxiliary/tarray1dlk/append

定义: public append(v);
说明:
追加
参数:
name | describe
v | tsl数据


clean

tvclib/utslvclauxiliary/tarray1dlk/clean

定义: public clean();
说明:
清空


create

tvclib/utslvclauxiliary/tarray1dlk/create

定义: public create();
说明:
构造


data

tvclib/utslvclauxiliary/tarray1dlk/data

定义: public data();
说明:
返回所有数据


deli

tvclib/utslvclauxiliary/tarray1dlk/deli

定义: public deli(i);
说明:
删除
参数:
name | type | describe
i | integer | id


delis

tvclib/utslvclauxiliary/tarray1dlk/delis

定义: public delis(i);
说明:
批量删除
参数:
name | type | describe
i | array | 删除的id


ergodic

tvclib/utslvclauxiliary/tarray1dlk/ergodic

定义: public ergodic(f);
说明:
循环所有数据
参数:
name | type | describe
f | fpointer | 处理函数 function(id,v) begin end


findvid

tvclib/utslvclauxiliary/tarray1dlk/findvid

定义: public findvid(v1,func,lx);
说明:
查找序号和v1 匹配的id
参数:
name | type | describe
v1 | any | tsl数据
func | fpointer | 比较函数 第一个参数为 数组中对象,第二个参数为输入判断条件
lx | bool | 逆序查找


geti

tvclib/utslvclauxiliary/tarray1dlk/geti

定义: public geti(i);
说明:
获得
参数:
name | type | describe
i | integer | id


getnext

tvclib/utslvclauxiliary/tarray1dlk/getnext

定义: public getnext(v1);
说明:
获得下一个 匹配的id
参数:
name | describe
v1 | tsl数据


getprev

tvclib/utslvclauxiliary/tarray1dlk/getprev

定义: public getprev(v1);
说明:
获得上一个 匹配的id
参数:
name | describe
v1 | tsl数据


insertafter

tvclib/utslvclauxiliary/tarray1dlk/insertafter

定义: public insertafter(v,i);
说明:
在i之后插入
参数:
name | describe | type
v | 插入数据 |
i | id | integer


insertbefor

tvclib/utslvclauxiliary/tarray1dlk/insertbefor

定义: public insertbefor(v,i);
说明:
在i之前插入
参数:
name | describe | type
v | 插入数据 |
i | id | integer


len

tvclib/utslvclauxiliary/tarray1dlk/len

定义: public len();
说明:
长度


replace

tvclib/utslvclauxiliary/tarray1dlk/replace

定义: public replace(i,v);
说明:
替换
参数:
name | type | describe
i | integer | 序号
v |  | tsl数据


setdata

tvclib/utslvclauxiliary/tarray1dlk/setdata

定义: public setdata(data);
说明:
一次性设置数据
参数:
name | type | describe
data | array | 数据


seti

tvclib/utslvclauxiliary/tarray1dlk/seti

定义: public seti(i,v);
说明:
设置值
参数:
name | type | describe
i | integer | id
v |  | tsl数据


setorder

tvclib/utslvclauxiliary/tarray1dlk/setorder

定义: public setorder(i,j);
说明:
设置元素位置
参数:
name | type | describe
i | integer | 原始位置
j | integer | 移动后的位置


swap

tvclib/utslvclauxiliary/tarray1dlk/swap

定义: public swap(i,j);
说明:
交换
参数:
name | type | describe
i | integer | 序号
j | integer | 序号


addcomponent

tvclib/utslvclauxiliary/tarraytreeclass/addcomponent

定义: public addcomponent(o);
说明:
添加节点
参数:
name
o


create

tvclib/utslvclauxiliary/tarraytreeclass/create

定义: public create(v);
说明:
构造节点
参数:
name
v


recycle

tvclib/utslvclauxiliary/tarraytreeclass/recycle

定义: public recycle();
说明:
出现死循环的时候的处理


toarray

tvclib/utslvclauxiliary/tarraytreeclass/toarray

定义: public toarray();
说明:
转换为array


totree

tvclib/utslvclauxiliary/tarraytreeclass/totree

定义: public class totree(d,info);
说明:
二维表转换为树结构
参数:
name | type | describe
d | array | 数据包含 信息
info | array | 字段信息 "id" 当前节点的字段,"pid" 当前节点的父节点字段,"sub" ,返回子节点的字段 默认值 array("id":"id","pid":"pid","sub":"sub");

返回值:
type | describe
tarraytreeclass |


totreearray

tvclib/utslvclauxiliary/tarraytreeclass/totreearray

定义: public class totreearray(d,info);
说明:
二维表转换为树结构
参数:
name | type | describe
d | array | 数据包含 信息
info | array | 字段信息 "id" 当前节点的字段,"pid" 当前节点的父节点字段,"sub" ,返回子节点的字段 默认值 array("id":"id","pid":"pid","sub":"sub");

返回值:
type | describe
array | 树形结构的array


treearraytoarray

tvclib/utslvclauxiliary/tarraytreeclass/treearraytoarray

定义: public class treearraytoarray(d,info);
说明:
树结构转换为二维表
参数:
name | type | describe
d | array | 数据包含 信息
info | array | 字段信息 "id" 当前节点的字段,"pid" 当前节点的父节点字段,"sub" ,返回子节点的字段 默认值 array("id":"id","pid":"pid","sub":"sub");

返回值:
type | describe
array |


bytesasint

tvclib/utslvclauxiliary/tbytedataop/bytesasint

定义: public class bytesasint(a);
说明:
四个byte转换为integer
参数:
name | type | describe
a | array | 正式表示的四字节

返回值:
type | describe
integer | 组装好的整数


bytesasstr

tvclib/utslvclauxiliary/tbytedataop/bytesasstr

定义: public class bytesasstr(b);
说明:
byte数组转字符串
参数:
name | type | describe
b | array | byte数组

返回值:
type | describe
string | 字符串


intasbytes

tvclib/utslvclauxiliary/tbytedataop/intasbytes

定义: public class intasbytes(v);
说明:
整数转换为byte 数组(整数数组模拟)
参数:
name | type
v | integer

返回值:
type | describe
array | 模拟的byte数组


inttoshorts

tvclib/utslvclauxiliary/tbytedataop/inttoshorts

定义: public class inttoshorts(v);
说明:
整数转换为两个short 数组(整数数组模拟)
参数:
name | type
v | integer

返回值:
type | describe
array | 模拟的short数组


shortstoint

tvclib/utslvclauxiliary/tbytedataop/shortstoint

定义: public class shortstoint(a);
说明:
两个short转换为一个int
参数:
name | type | describe
a | array | 两个元素的数组

返回值:
type | describe
integer | 整数


strasbytes

tvclib/utslvclauxiliary/tbytedataop/strasbytes

定义: public class strasbytes(s);
说明:
字符串转换为byte数组
参数:
name | type | describe
s | string | 字符串

返回值:
type | describe
array | 模拟的byte数组


create

tvclib/utslvclauxiliary/tcanvsrgnclipautosave/create

定义: public create(cvs,rec);
说明:
构造裁剪对象
参数:
name | type | describe
cvs | tcustomcanvas | canvas 对象
rec | array(左上右下 | )区域


add

tvclib/utslvclauxiliary/tfplist/add

定义: public add(v);
说明:
追加数据到链表
参数:
name | type | describe
v | any | 数据


count

tvclib/utslvclauxiliary/tfplist/count

定义: public count();
说明:
获取数据个数
返回值:
type | describe
integer |


indexof

tvclib/utslvclauxiliary/tfplist/indexof

定义: public indexof(v,f,lx);
说明:
查找值v在序列中的位置
参数:
name | type | describe
v | any | 任何类型
f |  |
lx |  |

返回值:
type | describe
integer | 位置 ,等于-1 表示没查找到


last

tvclib/utslvclauxiliary/tfplist/last

定义: public last();
说明:
获取最后一个数据
返回值:
type | describe
any | 数据


operator []

tvclib/utslvclauxiliary/tfplist/operator []

定义: public operator [](index);
说明:
获取序号为index的值
参数:
name
index

返回值:
type | describe
any | 数据


remove

tvclib/utslvclauxiliary/tfplist/remove

定义: public remove(v);
说明:
删除数据V
参数:
name | type | describe
v | any | 数据


create

tvclib/utslvclauxiliary/tinifileexter/create

定义: public create();
说明:
构造函数


erasesection

tvclib/utslvclauxiliary/tinifileexter/erasesection

定义: public erasesection(sn);virtual;
说明:
删除section
参数:
name
sn


readkey

tvclib/utslvclauxiliary/tinifileexter/readkey

定义: public readkey(sn,key,def);virtual;
说明:
读取key
参数:
name
sn
key
def


readsection

tvclib/utslvclauxiliary/tinifileexter/readsection

定义: public readsection(sn);virtual;
说明:
读取section 下面key
参数:
name
sn


readsections

tvclib/utslvclauxiliary/tinifileexter/readsections

定义: public readsections();virtual;
说明:
读取所有section名字


readsectionvalues

tvclib/utslvclauxiliary/tinifileexter/readsectionvalues

定义: public readsectionvalues(sn);virtual;
说明:
读取section下面的所有key:value
参数:
name
sn


readsectionvalues2

tvclib/utslvclauxiliary/tinifileexter/readsectionvalues2

定义: public readsectionvalues2(sn);
说明:
获得section 数据,二维表,name,value 列
参数:
name
sn


readsectionvalues3

tvclib/utslvclauxiliary/tinifileexter/readsectionvalues3

定义: public readsectionvalues3(sn);
说明:
获得section 数据,二维表,0列为key,1列为value
参数:
name
sn


renamekey

tvclib/utslvclauxiliary/tinifileexter/renamekey

定义: public renamekey(sec,k1,k2);virtual;
说明:
重命名key
参数:
name | type | describe
sec | string | section名称
k1 | string | 旧名字
k2 | string | 新名字


renamesection

tvclib/utslvclauxiliary/tinifileexter/renamesection

定义: public renamesection(sn1,sn2);virtual;
说明:
重命名section
参数:
name | type | describe
sn1 | string | 旧名字
sn2 | string | 新名字


writekey

tvclib/utslvclauxiliary/tinifileexter/writekey

定义: public writekey(sn,key,v);virtual;
说明:
写入key
参数:
name
sn
key
v


appendnode

tvclib/utslvclauxiliary/tnode/appendnode

定义: public appendnode(it);virtual;
说明:
插入一个节点
参数:
name | type | describe
it | tnode | 节点

返回值:
type | describe
bool | 是否成功


deletechildnode

tvclib/utslvclauxiliary/tnode/deletechildnode

定义: public deletechildnode(nd);
说明:
删除子节点
参数:
name | type | describe
nd | tnode | 节点


deletechildren

tvclib/utslvclauxiliary/tnode/deletechildren

定义: public deletechildren();virtual;
说明:
删除所有的子节点


deletenode

tvclib/utslvclauxiliary/tnode/deletenode

定义: public deletenode(nd);virtual;
说明:
删除节点
参数:
name | type | describe
nd | tnode | 待删除节点


deletenodebyindex

tvclib/utslvclauxiliary/tnode/deletenodebyindex

定义: public deletenodebyindex(idx);
说明:
根据位置删除节点
参数:
name | type | describe
idx | integer | 序号


getindex

tvclib/utslvclauxiliary/tnode/getindex

定义: public getindex();virtual;
说明:
获得在父节点中的序号
返回值:
type | describe
integer | 序号


getnodebyindex

tvclib/utslvclauxiliary/tnode/getnodebyindex

定义: public getnodebyindex(idx);
说明:
通过序号获得子节点
参数:
name | type
idx | tnode


hasnode

tvclib/utslvclauxiliary/tnode/hasnode

定义: public hasnode(nd);virtual;
说明:
是否为某个节点的祖先节点
参数:
name | type | describe
nd | tnode | 子节点

返回值:
type | describe
tnode|0 | 如果为祖先节点,就返回查询节点的父节点


insertnode

tvclib/utslvclauxiliary/tnode/insertnode

定义: public insertnode(it,idx);virtual;
说明:
插入一个节点
参数:
name | type | describe
it | tnode | 字符串
idx | integer | 序号 默认为0


insertnodes

tvclib/utslvclauxiliary/tnode/insertnodes

定义: public insertnodes(its,idx);virtual;
说明:
插入一个节点
参数:
name | type | describe
its |  |
idx | integer | 序号 默认为0


create

tvclib/utslvclauxiliary/tnumindexarray/create

定义: public create();virtual;
说明:
构造函数


length

tvclib/utslvclauxiliary/tnumindexarray/length

定义: public length();
说明:
获得数据长度
返回值:
type | describe
integer | 长度


operator [1]

tvclib/utslvclauxiliary/tnumindexarray/operator [1]

定义: public operator [1](idx,v);
说明:
通过下标设置元素
参数:
name
idx
v


operator []

tvclib/utslvclauxiliary/tnumindexarray/operator []

定义: public operator [](idx);
说明:
通过下标获取元素
参数:
name
idx


pop

tvclib/utslvclauxiliary/tnumindexarray/pop

定义: public pop();
说明:
弹出末尾的元素


push

tvclib/utslvclauxiliary/tnumindexarray/push

定义: public push();
说明:
在末尾追加元素,参数个数不定


shift

tvclib/utslvclauxiliary/tnumindexarray/shift

定义: public shift();
说明:
弹出头部元素


splice

tvclib/utslvclauxiliary/tnumindexarray/splice

定义: public splice();
说明:
替换元素,第一个参数为开始位置,第二个为替换的个数,以后的参数为用来替换的值,返回被替换的值


swap

tvclib/utslvclauxiliary/tnumindexarray/swap

定义: public swap(i,j);
说明:
交换下标中的值
参数:
name
i
j


unshift

tvclib/utslvclauxiliary/tnumindexarray/unshift

定义: public unshift();
说明:
在数据头部加入元素,个数待定


deleteindex

tvclib/utslvclauxiliary/tstrindexarray/deleteindex

定义: public deleteindex(idx);
说明:
删除指定下标
参数:
name
idx


haveindex

tvclib/utslvclauxiliary/tstrindexarray/haveindex

定义: public haveindex();
说明:
判断是否有某个下标


indexnames

tvclib/utslvclauxiliary/tstrindexarray/indexnames

定义: public indexnames();
说明:
获得 所有下标


size

tvclib/utslvclauxiliary/tstrindexarray/size

定义: public size();
说明:
获得长度


toarray

tvclib/utslvclauxiliary/tstrindexarray/toarray

定义: public toarray(n);
说明:
获得tsl array
参数:
name | type | describe
n | bool | false 返回小写下标，true 返回原始下标


trueindex

tvclib/utslvclauxiliary/tstrindexarray/trueindex

定义: public trueindex(n);
说明:
获得对应下标
参数:
name
n


tsluibase

tvclib/utslvclbase/tsluibase

定义:type tsluibase= class(tsluiconst);
说明:
图像库基类,提供基本的底层操作和常量
成员变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量

成员函数:
function | private
sinit | public
iskeywords | public
norecycled | public
recycling | public
hashset | public
hashget | public
hashdel | public
temppath | public

继承的变量:
name | private | static | type | describe
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tswin32api

tvclib/utslvclbase/tswin32api

定义:type tswin32api= class(tsgtkapi,twindowsapi);
uses:
  • ugtkinterface

说明:
win32api接口函数类
1. 导出了部分win32的api
2. winuser头文件的宏定义
3. 添加了部分结构体定义到成员变量
4. 下面的external函数的win32api可以在msdn中查找具体用法
成员函数:
function | private
getscreenrect | public
getpathbyprocid | public
enumprocesses | public
toolhelp32snapshot | public
toolhelp32snapshotmodule | public


hashdel

tvclib/utslvclbase/tsluibase/hashdel

定义: public hashdel(i,f);
说明:
删除一个哈希值
参数:
name | type | describe
i | string | integer | 下标
f | bool | i=nil and f=1 清空hash表

返回值:
type | describe
bool | 是否成功


hashget

tvclib/utslvclbase/tsluibase/hashget

定义: public hashget(i);
说明:
获取一个哈希值
参数:
name | type | describe
i | string | integer | 下标

返回值:
type | describe
 | 值


hashset

tvclib/utslvclbase/tsluibase/hashset

定义: public hashset(i,v,f);
说明:
设置一个哈希值
参数:
name | type | describe
i | string | integer | 下标
v |  | 值
f | bool | i=nil and f=1 and v=array 替换哈希表


iskeywords

tvclib/utslvclbase/tsluibase/iskeywords

定义: public class iskeywords(key);
说明:
判断是否为tsl关键字
参数:
name | type
key | string


norecycled

tvclib/utslvclbase/tsluibase/norecycled

定义: public norecycled();
说明:
是否没有被回收
返回值:
type | describe
bool | 没有回收返回true ,否则返回false;


recycling

tvclib/utslvclbase/tsluibase/recycling

定义: public recycling();virtual;
说明:
析构准备;为消除循环引用的销毁


sinit

tvclib/utslvclbase/tsluibase/sinit

定义: public class sinit();virtual;
说明:
初始化win32接口对象_wapi


temppath

tvclib/utslvclbase/tsluibase/temppath

定义: public temppath();
说明:
获取一个可以读写的文件夹
返回值:
type | describe
string | 目录路径


enumprocesses

tvclib/utslvclbase/tswin32api/enumprocesses

定义: public enumprocesses();
说明:
获取所有进程id
获取所有进程id,并获得路径
t := EnumProcesses();
for i,v in t do echo getpathbyprocid(v),"\r\n";


getpathbyprocid

tvclib/utslvclbase/tswin32api/getpathbyprocid

定义: public getpathbyprocid(id);
说明:
获取所有进程路径
参数:
name | type | describe
id | integer | 进程id


getscreenrect

tvclib/utslvclbase/tswin32api/getscreenrect

定义: public getscreenrect();
说明:
获取屏幕大小
返回值:
type | describe
array | 左上右下


toolhelp32snapshot

tvclib/utslvclbase/tswin32api/toolhelp32snapshot

定义: public toolhelp32snapshot();
说明:
获取所有进程信息


toolhelp32snapshotmodule

tvclib/utslvclbase/tswin32api/toolhelp32snapshotmodule

定义: public toolhelp32snapshotmodule(id);
说明:
获取所有module信息
参数:
name
id


_tvclmsageid_

tvclib/utslvclconstant/_tvclmsageid_

定义:type _tvclmsageid_= class();
说明:
tslvcl库重新定义的消息等常量lm_开头 %


_winuserdef_

tvclib/utslvclconstant/_winuserdef_

定义:type _winuserdef_= class();
说明:
一些常量 如按键相关的vk_开头,系统消息相关的常量wm_开头


constant

tvclib/utslvclconstant/constant

定义:type constant= class();
说明:
为方便使用,利用静态成员变量模拟的常量,请不要修改其值


talign

tvclib/utslvclconstant/talign

定义:type talign= class(tenumeration);
说明:
自动对齐类型常量
成员变量:
name | private | static | type | describe
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满

继承的函数:
  • basevalue
  • initenumeration


talignstyle9

tvclib/utslvclconstant/talignstyle9

定义:type talignstyle9= class(tenumeration);
说明:
九宫格对齐常量,al9_ 开头
成员变量:
name | private | static | type | describe
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居

继承的函数:
  • basevalue
  • initenumeration


talignstyleh3

tvclib/utslvclconstant/talignstyleh3

定义:type talignstyleh3= class(tenumeration);
说明:
水平对齐常量
成员变量:
name | private | static | type | describe
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中

继承的函数:
  • basevalue
  • initenumeration


tanchorkind

tvclib/utslvclconstant/tanchorkind

定义:type tanchorkind= class(tenumeration);
说明:
锚定类型常量
成员变量:
name | private | static | type | describe
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下

继承的函数:
  • basevalue
  • initenumeration


tconstant

tvclib/utslvclconstant/tconstant

定义:type tconstant= class(talign,tanchorkind,tformstyle,tcomponentstate,tcomponentstyle,twincontrolflag,tcontrolstyletype,tmousebutton,tshiftstateenum,tcontrolflag,tdockorientation,tdragkind,tdragmode,tdragstate,tdragmessage,tcanvasstates,tfppenmode,tfppenendcap,tfppenjoinstyle,tcontrolstatetype,tformborderstyle,talignstyle9,talignstyleh3,tsyscursor,tactionliststate,ttoolbuttonstyle,tpairsplittertype);
说明:
常量类集合
继承的变量:
name | private | static | type | describe
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tenumeration

tvclib/utslvclconstant/tenumeration

定义:type tenumeration= class();
说明:
自增长常量基类,其子类的静态成员变量将分配自增长的一个整数值
成员函数:
function | private
basevalue | public
initenumeration | public


tmacroconst

tvclib/utslvclconstant/tmacroconst

定义:type tmacroconst= class(_commctrldef_,_tvclmsageid_,_shellapi_);
说明:
宏定义集合


tmbbtnstyle

tvclib/utslvclconstant/tmbbtnstyle

定义:type tmbbtnstyle= class();
说明:
TMessageboxADlg 按钮样式常量
成员变量:
name | private | static | type | describe
mb_ok | public | static | constant | 样式
mb_okcancel | public | static | constant | 样式
mb_abortretryignore | public | static | constant | 样式
mb_yesnocancel | public | static | constant | 样式
mb_yesno | public | static | constant | 样式
mb_retrycancel | public | static | constant | 样式
mb_canceltrycontinue | public | static | constant | 样式
mb_help | public | static |  | 样式


tmbiconstyle

tvclib/utslvclconstant/tmbiconstyle

定义:type tmbiconstyle= class();
说明:
TMessageboxADlg 图标样式常量
成员变量:
name | private | static | type | describe
mb_iconwarning | public | static | constant | 样式
mb_iconasterisk | public | static | constant | 样式
mb_iconquestion | public | static | constant | 样式
mb_iconstop | public | static | constant | 样式


tmousebutton

tvclib/utslvclconstant/tmousebutton

定义:type tmousebutton= class(tenumeration);
成员变量:
name | private | static | type | describe
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键

继承的函数:
  • basevalue
  • initenumeration


trasteroperationconst

tvclib/utslvclconstant/trasteroperationconst

定义:type trasteroperationconst= class();
说明:
光栅操作代码常量类


tshiftstateenum

tvclib/utslvclconstant/tshiftstateenum

定义:type tshiftstateenum= class(tenumeration);
成员变量:
name | private | static | type | describe
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击

继承的函数:
  • basevalue
  • initenumeration


tsluiconst

tvclib/utslvclconstant/tsluiconst

定义:type tsluiconst= class(tmacroconst,tconstant);
说明:
界面库常量类
继承的变量:
name | private | static | type | describe
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tsyscursor

tvclib/utslvclconstant/tsyscursor

定义:type tsyscursor= class(tenumeration);
说明:
idc_ 开头的 光标样式
成员变量:
name | private | static | type | describe
idc_arrow | public | static | constant | 类型

继承的函数:
  • basevalue
  • initenumeration


tsystembitmap

tvclib/utslvclconstant/tsystembitmap

定义:type tsystembitmap= class();
说明:
系统提供的bitmap id


tsystemcursor

tvclib/utslvclconstant/tsystemcursor

定义:type tsystemcursor= class();
说明:
鼠标常量类,作为参考ocr_ 开头
成员变量:
name | private | static | type | describe
ocr_wait | public | static | constant | 样式
ocr_cross | public | static | constant | 样式
ocr_up | public | static | constant | 样式
ocr_size | public | static | constant | 样式
ocr_no | public | static | constant | 样式
ocr_hand | public | static | constant | 样式


basevalue

tvclib/utslvclconstant/tenumeration/basevalue

定义: public class basevalue();virtual;
说明:
请在该函数中设置基准值,可以在给函数中设置


initenumeration

tvclib/utslvclconstant/tenumeration/initenumeration

定义: public class initenumeration(o,ival);
说明:
常量类初始
参数:
name | type | describe
o | tenumeration | tenumeration的子类
ival | integer | 初始值,默认0开始


tcustomcoolbar

tvclib/utslvclcoolbar/tcustomcoolbar

定义:type tcustomcoolbar= class(tcustomcontrol);
说明:
coolbar基类
propeties:
name | private | type | read | write
autosize | public | bool | fautosize | setautosize
arrange | public | lazystr | getarrange | setarrange
dragbtncolor | public | color | fdragbtncolor | fdragbtncolor

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcommdlg

tvclib/utslvcldlg/tcommdlg

定义:type tcommdlg= class(tcomponent);
说明:
选择对话框类
成员函数:
function | private
opendlg | public
choosedlg | public

propeties:
name | private | read | type | describe | write
chooseok | public | fchooseok | bool | 是否执行成功 |
wndowner | public | fwndowner | twincontrol | 所属窗口 | fwndowner
caption | public | fcaption | string |  | setcaption

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tcustomcolordlg

tvclib/utslvcldlg/tcustomcolordlg

定义:type tcustomcolordlg= class(tcommdlg);
说明:
颜色选择器
propeties:
name | private | read | write | type | describe
customcolors | public | getcustomcolors | setcustomcolors | array of integer | 自定义颜色
result | public | getresult | setresult | color |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
chooseok | public | fchooseok | bool | 是否执行成功 |
wndowner | public | fwndowner | twincontrol | 所属窗口 | fwndowner
caption | public | fcaption | string |  | setcaption
owner | public | fowner | tcomponent | 所有者 |
componentcreated | public | fcomponentcreated | bool | 样式结合 |
componentstate | public | fcomponentstate |  | 状态集合 | setcomponentstate
componentstyle | public | fcomponentstyle |  | 样式结合 |
name | public | fname | string |  | setname
ondestroy | public | fondestroy | eventhandler |  | fondestroy
onnotification | public | fonnotification | eventhandler |  | fonnotification


tcustomfolderdlg

tvclib/utslvcldlg/tcustomfolderdlg

定义:type tcustomfolderdlg= class(tcommdlg);
说明:
文件夹路径选择对话框
propeties:
name | private | read | write | type | describe
rootfolder | public | frootstr | setrootfold | directory |
folder | public | ffolder |  | string | 文件夹路径
editbox | public | feditbox | seteditbox | bool |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
chooseok | public | fchooseok | bool | 是否执行成功 |
wndowner | public | fwndowner | twincontrol | 所属窗口 | fwndowner
caption | public | fcaption | string |  | setcaption
owner | public | fowner | tcomponent | 所有者 |
componentcreated | public | fcomponentcreated | bool | 样式结合 |
componentstate | public | fcomponentstate |  | 状态集合 | setcomponentstate
componentstyle | public | fcomponentstyle |  | 样式结合 |
name | public | fname | string |  | setname
ondestroy | public | fondestroy | eventhandler |  | fondestroy
onnotification | public | fonnotification | eventhandler |  | fonnotification


tcustomfontdlg

tvclib/utslvcldlg/tcustomfontdlg

定义:type tcustomfontdlg= class(tcommdlg);
说明:
字体选择对话框
propeties:
name | private | type | read | write | describe
fontinfo | public | array | getfontinfo | setfontinfo | 字体信息数组

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
chooseok | public | fchooseok | bool | 是否执行成功 |
wndowner | public | fwndowner | twincontrol | 所属窗口 | fwndowner
caption | public | fcaption | string |  | setcaption
owner | public | fowner | tcomponent | 所有者 |
componentcreated | public | fcomponentcreated | bool | 样式结合 |
componentstate | public | fcomponentstate |  | 状态集合 | setcomponentstate
componentstyle | public | fcomponentstyle |  | 样式结合 |
name | public | fname | string |  | setname
ondestroy | public | fondestroy | eventhandler |  | fondestroy
onnotification | public | fonnotification | eventhandler |  | fonnotification


tcustomfsdlg

tvclib/utslvcldlg/tcustomfsdlg

定义:type tcustomfsdlg= class(tcommdlg);
说明:
保存文件,获得文件名
成员变量:
name | private | type | describe
ffiletag | protected | ttagofna | openfile 对象

成员函数:
function | private
getselecteditemname | public
choosedlg | public
getresults | public

propeties:
name | private | type | read | write | describe
filter | public | array | ffilter | setfilter | array("所有文件":"*.*","tsl流文件":"*.stm")
filename | public | string | getresult |  | 文件名,不成功返回上一次的结果。
defaultfileextension | public | string | getdefaultfileextension | setdefaultfileextension | 默认扩展名，当文件名输入框中未指定扩展名且未选择保存类型时将使用该扩展名，用于保存对话框。
initialdir | public | string | getinitialdir | setinitialdir | 默认打开路径
showhidden | public | bool | fisshowhidden | setshowhidden | 是否强制显示隐藏文件。
multiselected | public | bool | fismultiselected | setmultiselected | 可多选，用于打开对话框。
overwriteprompt | public | bool | fisoverwriteprompt | setoverwriteprompt | 开启覆盖保存提醒，用于保存对话框。
linkfilepath | public | bool | fislinkfilepath | setlinkfilepath | 若所选为快捷方式文件则返回该文件本身路径；默认返回其指向文件的路径。
filemustexist | public | bool | fisfilemustexist | setfilemustexist | 若在文件名输入框中输入不存在的文件名则提示文件名不存在；默认则不提示而直接返回路径，用于打开对话框。
createprompt | public | bool | fiscreateprompt | setcreateprompt | 若在文件名输入框中输入不存在的文件名则提示是否创建；默认则不提示而直接返回路径，用于打开对话框。

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
chooseok | public | fchooseok | bool | 是否执行成功 |
wndowner | public | fwndowner | twincontrol | 所属窗口 | fwndowner
caption | public | fcaption | string |  | setcaption
owner | public | fowner | tcomponent | 所有者 |
componentcreated | public | fcomponentcreated | bool | 样式结合 |
componentstate | public | fcomponentstate |  | 状态集合 | setcomponentstate
componentstyle | public | fcomponentstyle |  | 样式结合 |
name | public | fname | string |  | setname
ondestroy | public | fondestroy | eventhandler |  | fondestroy
onnotification | public | fonnotification | eventhandler |  | fonnotification


tcustommsgadlg

tvclib/utslvcldlg/tcustommsgadlg

定义:type tcustommsgadlg= class(tcommdlg);
说明:
消息提示框
propeties:
name | private | type | read | write | describe
mbtext | public | string | fmbtext | setmbtext | 字符串
mbbtnstyle | public | tmbbtnstyle | fbtnval | setmbbtnstyle | 按钮样式
mbiconstyle | public | tmbiconstyle | ficonval | setmbiconstyle | 图标样式

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • opendlg
  • choosedlg
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
chooseok | public | fchooseok | bool | 是否执行成功 |
wndowner | public | fwndowner | twincontrol | 所属窗口 | fwndowner
caption | public | fcaption | string |  | setcaption
owner | public | fowner | tcomponent | 所有者 |
componentcreated | public | fcomponentcreated | bool | 样式结合 |
componentstate | public | fcomponentstate |  | 状态集合 | setcomponentstate
componentstyle | public | fcomponentstyle |  | 样式结合 |
name | public | fname | string |  | setname
ondestroy | public | fondestroy | eventhandler |  | fondestroy
onnotification | public | fonnotification | eventhandler |  | fonnotification


choosedlg

tvclib/utslvcldlg/tcommdlg/choosedlg

定义: public choosedlg();virtual;
说明:
打开对话框虚函数


opendlg

tvclib/utslvcldlg/tcommdlg/opendlg

定义: public opendlg();
说明:
打开对话框


choosedlg

tvclib/utslvcldlg/tcustomfsdlg/choosedlg

定义: public choosedlg();override;
说明:
打开一个对话框以使用户选择将要打开或保存的文件的路径
返回值:
type | describe
bool | 是否选择了有效的文件路径


getresults

tvclib/utslvcldlg/tcustomfsdlg/getresults

定义: public getresults();
说明:
获取所选择文件的完整路径
返回值:
type | describe
array | 所选择文件路径的数组


getselecteditemname

tvclib/utslvcldlg/tcustomfsdlg/getselecteditemname

定义: public getselecteditemname();
说明:
获取所选择文件的文件名
返回值:
type | describe
string | 当选择不止一个文件时，该函数返回首文件名。


tgridmdrawitem

tvclib/utslvclevent/tgridmdrawitem

定义:type tgridmdrawitem= class(tuieventbase);
说明:
表格控件绘制消息
成员变量:
name | private | type | describe
canvas | public | tcanvas | 画板对象
itemid | public | integer | 行号
subitemid | public | integer | 列号
rcitem | public | array(左上右下 | ) 区域
subitemrect | public | array(左上右下 | ) 区域

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tmkey

tvclib/utslvclevent/tmkey

定义:type tmkey= class(tuieventbase);
propeties:
name | private | read | type | describe
char | public | fchar | string | 键符号
charcode | public | wparam | integer | ascii码
shiftstate | public | getshiftsate | arry of tshiftstateenum member | ascii码

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tmmenuselect

tvclib/utslvclevent/tmmenuselect

定义:type tmmenuselect= class(tuieventbase);
说明:
菜单选择消息
propeties:
name | private | read | type | describe
itemid | public | lowparam | integer | 菜单id
flags | public | hiwparam | integer | 状态

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tmmouse

tvclib/utslvclevent/tmmouse

定义:type tmmouse= class(tuieventbase);
说明:
鼠标消息类
成员变量:
name | private | type | describe
fbutton | protected | integer | 按键状态,继承时候使用

成员函数:
function | private
pos | public
button | public
shiftstate | public
shiftdouble | public

propeties:
name | private | type | read | describe
xpos | public | integer | lolparamsigned | x 位置
ypos | public | integer | hilparamsigned | y 位置

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tmmousewheel

tvclib/utslvclevent/tmmousewheel

定义:type tmmousewheel= class(tuieventbase);
说明:
鼠标滚动消息类
成员函数:
function | private
shiftstate | public

propeties:
name | private | read | type | describe
delta | public | hiwparamsigned | integer | 运动距离
ypos | public | hilparamsigned | integer | 鼠标的y坐标
xpos | public | lolparamsigned | integer | 鼠标的x坐标

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tmnotify

tvclib/utslvclevent/tmnotify

定义:type tmnotify= class(tuieventbase,tslcstructureobj);
说明:
系统控件通知消息
propeties:
name | private | index | read | type | describe
hwndfrom | public | hwndfrom | _getvalue_ | pointer | 子控件句柄
code | public | code | _getvalue_ | integer | 通知码

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static
_blocks | array | protected | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | aefclassobj_ | protected | 内存管理底层工具 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tmstylechang

tvclib/utslvclevent/tmstylechang

定义:type tmstylechang= class(tuieventbase);
说明:
窗口样式改变消息
propeties:
name | private | index | read | write | type | describe
styleold | public | styleold | _getvalue_ | _setvalue_ | integer | 旧样式
stylenew | public | stylenew | _getvalue_ | _setvalue_ | integer | 新样式

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tsiftstate

tvclib/utslvclevent/tsiftstate

定义:type tsiftstate= class(tsluiconst);
成员函数:
function | private
keystoshiftstate | public

继承的变量:
name | private | static | type | describe
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


ttagedrawitem

tvclib/utslvclevent/ttagedrawitem

定义:type ttagedrawitem= class(tslcstructureobj);
propeties:
name | private | index | read | write | type | describe
ctltype | public | ctltype | _getvalue_ | _setvalue_ | integer | 控件类型
ctlid | public | ctlid | _getvalue_ | _setvalue_ | integer | 控件id
id | public | itemid | _getvalue_ | _setvalue_ | integer | 待绘制的子项序号
itemaction | public | itemaction | _getvalue_ | _setvalue_ | integer | ODA_DRAWENTIRE or ODA_FOCUS or ODA_SELECT
itemstate | public | itemstate | _getvalue_ | _setvalue_ | member of tdrawitemstate | 状态
rcitem | public | rcitem | _getvalue_ | _setvalue_ | array of integer | array(左,上,右,下)
hdc | public | hdc | _getvalue_ | _setvalue_ | pointer | canvas句柄
hwnditem | public | hwnditem | _getvalue_ | _setvalue_ | pointer | windows句柄

继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


button

tvclib/utslvclevent/tmmouse/button

定义: public button();
说明:
鼠标按键情况
返回值:
type | describe
member of tmousebutton |


pos

tvclib/utslvclevent/tmmouse/pos

定义: public pos();
说明:
获得位置信息
返回值:
type | describe
array | x,y 位置


shiftdouble

tvclib/utslvclevent/tmmouse/shiftdouble

定义: public shiftdouble();
说明:
是否双击
返回值:
type | describe
bool | 是否双击


shiftstate

tvclib/utslvclevent/tmmouse/shiftstate

定义: public shiftstate();
说明:
按键状态
返回值:
type | describe
array of tshiftstateenum menuber |


shiftstate

tvclib/utslvclevent/tmmousewheel/shiftstate

定义: public shiftstate();
说明:
按键状态
返回值:
type | describe
array of tshiftstateenum menuber | shift 键集合


keystoshiftstate

tvclib/utslvclevent/tsiftstate/keystoshiftstate

定义: public class keystoshiftstate(keys);
说明:
解析按键状态
参数:
name | type
keys | ptruint


内存管理对象

tvclib/utslvclfackinterface/aefclassobj_

定义:type aefclassobj_= class();
别名:内存管理对象
说明:
内存操作底层接口伪类
成员函数:
function | private
tmalloc | public
trealloc | public
tfree | public
tmset | public
readbyte | public
writebyte | public
readint | public
writedouble | public
readdouble | public
writellong | public
readlong | public
writeshort | public
readshort | public
writebytes | public
readbytes | public
writeshorts | public
readshorts | public


getctypesize

tvclib/utslvclfackinterface/getctypesize

定义: getctypesize();
说明:
获取类型占用内存大小
返回值:
type | describe
array | 以类型字符串为下标的数字数组,数字表示该类型的内存大小


getsenderdatabyid

tvclib/utslvclfackinterface/getsenderdatabyid

定义: getsenderdatabyid();
说明:
获取变量的地址,在send消息使用
返回值:
type | describe
obj | tsl变量


gettslvariableptr

tvclib/utslvclfackinterface/gettslvariableptr

定义: gettslvariableptr(obj);
说明:
获取变量的地址,在send消息使用
参数:
name | type | describe
obj | obj | tsl变量

返回值:
type | describe
integer | 变量地址


getwinprocptr

tvclib/utslvclfackinterface/getwinprocptr

定义: getwinprocptr(f);
说明:
获取winProc函数句柄
参数:
name | type | describe
f | integer|nil | 1表示DefWindowProcA ,0 表示timeproc nil表示twinproc

返回值:
type | describe
integer | 消息函数句柄


readbyte

tvclib/utslvclfackinterface/aefclassobj_/readbyte

定义: public readbyte(p);
说明:
读取一个byte
参数:
name | type | describe
p | pointer | 内存地址


readbytes

tvclib/utslvclfackinterface/aefclassobj_/readbytes

定义: public readbytes(p,sz);
说明:
读取一组byte
参数:
name | type | describe
p | pointer | 内存地址
sz | pointer | 大小


readdouble

tvclib/utslvclfackinterface/aefclassobj_/readdouble

定义: public readdouble(p);
说明:
读取一个double
参数:
name | type | describe
p | pointer | 内存地址


readint

tvclib/utslvclfackinterface/aefclassobj_/readint

定义: public readint();
说明:
读取一个byte


readlong

tvclib/utslvclfackinterface/aefclassobj_/readlong

定义: public readlong(p);
说明:
读取一个long
参数:
name | type | describe
p | pointer | 内存地址


readshort

tvclib/utslvclfackinterface/aefclassobj_/readshort

定义: public readshort();
说明:
读取一个short


readshorts

tvclib/utslvclfackinterface/aefclassobj_/readshorts

定义: public readshorts(p,sz);
说明:
读取一组short
参数:
name | type | describe
p | pointer | 内存地址
sz | pointer | 大小


tfree

tvclib/utslvclfackinterface/aefclassobj_/tfree

定义: public tfree(p);
说明:
释放内存
参数:
name | type | describe
p | pointer | 内存地址


tmalloc

tvclib/utslvclfackinterface/aefclassobj_/tmalloc

定义: public tmalloc(sz);
说明:
内存分配
参数:
name | type | describe
sz | integer | 大小

返回值:
type | describe
pointer | 分配的内存的句柄


tmset

tvclib/utslvclfackinterface/aefclassobj_/tmset

定义: public tmset(p,sz);
说明:
初始化内存
参数:
name | type | describe
p | pointer | 内存地址
sz | integer | 大小


trealloc

tvclib/utslvclfackinterface/aefclassobj_/trealloc

定义: public trealloc(p,sz);
说明:
重新内存分配
参数:
name | type | describe
p | pointer | 内存地址
sz | integer | 大小

返回值:
type | describe
pointer | 新的内存地址


writebyte

tvclib/utslvclfackinterface/aefclassobj_/writebyte

定义: public writebyte(p,v);
说明:
写入一个beyte
参数:
name | type | describe
p | pointer | 内存地址
v | integer | 值


writebytes

tvclib/utslvclfackinterface/aefclassobj_/writebytes

定义: public writebytes(p,sz,v);
说明:
写入一组short
参数:
name | type | describe
p | pointer | 内存地址
sz |  |
v |  |


writedouble

tvclib/utslvclfackinterface/aefclassobj_/writedouble

定义: public writedouble(p,v);
说明:
读取一个double
参数:
name | type | describe
p | pointer | 内存地址
v |  |


writellong

tvclib/utslvclfackinterface/aefclassobj_/writellong

定义: public writellong(p,v);
说明:
写入一个long
参数:
name | type | describe
p | pointer | 内存地址
v |  |


writeshort

tvclib/utslvclfackinterface/aefclassobj_/writeshort

定义: public writeshort(p,v);
说明:
写入一个short
参数:
name | type | describe
p | pointer | 内存地址
v |  |


writeshorts

tvclib/utslvclfackinterface/aefclassobj_/writeshorts

定义: public writeshorts(p,sz,v);
说明:
写入一组short
参数:
name | type | describe
p | pointer | 内存地址
sz |  |
v |  |


getgdipstatus

tvclib/utslvclgdi/getgdipstatus

定义: getgdipstatus(v);
说明:
获得gdiflat的运行状态说明
参数:
name | type | describe
v | integer | 状态值

返回值:
type | describe
string | 状态说明


gettextwidthandheightwidthfont

tvclib/utslvclgdi/gettextwidthandheightwidthfont

定义: gettextwidthandheightwidthfont(s,f,mul);
说明:
获得文本在给定字体f下的绘制宽高
参数:
name | type | describe
s | string | 文本
f | tfont | 给定字体
mul | bool | 是否多行文本


tcustombitmap

tvclib/utslvclgdi/tcustombitmap

定义:type tcustombitmap= class(tpicturebase);
说明:
bitmap 类
成员函数:
function | private
setid | private
loadsysbmp | protected
destroyhandle | protected
handleallocated | public
draw | public
stretchdraw | public
readvcon | public
tovcon | public
copyrect | public
toicon | public

propeties:
name | private | read | write | type | describe | index
id | public | fid | setid |  | 资源id |
handle | public | fhandle | sethandle |  | 句柄 |
autodestroy | public | fdestroy | fdestroy |  | 析构时销毁句柄 |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tcustomcanvas

tvclib/utslvclgdi/tcustomcanvas

定义:type tcustomcanvas= class(tsluibase);
说明:
画布对象
成员函数:
function | private
gettextextent | public
selectcliprgn | public
recycling | public
handleallocated | public
requiregdi | public
setviewportorg | public
setpixel | public
fillrgn | public
fillrect | public
invertrect | public
moveto | public
lineto | public
textout | public
drawtext | public
stretchdraw | public
drawbitmap | public
drawicon | public
draw | public
copybitmap | public
setworldtransform | public
setpolyfillmode | public
setbkmode | public
getbkmode | public
settextalign | public
savedc | public
restoredc | public

propeties:
name | private | read | write | type | describe
pen | public | fpen | setpen | tcustompen | 画笔
font | public | ffont | setfont | tcustomfont | 字体
brush | public | fbrush | setbrush | tbrush | 画刷
bkmode | public |  | setbkmode | integer | 背景样式 OPAQUE or TRANSPARENT 默认 TRANSPARENT
textmetric | public | ftextmetrica |  | ttagtextmetrica | 文本样式信息

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tcustomcontrolimagelist

tvclib/utslvclgdi/tcustomcontrolimagelist

定义:type tcustomcontrolimagelist= class(tcustomimagelist);
说明:
控件imagleit
成员函数:
function | private
handlechanged | public
deletecontrol | public
recycling | public

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • change
  • sethandle
  • handleallocated
  • destroyhandle
  • addbmp
  • addicon
  • draw
  • removeimge
  • replaceimge
  • geticon
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | write | type | describe
handle | public | handleneeded | sethandle | himagelis | imagelist句柄
autodestroy | public | fautodestroy | fautodestroy | bool | 是否销毁句柄
imagecount | public | fimagecount |  | integer | 图标数量
height | public | fheight | setheight | integer |
width | public | fwidth | setwidth | integer |
imgheight | public | fheight | setheight | integer |
imgwidth | public | fwidth | setwidth | integer |
onchange | public | fonchange | fonchange | function[tcustomimagelist] | 改变时的回调
bkcolor | public | fbkcolor | setbkcolor | colorref |
images | public | getimages | setimages | imagesdata |
owner | public | fowner |  | tcomponent | 所有者
componentcreated | public | fcomponentcreated |  | bool | 样式结合
componentstate | public | fcomponentstate | setcomponentstate |  | 状态集合
componentstyle | public | fcomponentstyle |  |  | 样式结合
name | public | fname | setname | string |
ondestroy | public | fondestroy | fondestroy | eventhandler |
onnotification | public | fonnotification | fonnotification | eventhandler |


tcustomcursor

tvclib/utslvclgdi/tcustomcursor

定义:type tcustomcursor= class(tcustomicon);
说明:
光标类
成员函数:
function | private
loadsysico | protected
show | public

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • destroyhandle
  • handleallocated
  • tobitmap
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | write | type | describe | index
id | public | fid | setid | integer|string | 资源id |
handle | public | fhandle | sethandle | intptr | 句柄 |
maskbmp | public | getmaskbitmap |  | tcustombitmap | mask位图 |
colorbmp | public | getcolorbitmap |  | tcustombitmap | color位图 |
autodestroy | public | fdestroy | fdestroy | bool | 是否自动是否资源 |


tcustomfont

tvclib/utslvclgdi/tcustomfont

定义:type tcustomfont= class(tgdi);
成员函数:
function | private
fontinfo | public
copyfont | public
setvalues | public


tcustomicon

tvclib/utslvclgdi/tcustomicon

定义:type tcustomicon= class(tpicturebase);
说明:
图标对象类
成员函数:
function | private
destroyhandle | protected
handleallocated | public
tobitmap | public

propeties:
name | private | read | write | type | describe | index
id | public | fid | setid | integer|string | 资源id |
handle | public | fhandle | sethandle | intptr | 句柄 |
maskbmp | public | getmaskbitmap |  | tcustombitmap | mask位图 |
colorbmp | public | getcolorbitmap |  | tcustombitmap | color位图 |
autodestroy | public | fdestroy | fdestroy | bool | 是否自动是否资源 |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tcustomimage

tvclib/utslvclgdi/tcustomimage

定义:type tcustomimage= class(tsluibase);
说明:
image类采用gdiflat封装
成员函数:
function | private
destroyhandle | public
recycling | public
loadfromfile | public
savetofile | public
imagetostring | public
stringtoimage | public
tohbitmap | public
fromhbitmap | public
fromhicon | public
tohicon | public

propeties:
name | private | read | type | describe
gdi | public | fgdi | tgdiplusflat | gdi对象
handle | public | fhandle | pointer | 句柄

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


tcustomimagelist

tvclib/utslvclgdi/tcustomimagelist

定义:type tcustomimagelist= class(tcomponent);
说明:
imgelist 类封装
成员函数:
function | private
change | private
sethandle | protected
handleallocated | public
destroyhandle | public
addbmp | public
addicon | public
draw | public
removeimge | public
replaceimge | public
geticon | public

propeties:
name | private | read | write | type | describe
handle | public | handleneeded | sethandle | himagelis | imagelist句柄
autodestroy | public | fautodestroy | fautodestroy | bool | 是否销毁句柄
imagecount | public | fimagecount |  | integer | 图标数量
height | public | fheight | setheight | integer |
width | public | fwidth | setwidth | integer |
imgheight | public | fheight | setheight | integer |
imgwidth | public | fwidth | setwidth | integer |
onchange | public | fonchange | fonchange | function[tcustomimagelist] | 改变时的回调
bkcolor | public | fbkcolor | setbkcolor | colorref |
images | public | getimages | setimages | imagesdata |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tfontcontrol

tvclib/utslvclgdi/tfontcontrol

定义:type tfontcontrol= class(tcustomfont);
说明:
控件字体
继承的函数:
  • fontinfo
  • copyfont
  • setvalues


tpicturebase

tvclib/utslvclgdi/tpicturebase

定义:type tpicturebase= class(tsluibase);
说明:
bitmap,ico基类
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


trgn

tvclib/utslvclgdi/trgn

定义:type trgn= class(tsluibase);
说明:
区域
成员函数:
function | private
combinergn | public

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


trgnellip

tvclib/utslvclgdi/trgnellip

定义:type trgnellip= class(trgn);
说明:
椭圆rgn
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • combinergn
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


trgnpoly

tvclib/utslvclgdi/trgnpoly

定义:type trgnpoly= class(trgn);
说明:
多边形区域
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • combinergn
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


trgnrect

tvclib/utslvclgdi/trgnrect

定义:type trgnrect= class(trgnellip);
说明:
矩形区域
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • combinergn
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


trgnroundrect

tvclib/utslvclgdi/trgnroundrect

定义:type trgnroundrect= class(trgnellip);
说明:
RoundRect rgn
propeties:
name | private | type | read | write
ellipsewidth | public | integer | fellipsewidth | setellipsewidth
ellipseheight | public | integer | fellipseheight | setellipseheight

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • combinergn
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


copyrect

tvclib/utslvclgdi/tcustombitmap/copyrect

定义: public copyrect(x,y,w,h);
说明:
拷贝位图
参数:
name
x
y
w
h


destroyhandle

tvclib/utslvclgdi/tcustombitmap/destroyhandle

定义: protected destroyhandle();virtual;
说明:
析构句柄


draw

tvclib/utslvclgdi/tcustombitmap/draw

定义: public draw(dc,x,y,flag,rect);
说明:
粘贴到hdc
参数:
name | type | describe
dc | tcustomcanvas | canvas 对象
x | integer | canvas 中的x位置
y | integer | canvas 中的y位置
flag | member of trasteroperationconst | 光栅操作码
rect | array | bimap 的范围 array(左上右下)


handleallocated

tvclib/utslvclgdi/tcustombitmap/handleallocated

定义: public handleallocated();
说明:
判断是有句柄
返回值:
type | describe
bool |


loadsysbmp

tvclib/utslvclgdi/tcustombitmap/loadsysbmp

定义: protected class loadsysbmp(id);virtual;
说明:
获取系统的bitmap句柄
参数:
name | type | describe
id | menuber of tsystembitmap | id

返回值:
type | describe
hbitmap | 句柄


readvcon

tvclib/utslvclgdi/tcustombitmap/readvcon

定义: public readvcon(d);override;
参数:
name
d


setid

tvclib/utslvclgdi/tcustombitmap/setid

定义: private setid(id);virtual;
说明:
设置id
参数:
name
id


stretchdraw

tvclib/utslvclgdi/tcustombitmap/stretchdraw

定义: public stretchdraw(dc,drect,flag,brect);
说明:
粘贴到hdc
参数:
name | type | describe
dc | tcustomcanvas | canvas 对象
drect | array | canvas 的范围 array(左上右下)
flag | member of trasteroperationconst | 光栅操作码
brect | array | bimap 的范围 array(左上右下)


toicon

tvclib/utslvclgdi/tcustombitmap/toicon

定义: public toicon();
说明:
将位图转换为icon
返回值:
type | describe
ticon|nil | 成功返回图标


tovcon

tvclib/utslvclgdi/tcustombitmap/tovcon

定义: public tovcon();override;


copybitmap

tvclib/utslvclgdi/tcustomcanvas/copybitmap

定义: public copybitmap(rect);
说明:
获取canvas区域到位图
参数:
name
rect


draw

tvclib/utslvclgdi/tcustomcanvas/draw

定义: public draw(name_,points,f,m);
说明:
gdi画图函数
参数:
name | type | describe
name_ | string | 图形名称, rectangle 矩形 ;ellipse 椭圆;roundrect 圆角矩形;chord 弧线 ;pie 饼 ;polybezier 贝塞尔 ;polygon多条直线
points | array | 点数组 例如 array((0,0),(1,2)) 表述两个点的数组,点的多少根据name_参数确定
f | integer | 作图辅助参数 在画弧线的时候会用到的方向
m | integer | 在polypolyline 使用表示绘图样式


drawbitmap

tvclib/utslvclgdi/tcustomcanvas/drawbitmap

定义: public drawbitmap(bmp,p);
说明:
绘制bitmap
参数:
name | type | describe
bmp | tcustombitmap | 图标
p | array of integer | 位置 array(x,y)


drawicon

tvclib/utslvclgdi/tcustomcanvas/drawicon

定义: public drawicon(ico,p);
说明:
绘制icon
参数:
name | type | describe
ico | ticon | 图标
p | array of integer | 位置 array(x,y)


drawtext

tvclib/utslvclgdi/tcustomcanvas/drawtext

定义: public drawtext(str,rec,uft);
说明:
在指定区域上输出文本
参数:
name | type | describe
str | string | 绘制的文字
rec | array | array(left,top,right,bottom)
uft | integer | DT_CALCRECT：这个参数比较重要，可以使DrawText函数计算出输出文本的尺寸。如果输出文本有多行，DrawText函数使用lpRect定义的矩形的宽度，并扩展矩形的底部以容纳输出文本的最后一行。如果输出文本只有一行，则DrawText函数改变矩形的右边界，以容纳下正文行的最后一个字符。出现上述任何一种情况，DrawText函数将返回格式化文本的高度，而不是绘制文本。 DT_CENTER：指定文本水平居中显示。 DT_VCENTER：指定文本垂直居中显示。该标记只在单行文本输出时有效，所以它必须与DT_SINGLELINE结合使用。 DT_SINGLELINE：单行显示文本，回车和换行符都不断行。


fillrect

tvclib/utslvclgdi/tcustomcanvas/fillrect

定义: public fillrect(rec);
说明:
填充rect
参数:
name | type | describe
rec | array | 区域 array(左,上,右,下)


fillrgn

tvclib/utslvclgdi/tcustomcanvas/fillrgn

定义: public fillrgn(rgn);
说明:
区域填充
参数:
name | type | describe
rgn | trgn | 区域


getbkmode

tvclib/utslvclgdi/tcustomcanvas/getbkmode

定义: public getbkmode();
说明:
文本背景样式
返回值:
type | describe
integer | 背景样式


gettextextent

tvclib/utslvclgdi/tcustomcanvas/gettextextent

定义: public gettextextent(s,mul);
说明:
获得 字符串绘制宽度和高度
参数:
name | type | describe
s | string | 字符串
mul | bool | 多行 默认多行true


handleallocated

tvclib/utslvclgdi/tcustomcanvas/handleallocated

定义: public handleallocated();
说明:
判断canvas句柄是否构造
返回值:
type | describe
bool |


invertrect

tvclib/utslvclgdi/tcustomcanvas/invertrect

定义: public invertrect(rec);
说明:
反向填充区域
参数:
name | type | describe
rec | array | 区域 array(左,上,右,下)


lineto

tvclib/utslvclgdi/tcustomcanvas/lineto

定义: public lineto(pos);
说明:
画线到点
参数:
name | type | describe
pos | array | 位置array(x,y)


moveto

tvclib/utslvclgdi/tcustomcanvas/moveto

定义: public moveto(pos);
说明:
移动当前点
参数:
name | type | describe
pos | array | 位置array(x,y)

返回值:
type | describe
array | 原来位置


recycling

tvclib/utslvclgdi/tcustomcanvas/recycling

定义: public recycling();override;
说明:
资源回收


requiregdi

tvclib/utslvclgdi/tcustomcanvas/requiregdi

定义: public requiregdi(rq);
说明:
初始化gdi对象 如画刷 画笔 等
参数:
name
rq


restoredc

tvclib/utslvclgdi/tcustomcanvas/restoredc

定义: public restoredc();
说明:
还原dc


savedc

tvclib/utslvclgdi/tcustomcanvas/savedc

定义: public savedc();
说明:
保存当前的dc


selectcliprgn

tvclib/utslvclgdi/tcustomcanvas/selectcliprgn

定义: public selectcliprgn(rgn);
说明:
设置区域
参数:
name | type | describe
rgn | trgn | 选择区域


setbkmode

tvclib/utslvclgdi/tcustomcanvas/setbkmode

定义: public setbkmode(m);
说明:
文本背景样式
参数:
name | type | describe
m | integer | 背景样式OPAQUE or TRANSPARENT


setpixel

tvclib/utslvclgdi/tcustomcanvas/setpixel

定义: public setpixel(xy,colr);
说明:
画一个像素
参数:
name | type | describe
xy | array | array(x,y)
colr | integer | 颜色rgb值

返回值:
type | describe
integer |


setpolyfillmode

tvclib/utslvclgdi/tcustomcanvas/setpolyfillmode

定义: public setpolyfillmode(md);
说明:
设置填充模式
参数:
name | type | describe
md | integer | 填充模式 ALTERNA WINDING


settextalign

tvclib/utslvclgdi/tcustomcanvas/settextalign

定义: public settextalign(fmt);
说明:
文字对其方式
参数:
name type describe
fmt integer 对其方式TA_LEFT;
TA_RIGHT;
TA_CENTER;
TA_TOP;
TA_BOTTOM;默认左对齐


setviewportorg

tvclib/utslvclgdi/tcustomcanvas/setviewportorg

定义: public setviewportorg(xy);
说明:
设置选择基准点
参数:
name | type | describe
xy | array | array(x,y)

返回值:
type | describe
integer |


setworldtransform

tvclib/utslvclgdi/tcustomcanvas/setworldtransform

定义: public setworldtransform(trans);
说明:
文本旋转
参数:
name | type | describe
trans | array | array(cos,-sin,sin,cos,x,y)


stretchdraw

tvclib/utslvclgdi/tcustomcanvas/stretchdraw

定义: public stretchdraw(rec,bmp);
说明:
绘制bitmap
参数:
name | type | describe
rec | array of integer | array(左,上,右,下)
bmp | tcustombitmap | 位图


textout

tvclib/utslvclgdi/tcustomcanvas/textout

定义: public textout(str,pos);
说明:
输出文本
参数:
name | type | describe
str | string | 字符串
pos | array | 位置array(x,y)


deletecontrol

tvclib/utslvclgdi/tcustomcontrolimagelist/deletecontrol

定义: public deletecontrol(v);
说明:
删除控件
参数:
name
v


handlechanged

tvclib/utslvclgdi/tcustomcontrolimagelist/handlechanged

定义: public handlechanged();virtual;
说明:
句柄发生变化


recycling

tvclib/utslvclgdi/tcustomcontrolimagelist/recycling

定义: public recycling();override;
说明:
回收空间


loadsysico

tvclib/utslvclgdi/tcustomcursor/loadsysico

定义: protected class loadsysico(id);override;
参数:
name | type | describe
id | member of tsystemcursor | cursor id

返回值:
type | describe
pointer | 句柄


show

tvclib/utslvclgdi/tcustomcursor/show

定义: public show();override;
说明:
显示光标


copyfont

tvclib/utslvclgdi/tcustomfont/copyfont

定义: public copyfont(f);virtual;
说明:
字体信息拷贝
参数:
name | type
f | tcostmtont


fontinfo

tvclib/utslvclgdi/tcustomfont/fontinfo

定义: public fontinfo();
说明:
获得字体信息


setvalues

tvclib/utslvclgdi/tcustomfont/setvalues

定义: public setvalues(vs);virtual;
说明:
通过数组设置字体属性
参数:
name | type | describe
vs | array | 字体信息数据


destroyhandle

tvclib/utslvclgdi/tcustomicon/destroyhandle

定义: protected destroyhandle();virtual;
说明:
析构句柄
返回值:
type | describe
bool |


handleallocated

tvclib/utslvclgdi/tcustomicon/handleallocated

定义: public handleallocated();
说明:
判断是有句柄


tobitmap

tvclib/utslvclgdi/tcustomicon/tobitmap

定义: public tobitmap();
说明:
将ico转换为bitmap
返回值:
type | describe
nil|tcustombitmap |


destroyhandle

tvclib/utslvclgdi/tcustomimage/destroyhandle

定义: public destroyhandle();
说明:
销毁句柄


fromhbitmap

tvclib/utslvclgdi/tcustomimage/fromhbitmap

定义: public fromhbitmap(bmp);
说明:
从bitmap得到图片
参数:
name | type | describe
bmp | pointer | hbitmap


fromhicon

tvclib/utslvclgdi/tcustomimage/fromhicon

定义: public fromhicon(ico);
说明:
从hicon得到图片
参数:
name | type | describe
ico | pointer | hicon


imagetostring

tvclib/utslvclgdi/tcustomimage/imagetostring

定义: public imagetostring(t);
说明:
得到图片内存
参数:
name | type | describe
t | string | png bmp


loadfromfile

tvclib/utslvclgdi/tcustomimage/loadfromfile

定义: public loadfromfile(path);
说明:
打开文件
参数:
name | type | describe
path | string | 路径


recycling

tvclib/utslvclgdi/tcustomimage/recycling

定义: public recycling();override;
说明:
回收


savetofile

tvclib/utslvclgdi/tcustomimage/savetofile

定义: public savetofile(p,t);
说明:
保存到文件
参数:
name | type | describe
p | string | 路径
t | string | 类型 ,"png" "bmp" "gif"


stringtoimage

tvclib/utslvclgdi/tcustomimage/stringtoimage

定义: public stringtoimage(b);
说明:
从字符串到图片
参数:
name | type | describe
b | string | 内存


tohbitmap

tvclib/utslvclgdi/tcustomimage/tohbitmap

定义: public tohbitmap();
说明:
转换为bitmap
返回值:
type | describe
pointer |


tohicon

tvclib/utslvclgdi/tcustomimage/tohicon

定义: public tohicon();
说明:
得到hcion
返回值:
type | describe
pointer | hicon


addbmp

tvclib/utslvclgdi/tcustomimagelist/addbmp

定义: public addbmp(bmp);
说明:
添加bitmap 到imagelist
参数:
name | type
bmp | tcustombitmap


addicon

tvclib/utslvclgdi/tcustomimagelist/addicon

定义: public addicon(ico);
说明:
添加图标
参数:
name
ico


change

tvclib/utslvclgdi/tcustomimagelist/change

定义: private change();virtual;
说明:
修改时的回调


destroyhandle

tvclib/utslvclgdi/tcustomimagelist/destroyhandle

定义: public destroyhandle();
说明:
销毁句柄


draw

tvclib/utslvclgdi/tcustomimagelist/draw

定义: public draw(i,dc,x,y,flag);
说明:
绘制imge
参数:
name | type | describe
i | integer | 序号
dc | tcustomcanvas | dc 对象
x | integer | x坐标
y | integer | y坐标
flag | member of timagelistdrawstyle | 标记


geticon

tvclib/utslvclgdi/tcustomimagelist/geticon

定义: public geticon(i,flag);
说明:
获取ticon 对象
参数:
name | type | describe
i | integer | 序号
flag | member of timagelistdrawstyle | 样式


handleallocated

tvclib/utslvclgdi/tcustomimagelist/handleallocated

定义: public handleallocated();
说明:
句柄是否有效


removeimge

tvclib/utslvclgdi/tcustomimagelist/removeimge

定义: public removeimge(i);
说明:
删除
参数:
name
i


replaceimge

tvclib/utslvclgdi/tcustomimagelist/replaceimge

定义: public replaceimge(i,btmap,msk);
说明:
替换 image
参数:
name | type | describe
i | integer | 位置
btmap | tcustombitmap | 位图
msk | tbitmap|hbitmap | mask


sethandle

tvclib/utslvclgdi/tcustomimagelist/sethandle

定义: protected sethandle(h);
说明:
设置句柄
参数:
name
h


combinergn

tvclib/utslvclgdi/trgn/combinergn

定义: public class combinergn(rgn1,rgn2,f,rgn);
说明:
rgn合并
参数:
name | type | describe
rgn1 | trgn | 区域1
rgn2 | trgn | 区域2
f | integer | 合并方式 RGN_AND RGN_COPY RGN_DIFF RGN_OR RGN_XOR
rgn | trgn | 返回合并后的区域


tcustomgridctl

tvclib/utslvclgrid/tcustomgridctl

定义:type tcustomgridctl= class(tcustomscrollcontrol);
说明:
自绘制表格控件
成员函数:
function | private
getitemrect | public
getitemstarty | public
getitemybound | public
getsubitemrect | public
getturesubitemrect | public
getcolindexbypos | public
invalidateitem | public
invalidatesubitem | public
getindexbypos | public
getrowindexbypos | public
setcolumns | public
getcolumnwidth | public
setcolumnwidth | public
drawcell | public
getrowheight | public
mergecells | public
getmergeinfo | public
cleanmergecells | public

propeties:
name | private | read | type | write | describe
itemcount | public | getitemcount | integer | setitemcount | 行数
itemheight | public | frowheight | integer | setrowheigt | 行高,固定高度情况下使用
mousesizecell | public | fmousesizecolumnwidth | bool | setmousesizetype | 鼠标改变列宽
fixedrows | public | ffixedrows | integer | setfixedrows | 固定的行数作为列标
fixedcolumns | public | fcolumfixed | integer | setfixedcolumns | 固定的列数作为列标
columncount | public | getcolumncount | integer | setcolumncount | 列数
ondrawcell | public | fondrawcell | function[o,e] | fondrawcell | 绘制回调,e.row 行号,e.col 列号,e.rec 绘制区域,e.canvas 绘画对象
onhitcellsizer | public | fonhitcellsizer | function[o,e] | fonhitcellsizer | 鼠标移动到边线时候回调,e.wparam 1,2 表示行列,e.lparam 代表对于序号,e.skip是的值作为返回表示是否忽略调整大小
mergeinfo | public | getmergeinfo | array | setmergeinfo | 合并信息,二维数组,每行为一个合并信息array(开始行,开始列,截止行,截止列)

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tgriddrawcellevent

tvclib/utslvclgrid/tgriddrawcellevent

定义:type tgriddrawcellevent= class(tuieventbase);
说明:
单元格绘制消息对象
成员变量:
name | private | type | describe
row | public | integer | 行号
col | public | integer | 列号
rec | public | array(左上右下 | ) 区域
canvas | public | tcanvas | 画布

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


cleanmergecells

tvclib/utslvclgrid/tcustomgridctl/cleanmergecells

定义: public cleanmergecells(rc);
说明:
清空合并信息
参数:
name | type | describe
rc | array(行,列 | )指定清除的合并格子


drawcell

tvclib/utslvclgrid/tcustomgridctl/drawcell

定义: public drawcell(cvs,rec,i,j);virtual;
说明:
绘制单元格
参数:
name | type | describe
cvs | tcustomcanvas | 画布
rec | array | array(左上右下)
i | integer | 行号
j | integer | 列号


getcolindexbypos

tvclib/utslvclgrid/tcustomgridctl/getcolindexbypos

定义: public getcolindexbypos(x);virtual;
说明:
通过坐标获得 列号
参数:
name | type | describe
x | integer | 坐标

返回值:
type | describe
integer | 行号


getcolumnwidth

tvclib/utslvclgrid/tcustomgridctl/getcolumnwidth

定义: public getcolumnwidth(i);
说明:
获得第i列宽度
参数:
name | type | describe
i | integer | 列号

返回值:
type | describe
integer | 宽度


getindexbypos

tvclib/utslvclgrid/tcustomgridctl/getindexbypos

定义: public getindexbypos(x,y);
说明:
根据位置获得行列
参数:
name | type | describe
x | integer | x坐标
y | integer | y坐标

返回值:
type | describe
0|array(r,c | ) 行列


getitemrect

tvclib/utslvclgrid/tcustomgridctl/getitemrect

定义: public getitemrect(i);virtual;
说明:
获得行的区域
参数:
name | type | describe
i | integer | 行号

返回值:
type | describe
array | array(左,上,右,下);


getitemstarty

tvclib/utslvclgrid/tcustomgridctl/getitemstarty

定义: public getitemstarty(i);virtual;
说明:
获得行的区域范围
参数:
name | type | describe
i | integer | 行号

返回值:
type | describe
array | array(上,下);


getitemybound

tvclib/utslvclgrid/tcustomgridctl/getitemybound

定义: public getitemybound(i);virtual;
说明:
获得行的区域范围
参数:
name | type | describe
i | integer | 行号

返回值:
type | describe
array | array(上,下);


getmergeinfo

tvclib/utslvclgrid/tcustomgridctl/getmergeinfo

定义: public getmergeinfo();
说明:
获得合并信息


getrowheight

tvclib/utslvclgrid/tcustomgridctl/getrowheight

定义: public getrowheight(idx);
说明:
获得行高
参数:
name
idx


getrowindexbypos

tvclib/utslvclgrid/tcustomgridctl/getrowindexbypos

定义: public getrowindexbypos(y);virtual;
说明:
通过坐标获得 行号
参数:
name | type | describe
y | integer | 坐标

返回值:
type | describe
integer | 行号


getsubitemrect

tvclib/utslvclgrid/tcustomgridctl/getsubitemrect

定义: public getsubitemrect(i,j);virtual;
说明:
获得cell的范围
参数:
name | type | describe
i | integer | 行号
j | integer | 列号

返回值:
type | describe
array | array(左,上,右,下);


getturesubitemrect

tvclib/utslvclgrid/tcustomgridctl/getturesubitemrect

定义: public getturesubitemrect(i,j);
说明:
获得真实的格子区域 ,在有合并表格中使用
参数:
name
i
j


invalidateitem

tvclib/utslvclgrid/tcustomgridctl/invalidateitem

定义: public invalidateitem(i);virtual;
说明:
刷新行
参数:
name | type | describe
i | integer | 行号


invalidatesubitem

tvclib/utslvclgrid/tcustomgridctl/invalidatesubitem

定义: public invalidatesubitem(i,j);virtual;
说明:
刷新cell的范围
参数:
name | type | describe
i | integer | 行号
j | integer | 列号


mergecells

tvclib/utslvclgrid/tcustomgridctl/mergecells

定义: public mergecells(cells);
说明:
单元格
参数:
name | type | describe
cells | array | array(开始行,开始列,结束行,结束列)


setcolumns

tvclib/utslvclgrid/tcustomgridctl/setcolumns

定义: public setcolumns(cls,beg,len);virtual;
说明:
设置列宽信息
参数:
name | type | describe
cls | array of integer | 列宽
beg | integer | 开始位置
len | integer | 替代长度


setcolumnwidth

tvclib/utslvclgrid/tcustomgridctl/setcolumnwidth

定义: public setcolumnwidth(i,w);
说明:
设置列宽
参数:
name | type | describe
i | integer | 列序号
w | integer | 新宽度 0


tbrowseinfoa

tvclib/utslvclmemstruct/tbrowseinfoa

定义:type tbrowseinfoa= class(tcstructwithcharptr);
说明:
文件夹选择结构构造
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • _setvalue_
  • _getvalue_
  • _getdata_
  • setstringi
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


tbrowseinfoa_

tvclib/utslvclmemstruct/tbrowseinfoa_

定义:type tbrowseinfoa_= class(tslcstructureobj);
说明:
文件夹选择结构读取
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


tcrect

tvclib/utslvclmemstruct/tcrect

定义:type tcrect= class(tslcstructureobj);
说明:
矩形区域内存分配
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


tpaintstruct

tvclib/utslvclmemstruct/tpaintstruct

定义:type tpaintstruct= class(tslcstructureobj);
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


ttagchoosecolora

tvclib/utslvclmemstruct/ttagchoosecolora

定义:type ttagchoosecolora= class(tslcstructureobj);
说明:
颜色选择结构体类
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


ttagchoosefonta

tvclib/utslvclmemstruct/ttagchoosefonta

定义:type ttagchoosefonta= class(tslcstructureobj);
说明:
字体选择结构体
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


ttaglogfonta

tvclib/utslvclmemstruct/ttaglogfonta

定义:type ttaglogfonta= class(tslcstructureobj);
说明:
逻辑字体对象结构表示
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


ttagmsg

tvclib/utslvclmemstruct/ttagmsg

定义:type ttagmsg= class(tslcstructureobj);
说明:
消息循环对象类
继承的变量:
name | private | type | describe | static
_blocks | protected | array | 分配的内存块;以地址为索引的数组,值为分配的大小 |
_tool | protected | aefclassobj_ | 内存管理底层工具 | static

继承的函数:
  • create
  • operator [1]
  • operator []
  • create
  • _getptr2_
  • _getptr_
  • _setcptr_
  • _size_
  • arraynumberchek
  • _getvalue_
  • _getvalueaddr_
  • _getvalueaddr2_
  • _getdata_
  • copytostring
  • copyfromstring
  • getpointersize
  • opblocks
  • tmalloc
  • tfree
  • trealloc
  • mtool


tcustommainmenu

tvclib/utslvclmenu/tcustommainmenu

定义:type tcustommainmenu= class(tcustommenu);
说明:
主菜单类
propeties:
name | private | type | read | write | describe
hwnd | public |  | fwndhandle | setwndhandle | 窗口句柄

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getactionlinkclass
  • handleneeded
  • sinit
  • dispatch
  • handleallocated
  • destroyhandle
  • createmenu
  • createhandle
  • recycling
  • removefromparent
  • indexof
  • getitembyindex
  • setmenuiteminfo
  • insertitem
  • removeitembyindex
  • recyclingallitems
  • removeitem
  • setchangedpublish
  • menuchanged
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe | index
action | public | taction | getaction | setaction | action对象 |
caption | public | string | fcaption | setcaption | 菜单显示文字 |
enabled | public | bool | fenabled | setenabled |  |
itemcount | public | integer | getitemcount |  | 菜单子项个数 |
handle | public | pointer | handleneeded |  | 菜单句柄 |
parent | public | tcustommenu|nil | fparent | setparentforproperty | 添加父节点,如果非tmenu,从父节点移除 |
command | public | integer | fcommand |  | 菜单id |
bitmap | public | tbitmap | fbitmap | setbitmap |  |
onclick | public | function[tcustommenu,tuieventbase] | fonclick | fonclick | 菜单点击回调函数 |
tseparator | public | bool | getmenutype | setmenutype |  | 0x800
townerdraw | public | bool | getmenutype | setmenutype |  | 0x100
checked | public | bool | fchecked | setchecked |  |
ondrawitem | public | function[tcustommenu,tmdrawitem] | fondrawitem | fondrawitem | 自绘制菜单回调函数 |
onmeasureitem | public | function[tcustommenu,tmmeasureitem] | fonmeasureitem | fonmeasureitem | 自绘制菜单高度宽度设置回调函数 |
onselect | public | function[tcustommenu,tmmenuselect] | fonselect | fonselect | 菜单被鼠标选中回调函数 |
oninitmenupopup | public | function[tcustommenu,tuieventbase] | foninitmenupopup | foninitmenupopup | 进入菜单循环菜单回调函数 |
onrbuttonup | public | function[tcustommenu,tuieventbase] | fonrbuttonup | fonrbuttonup | 菜单右击回调函数 |
owner | public | tcomponent | fowner |  | 所有者 |
componentcreated | public | bool | fcomponentcreated |  | 样式结合 |
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合 |
componentstyle | public |  | fcomponentstyle |  | 样式结合 |
name | public | string | fname | setname |  |
ondestroy | public | eventhandler | fondestroy | fondestroy |  |
onnotification | public | eventhandler | fonnotification | fonnotification |  |


tcustommenu

tvclib/utslvclmenu/tcustommenu

定义:type tcustommenu= class(tcomponent);
说明:
菜单类
成员函数:
function | private
getactionlinkclass | protected
handleneeded | protected
sinit | public
dispatch | public
handleallocated | public
destroyhandle | public
createmenu | public
createhandle | public
recycling | public
removefromparent | public
indexof | public
getitembyindex | public
setmenuiteminfo | public
insertitem | public
removeitembyindex | public
recyclingallitems | public
removeitem | public
setchangedpublish | public
menuchanged | public

propeties:
name | private | type | read | write | describe | index
action | public | taction | getaction | setaction | action对象 |
caption | public | string | fcaption | setcaption | 菜单显示文字 |
enabled | public | bool | fenabled | setenabled |  |
itemcount | public | integer | getitemcount |  | 菜单子项个数 |
handle | public | pointer | handleneeded |  | 菜单句柄 |
parent | public | tcustommenu|nil | fparent | setparentforproperty | 添加父节点,如果非tmenu,从父节点移除 |
command | public | integer | fcommand |  | 菜单id |
bitmap | public | tbitmap | fbitmap | setbitmap |  |
onclick | public | function[tcustommenu,tuieventbase] | fonclick | fonclick | 菜单点击回调函数 |
tseparator | public | bool | getmenutype | setmenutype |  | 0x800
townerdraw | public | bool | getmenutype | setmenutype |  | 0x100
checked | public | bool | fchecked | setchecked |  |
ondrawitem | public | function[tcustommenu,tmdrawitem] | fondrawitem | fondrawitem | 自绘制菜单回调函数 |
onmeasureitem | public | function[tcustommenu,tmmeasureitem] | fonmeasureitem | fonmeasureitem | 自绘制菜单高度宽度设置回调函数 |
onselect | public | function[tcustommenu,tmmenuselect] | fonselect | fonselect | 菜单被鼠标选中回调函数 |
oninitmenupopup | public | function[tcustommenu,tuieventbase] | foninitmenupopup | foninitmenupopup | 进入菜单循环菜单回调函数 |
onrbuttonup | public | function[tcustommenu,tuieventbase] | fonrbuttonup | fonrbuttonup | 菜单右击回调函数 |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tcustompopupmenu

tvclib/utslvclmenu/tcustompopupmenu

定义:type tcustompopupmenu= class(tcustommenu);
说明:
弹出菜单
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getactionlinkclass
  • handleneeded
  • sinit
  • dispatch
  • handleallocated
  • destroyhandle
  • createmenu
  • createhandle
  • recycling
  • removefromparent
  • indexof
  • getitembyindex
  • setmenuiteminfo
  • insertitem
  • removeitembyindex
  • recyclingallitems
  • removeitem
  • setchangedpublish
  • menuchanged
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe | index
action | public | taction | getaction | setaction | action对象 |
caption | public | string | fcaption | setcaption | 菜单显示文字 |
enabled | public | bool | fenabled | setenabled |  |
itemcount | public | integer | getitemcount |  | 菜单子项个数 |
handle | public | pointer | handleneeded |  | 菜单句柄 |
parent | public | tcustommenu|nil | fparent | setparentforproperty | 添加父节点,如果非tmenu,从父节点移除 |
command | public | integer | fcommand |  | 菜单id |
bitmap | public | tbitmap | fbitmap | setbitmap |  |
onclick | public | function[tcustommenu,tuieventbase] | fonclick | fonclick | 菜单点击回调函数 |
tseparator | public | bool | getmenutype | setmenutype |  | 0x800
townerdraw | public | bool | getmenutype | setmenutype |  | 0x100
checked | public | bool | fchecked | setchecked |  |
ondrawitem | public | function[tcustommenu,tmdrawitem] | fondrawitem | fondrawitem | 自绘制菜单回调函数 |
onmeasureitem | public | function[tcustommenu,tmmeasureitem] | fonmeasureitem | fonmeasureitem | 自绘制菜单高度宽度设置回调函数 |
onselect | public | function[tcustommenu,tmmenuselect] | fonselect | fonselect | 菜单被鼠标选中回调函数 |
oninitmenupopup | public | function[tcustommenu,tuieventbase] | foninitmenupopup | foninitmenupopup | 进入菜单循环菜单回调函数 |
onrbuttonup | public | function[tcustommenu,tuieventbase] | fonrbuttonup | fonrbuttonup | 菜单右击回调函数 |
owner | public | tcomponent | fowner |  | 所有者 |
componentcreated | public | bool | fcomponentcreated |  | 样式结合 |
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合 |
componentstyle | public |  | fcomponentstyle |  | 样式结合 |
name | public | string | fname | setname |  |
ondestroy | public | eventhandler | fondestroy | fondestroy |  |
onnotification | public | eventhandler | fonnotification | fonnotification |  |


tmenuactionlink

tvclib/utslvclmenu/tmenuactionlink

定义:type tmenuactionlink= class(tcontrolactionlink);
说明:
菜单actionlink
成员函数:
function | private
assignclient | protected

继承的变量:
name | type | private | static | describe
fclient | tcontrol | protected |  |
faction | tbasicaction | public |  |
_wapi | tswin32api | public | static | win32宏定义,以及api接口
_tag | any | public |  | 调用者使用的成员变量
alnone | constant | public | static | 不对齐
altop | constant | public | static | 上
albottom | constant | public | static | 下
alleft | constant | public | static | 左对齐
alright | constant | public | static | 右对齐
alclient | constant | public | static | 占满
aktop | constant | public | static | 上
akleft | constant | public | static | 左
akright | constant | public | static | 右
akbottom | constant | public | static | 下
mbleft | constant | public | static | 左键
mbright | constant | public | static | 右键
mbmiddle | constant | public | static | 中间按键
ssshift | constant | public | static | shift
ssalt | constant | public | static | alt
ssctrl | constant | public | static | ctl
ssdouble | constant | public | static | 双击
al9_default | constant | public | static | 默认
al9_topleft | constant | public | static | 顶部
al9_center | constant | public | static | 居
al3_left | constant | public | static | 左
al3_right | constant | public | static | 右
al3_center | constant | public | static | 居中
idc_arrow | constant | public | static | 类型

继承的函数:
  • assignclient
  • execute
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
action | public | taction | faction | setaction | action对象
onchange | public | function[sender:tcomponent] | fonchange | fonchange | 改变的回调


createhandle

tvclib/utslvclmenu/tcustommenu/createhandle

定义: public createhandle();
说明:
更新节点句柄


createmenu

tvclib/utslvclmenu/tcustommenu/createmenu

定义: public createmenu();virtual;
说明:
构造菜单句柄,通过overrid此函数实现不同类型菜单构造
返回值:
type | describe
pointer | 句柄


destroyhandle

tvclib/utslvclmenu/tcustommenu/destroyhandle

定义: public destroyhandle();
说明:
销毁菜单句柄


dispatch

tvclib/utslvclmenu/tcustommenu/dispatch

定义: public dispatch(e);override;
说明:
菜单消息分发
参数:
name | type | describe
e | tuieventbase | 消息对象


getactionlinkclass

tvclib/utslvclmenu/tcustommenu/getactionlinkclass

定义: protected getactionlinkclass();virtual;
说明:
返回actionlinkclass
返回值:
type | describe
tmenuactionlink class |


getitembyindex

tvclib/utslvclmenu/tcustommenu/getitembyindex

定义: public getitembyindex(idx);
说明:
根据序号id 获得菜单
参数:
name | type | describe
idx | integer | 序号id

返回值:
type | describe
tcustommenu|nil | 如果存在返回菜单项,如果不错返回nil


handleallocated

tvclib/utslvclmenu/tcustommenu/handleallocated

定义: public handleallocated();
说明:
菜单句柄是否已有效


handleneeded

tvclib/utslvclmenu/tcustommenu/handleneeded

定义: protected handleneeded();
说明:
获取节点句柄,必须有子节点
返回值:
type | describe
pointer | 节点句柄


indexof

tvclib/utslvclmenu/tcustommenu/indexof

定义: public indexof(item);
说明:
查看对象位置
参数:
name | type | describe
item | tcustommenu | nil | 如为nil 返回在自己在父节点位置,为菜单返回该菜单,在本菜单的位置


insertitem

tvclib/utslvclmenu/tcustommenu/insertitem

定义: public insertitem(item,bef);virtual;
说明:
添加节点
参数:
name | type | describe
item | tcustommenu | 待添加的节点
bef | tcustommenu | integer | 基准位置


menuchanged

tvclib/utslvclmenu/tcustommenu/menuchanged

定义: public menuchanged();virtual;
说明:
菜单改变时的回调


recycling

tvclib/utslvclmenu/tcustommenu/recycling

定义: public recycling();override;
说明:
菜单资源回收


recyclingallitems

tvclib/utslvclmenu/tcustommenu/recyclingallitems

定义: public recyclingallitems();
说明:
销毁当前节点的 所有子节点,子节点不可以再被使用


removefromparent

tvclib/utslvclmenu/tcustommenu/removefromparent

定义: public removefromparent();
说明:
从父节点中删除自己


removeitem

tvclib/utslvclmenu/tcustommenu/removeitem

定义: public removeitem(item);virtual;
说明:
删除节点
参数:
name | type | describe
item | tcustommenu | 将删除的菜单项


removeitembyindex

tvclib/utslvclmenu/tcustommenu/removeitembyindex

定义: public removeitembyindex(idx);
说明:
根据序号删除子菜单
参数:
name | type | describe
idx | integer | 序号id


setchangedpublish

tvclib/utslvclmenu/tcustommenu/setchangedpublish

定义: public setchangedpublish(n,v,pp);virtual;
说明:
设计器相关函数
参数:
name
n
v
pp


setmenuiteminfo

tvclib/utslvclmenu/tcustommenu/setmenuiteminfo

定义: public setmenuiteminfo(idx,mv,vid,vv);
说明:
设置菜单信息
参数:
name | type | describe
idx |  |
mv | integer | mask
vid | string | 下标
vv |  | 值


sinit

tvclib/utslvclmenu/tcustommenu/sinit

定义: public class sinit();override;
说明:
初始化类成员


assignclient

tvclib/utslvclmenu/tmenuactionlink/assignclient

定义: protected assignclient(aclient);override;
说明:
赋值control
参数:
name | type
aclient | tcontrol


tcustompagecontrol

tvclib/utslvclpage/tcustompagecontrol

定义:type tcustompagecontrol= class(tcustomcontrol);
成员函数:
function | private
getsheetrect | public
getpageid | public
settabtext | public
settabindex | public

propeties:
name | private | type | read | write | describe
cursel | public | integer | fcurrentid | setcursel | 当前选中序号
onselchanged | public | eventhandler | fonselchanged | fonselchanged |
onselchanging | public | function[tcustompagecontrol,tuieventbase] | fonselchanging | fonselchanging | 标签正在切换
tabcount | public | integer | gettabcount |  | page数量
tabposition | public | tabalign | ftabposition | settabposition |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomtabsheet

tvclib/utslvclpage/tcustomtabsheet

定义:type tcustomtabsheet= class(tcustomcontrol);
说明:
page控件页面
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


getpageid

tvclib/utslvclpage/tcustompagecontrol/getpageid

定义: public getpageid(page);
说明:
获取page的序号
参数:
name
page


getsheetrect

tvclib/utslvclpage/tcustompagecontrol/getsheetrect

定义: public getsheetrect();
说明:
获得sheet可视区域
返回值:
type | describe
array | array(左,上,右,下)


settabindex

tvclib/utslvclpage/tcustompagecontrol/settabindex

定义: public settabindex(aindex,aindexnew);
说明:
修改标签的次序
参数:
name | type | describe
aindex | integer | 位置
aindexnew | integer | 新位置


settabtext

tvclib/utslvclpage/tcustompagecontrol/settabtext

定义: public settabtext(i,value);
说明:
修改tab标签文字
参数:
name | type | describe
i | integer | 序号
value | string | 文本


tcustombtn

tvclib/utslvclstdctl/tcustombtn

定义:type tcustombtn= class(tcustomcontrol);
说明:
普通按钮
成员函数:
function | private
click | public
dosetfocus | public
dokillfocus | public

propeties:
name | private | type | read | write | describe
textpos | public | member of talignstyle9 | ftextposition | settextposition | 文本位置
pushlike | public | bool | fpushlike | setpushlike | 是否为普通按钮外观
multiline | public | bool | fmultiline | setmultiline | 文本是否为多行显示

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomcheckbtn

tvclib/utslvclstdctl/tcustomcheckbtn

定义:type tcustomcheckbtn= class(tcustombtn);
说明:
复选框
propeties:
name | private | type | read | write | describe
checked | public | integer | fcheckstate | setchecked | 勾选状态： 0：未选中。 1：选中。 @param(leftText)(bool)文本是否在左
lefttext | public | bool | flefttext | setlefttext |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • click
  • dosetfocus
  • dokillfocus
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
textpos | public | member of talignstyle9 | ftextposition | settextposition | 文本位置
pushlike | public | bool | fpushlike | setpushlike | 是否为普通按钮外观
multiline | public | bool | fmultiline | setmultiline | 文本是否为多行显示
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomclipboard

tvclib/utslvclstdctl/tcustomclipboard

定义:type tcustomclipboard= class(tcomponent);
说明:
剪切板类Text(string) 设置或者获取剪切板文本
成员函数:
function | private
create | public

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tcustomcombobox

tvclib/utslvclstdctl/tcustomcombobox

定义:type tcustomcombobox= class(tcustomcomboboxbase);
说明:
comboBox下拉框
成员函数:
function | private
appenditem | public
appenditems | public
insertitem | public
deleteitem | public
clean | public
getitems | public
getitemcount | public
getitemtext | public
getcurrentitemtext | public

propeties:
name | private | type | read | write | describe
readonly | public | bool | freadonly | setreadonly |
multisel | public | bool | fmultisel | setmultisel |
checkbox | public | bool | fcheckbox | setcheckbox |
items | public | strings | getitems | setitems |
oneditchanged | public | function[tcombobox,tuieventbase] | foneditchanged | foneditchanged | 文本被改变回调,文本显示后调用
oneditupdate | public | eventhandler | foneditupdate | foneditupdate |

继承的变量:
name | private | type | describe | static
flistbox | protected | twincontrol | 弹出框 |
fleft | protected | integer | 左边 |
ftop | protected | integer | 上边 |
fwidth | protected | integer | 宽度 |
fheight | protected | integer | 高度 |
_wapi | public | tswin32api | win32宏定义,以及api接口 | static
_tag | public | any | 调用者使用的成员变量 |
alnone | public | constant | 不对齐 | static
altop | public | constant | 上 | static
albottom | public | constant | 下 | static
alleft | public | constant | 左对齐 | static
alright | public | constant | 右对齐 | static
alclient | public | constant | 占满 | static
aktop | public | constant | 上 | static
akleft | public | constant | 左 | static
akright | public | constant | 右 | static
akbottom | public | constant | 下 | static
mbleft | public | constant | 左键 | static
mbright | public | constant | 右键 | static
mbmiddle | public | constant | 中间按键 | static
ssshift | public | constant | shift | static
ssalt | public | constant | alt | static
ssctrl | public | constant | ctl | static
ssdouble | public | constant | 双击 | static
al9_default | public | constant | 默认 | static
al9_topleft | public | constant | 顶部 | static
al9_center | public | constant | 居 | static
al3_left | public | constant | 左 | static
al3_right | public | constant | 右 | static
al3_center | public | constant | 居中 | static
idc_arrow | public | constant | 类型 | static

继承的函数:
  • createalist
  • showdropdown
  • setlistboxrect
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
itemindex | public | integer | getitemindex | setitemindex | 设置当前项序号
onselchanged | public | function[tcombobox,tuieventbase] | fonselchanged | fonselchanged | 当前选项改变回调
ondropdown | public | function[tcombobox,tuieventbase] | fondropdown | fondropdown | 下拉框展开回调
oncloseup | public | function[tcombobox,tuieventbase] | foncloseup | foncloseup | 下拉框关闭回调
dropdowncount | public | integer | fmaxlistitemshow | setmaxlistitemshow | 下拉列表项数
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomcomboboxbase

tvclib/utslvclstdctl/tcustomcomboboxbase

定义:type tcustomcomboboxbase= class(tcustomcontrol);
说明:
combox 基类
成员变量:
name | private | type | describe
flistbox | protected | twincontrol | 弹出框

成员函数:
function | private
createalist | public
showdropdown | public
setlistboxrect | protected

propeties:
name | private | type | read | write | describe
itemindex | public | integer | getitemindex | setitemindex | 设置当前项序号
onselchanged | public | function[tcombobox,tuieventbase] | fonselchanged | fonselchanged | 当前选项改变回调
ondropdown | public | function[tcombobox,tuieventbase] | fondropdown | fondropdown | 下拉框展开回调
oncloseup | public | function[tcombobox,tuieventbase] | foncloseup | foncloseup | 下拉框关闭回调
dropdowncount | public | integer | fmaxlistitemshow | setmaxlistitemshow | 下拉列表项数

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomedit

tvclib/utslvclstdctl/tcustomedit

定义:type tcustomedit= class(tcustomcontrol);
说明:
单行文本编辑框类
成员函数:
function | private
setsel | public

propeties:
name | private | type | read | write | describe
text | public | string | getentrytext | setentrytext |
onmaxtext | public | fpointer | fonmaxtext | fonmaxtext | 达到文本最大回调
onupdate | public | fpointer | fonupdate | fonupdate | 文本更新回调
onchange | public | fpointer | fonchange | fonchange | 文本改变回调
readonly | public | bool | getreadonly | setreadonly | 只读
limitlength | public | integer | getlimitlength | setlimitlength |
linewrap | public | bool | getlinewrap | setlinewrap | 自动换行,默认为false不自动换行
placeholder | public | string | getplaceholder | setplaceholder |
border | public | bool | getborder | setborder |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomipaddr

tvclib/utslvclstdctl/tcustomipaddr

定义:type tcustomipaddr= class(tcustomcontrol);
说明:
ip控件
成员函数:
function | private
cleanaddr | public
setrange | public

propeties:
name | private | type | read | write | describe
hasport | public | bool | fhasport | sethasport |
ipaddr | public | string | getaddress | setaddress | ip地址
onaddrchanged | public | function[tipaddr,tuieventbase] | faddrchange | faddrchange | id地址变化回调

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomlabel

tvclib/utslvclstdctl/tcustomlabel

定义:type tcustomlabel= class(tgraphiccontrol);
说明:
标签控件
成员函数:
function | private
canvasdrawaligntext | public

propeties:
name | private | type | read | write | describe
textalign | public | member of talignstyle9 | ftextalign | settextalign | 文字对齐

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • realsettext
  • paint
  • invalidaterect
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tgraphiccontrol]:bool | fonpaint | fonpaint | 绘制回调,返回true不执行默认绘制
transparent | public | bool | ftransparent | settransparent |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomlistbox

tvclib/utslvclstdctl/tcustomlistbox

定义:type tcustomlistbox= class(tcustomlistboxbase);
说明:
listbox控件(TMyarrayB) list数据数据,不要试图修改该变量
成员函数:
function | private
paintidx | public
getcurrentselection | public
setcurrentselection | public
getitemselectedstate | public
setitemselectedstate | public
appenditem | public
appenditems | public
insertitem | public
insertitems | public
deleteitem | public
deleteitems | public
deleteselecteditems | public
getselectedindexes | public
getitem | public
getitemtext | public
checklistitem | protected

propeties:
name | private | type | read | write
itemheight | public | integer | getyscrolldelta | setitemheight
itemcount | public | integer | getitemcount | setitemcount
multisel | public | bool | fmultisel | setmultisel
checkbox | public | bool | fcheckbox | setcheckbox
selbkcolor | public | color | fselbkcolor | setselbkcolor
onselchanged | public | eventhandler | fselectionchange | fselectionchange
ondrawlist | public | eventhandler | fondrawlist | fondrawlist
items | public | strings | getdata | setdata
itemindex | public | tsl | getcurrentselection | setcurrentselection
ownerdraw | public | bool | fownerdraw | setownerdraw

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • paintidx
  • getidxrect
  • insureidxinclient
  • getclientidxs
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | write | type | describe
itemcount | public | getitemcount | setitemcount | integer | 项数量
autoscroll | public | fautoscroll | setautoscroll | integer | 0,1,2,3 滚动条模式
thumbtrack | public | fthumbtrack | fthumbtrack | bool | 拖动按钮
whilestep | public | fwhilestep | setwhilestep | integer | 滚动步长
onpaint | public | fonpaint | fonpaint | function[tcustomcontrol,tuieventbase] | 窗口关闭消息回调
minwidth | public | fminwidth | setminwidth | natural |
minheight | public | fminheigt | setminheight | natural |
borderstyle | public | getborderstyle | setborderstyle | bsnone|bssingle | 边框样式
handle | public | gethandle | sethandle | pointer | 窗口句柄
tabstop | public | ftabstop | settabstop | bool |
controlcount | public | getcontrolcount |  | integer | 子控件数量
onactivate | public | fonactivate | fonactivate | eventhandler |
onclose | public | fonclose | fonclose | function[twincontrol,tuieventbase] | 窗口关闭消息回调
onkeydown | public | fonkeydown | fonkeydown | function[twincontrol,tmkey] | 按键按下回调
onkeyup | public | fonkeyup | fonkeyup | function[twincontrol,tmkey] | 按键松开
onkeypress | public | fonkeypress | fonkeypress | function[twincontrol,tmkey] | 字符消息
wspopup | public | getwspopup | setwspopup | bool |
wsdlgmodalframe | public | fwsdlgmodalframe | setwsdlgmodalframe | bool | dlg边框效果
wscaption | public | getwscaption | setwscaption | bool |
wssizebox | public | fwssizebox | setwssizebox | bool |
wssysmenu | public | fwssysmenu | setwssysmenu | bool |
imagelist | public | fimagelist | setimagelist | tcontrolimagelist |
onkillfocus | public | fonkillfocus | fonkillfocus | eventhandler |
onsetfocus | public | fonsetfocus | fonsetfocus | eventhandler |
oncreated | public | foncreated | foncreated | eventhandler |
action | public | getaction | setaction | taction | action对象
anchors | public | fanchors | setanchors | array of tanchorkind member | 锚定位置 ,默认 array(akTop,akLeft)
align | public | falign | setalign | member of talign | 默认 alNone 对齐方式
unalignbounds | protected | getunalignbounds | setunalignbounds | array of integer | 去除自动对齐时的范围
parentfont | public | fparentfont | setparentfont | bool |
parentcolor | public | fparentcolor | setparentcolor | bool |
caption | public | gettext | settext | string | 控件标题
enabled | public | getenabled | setenabled | bool | 控件是否有效
cursor | public | getcursor | setcursor | tcursor 通过 member of tsystemcursor 设置 | 系统鼠标
font | public | getcontrolfont | setcontrolfont | font |
onmousewheel | public | fonmousewheel | fonmousewheel | function[tcontrol,tmmousewheel] | 滚动回调函数
onsize | public | fonsize | fonsize | eventhandler |
onmove | public | fonmove | fonmove | eventhandler |
onmousemove | public | fonmousemove | fonmousemove | function[tcontrol,tmmouse] | 鼠标移动回调函数
onpopupmenu | public | fonpopupmenu | fonpopupmenu | function[tcontrol,tmmouse] | 弹出菜单回调函数
onmousedown | public | fonmousedown | fonmousedown | function[tcontrol,tmmouse] | 鼠标按下回调函数
onmouseup | public | fonmouseup | fonmouseup | function[tcontrol,tmmouse] | 鼠标松开回调函数
onclick | public | fonclick | fonclick | function[tcontrol,tmmouse] | 鼠标点击回调函数
onrclick | public | fonrclick | fonrclick | eventhandler |
ondblclick | public | fondblclick | fondblclick | function[tcontrol,tmmouse] | 鼠标双击回调函数
parent | public | fparent | preparesetparent | tcontrol | 父控件
popupmenu | public | fpopupmenu | fpopupmenu | tpopupmenu | 弹出菜单
visible | public | fvisible | setvisible | bool | 是否可见
clientrect | public | getclientrect |  | array of integer | 客户区矩形array(left,top,right,bottom)
height | public | fheight | setheight | integer | 高度
width | public | fwidth | setwidth | integer | 宽度
left | public | fleft | setleft | integer | 左边
top | public | ftop | settop | integer | 上方位置
border | public | fborder | setborder | bool |
boundsrect | public | getboundsrect | setboundsrect | array of integer | 控件区矩形array(left,top,right,bottom)
zorder | public | getzorder | setzorder | integer | 设置控件在父窗口的次序,最底层为 0
controlstate | public | fcontrolstate | fcontrolstate | tcontrolstate |
color | public | getcolor | setcolor | integer | 背景色
bkbitmap | public | fbkbitmap | setbitmap | tbitmap |
controls | public | fcontrols |  | tfplist of tcontrol | 子组件
canvas | public | fcanvas |  | tcanvas | 画布对象
owner | public | fowner |  | tcomponent | 所有者
componentcreated | public | fcomponentcreated |  | bool | 样式结合
componentstate | public | fcomponentstate | setcomponentstate |  | 状态集合
componentstyle | public | fcomponentstyle |  |  | 样式结合
name | public | fname | setname | string |
ondestroy | public | fondestroy | fondestroy | eventhandler |
onnotification | public | fonnotification | fonnotification | eventhandler |


tcustomlistboxbase

tvclib/utslvclstdctl/tcustomlistboxbase

定义:type tcustomlistboxbase= class(tcustomscrollcontrol);
说明:
listbox基类
成员函数:
function | private
paintidx | public
getidxrect | public
insureidxinclient | public
getclientidxs | public

propeties:
name | private | read | write | type | describe
itemcount | public | getitemcount | setitemcount | integer | 项数量

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • getxscrolldelta
  • getyscrolldelta
  • getclientxcapacity
  • getclientycapacity
  • getclientxcount
  • getclientycount
  • positionchanged
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
autoscroll | public | integer | fautoscroll | setautoscroll | 0,1,2,3 滚动条模式
thumbtrack | public | bool | fthumbtrack | fthumbtrack | 拖动按钮
whilestep | public | integer | fwhilestep | setwhilestep | 滚动步长
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustompassword

tvclib/utslvclstdctl/tcustompassword

定义:type tcustompassword= class(tcustomedit);
说明:
密码编辑框类
propeties:
name | private | type | read | write
passwordchar | public | string | getpasswordchar | setpasswordchar

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • setsel
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
text | public | string | getentrytext | setentrytext |
onmaxtext | public | fpointer | fonmaxtext | fonmaxtext | 达到文本最大回调
onupdate | public | fpointer | fonupdate | fonupdate | 文本更新回调
onchange | public | fpointer | fonchange | fonchange | 文本改变回调
readonly | public | bool | getreadonly | setreadonly | 只读
limitlength | public | integer | getlimitlength | setlimitlength |
linewrap | public | bool | getlinewrap | setlinewrap | 自动换行,默认为false不自动换行
placeholder | public | string | getplaceholder | setplaceholder |
border | public | bool | getborder | setborder |
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomprogressbar

tvclib/utslvclstdctl/tcustomprogressbar

定义:type tcustomprogressbar= class(tcustomcontrol);
说明:
进度栏
进度栏是显示任务进行完成度的控件。进度栏的上下限是进度条位置可移动的
范围，可以通过range属性获取、修改，其默认值是array(0,100)。进度条的位置可以通过
position属性获取、修改。进度栏的步增量是其每次调用increaseByStep函数进度条
位置移动的量，可以通过step属性获取、修改，其默认值是10.
进度条默认是分段离散的，可通过修改smooth成员设置其为平滑连续的。默认是
水平从左到右移动，可通过修改vertical成员来设置其为垂直从底部到顶部移动。
成员函数:
function | private
increasebystep | public
increasebyspecifiedincrement | public

propeties:
name | private | type | read | write | describe
smooth | public | bool | fsmooth | setsmooth | 进度条平滑移动
vertical | public | bool | fvertical | setvertical | 进度条垂直移动
range | public | array of integer | frange | setrangea | 进度栏的上下限
position | public | integer | fposition | setposition | 进度条的位置
stepincrement | public | integer | fstep | setstep | 进度栏的步增量
barcolor | public | color | fbarcolor | setindicatorbarcolor |

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomradiobtn

tvclib/utslvclstdctl/tcustomradiobtn

定义:type tcustomradiobtn= class(tcustomcheckbtn);
说明:
radiobtn单选按钮控件
继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • click
  • dosetfocus
  • dokillfocus
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
checked | public | integer | fcheckstate | setchecked | 勾选状态： 0：未选中。 1：选中。 @param(leftText)(bool)文本是否在左
lefttext | public | bool | flefttext | setlefttext |
textpos | public | member of talignstyle9 | ftextposition | settextposition | 文本位置
pushlike | public | bool | fpushlike | setpushlike | 是否为普通按钮外观
multiline | public | bool | fmultiline | setmultiline | 文本是否为多行显示
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomspinedit

tvclib/utslvclstdctl/tcustomspinedit

定义:type tcustomspinedit= class(tcustomcontrol);
说明:
spinedit控件
propeties:
name | private | type | read | write | describe
onincrease | public | function[tcustomspinedit,tuieventbase] | fonincrease | fonincrease | 增加时的回调
ondecrease | public | function[tcustomspinedit,tuieventbase] | fondecrease | fondecrease | 减少时的回调
increment | public | integer | fincrement | setincrement | 增长间隔
minvalue | public | integer | fminvalue | setminvalue | 下界
maxvalue | public | integer | fmaxvalue | setmaxvalue | 上界
value | public | integer | getvalue | setvalue | 值

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomstatusbar

tvclib/utslvclstdctl/tcustomstatusbar

定义:type tcustomstatusbar= class(tcustomcontrol);
说明:
状态栏
成员函数:
function | private
additem | public
deleteitem | public
setitemtext | public

propeties:
name | private | type | read | write | describe
items | public | array | fitems | setitems | 设置项 ,二维数组包括 text ,width 两个字段 array(("text":"abc","width":200),("text":"part2","width":0.4))

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomtimer

tvclib/utslvclstdctl/tcustomtimer

定义:type tcustomtimer= class(tcomponent);
说明:
定时器类,间隔是以毫秒为最小单位
成员函数:
function | private
timeout | public
start | public
stop | public
recycling | public
_timeproc_ | public
sinit | public

propeties:
name | private | type | read | write | describe
interval | public | integer | finterval | setinterval | 设置运行间隔
ontimer | public | funtion[self,tuieventbase] | fontimer | fontimer | 定时调度
enabled | public | bool | fstart | setenabled | 是否已经启动

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification

范例--定时器
//构造计算器,第一个参数为间隔(毫秒),第二个为函数指针
tm := new TCustomTimer(1000,function(o,e)begin echo now(); end );
tm.start();//启动定时器
tm.stop();//停止


tcustomtoolbar

tvclib/utslvclstdctl/tcustomtoolbar

定义:type tcustomtoolbar= class(tcustomcontrol);
说明:
工具栏控件
成员函数:
function | private
addbutton | public
setbtnindex | public
insertbutton | public
deletebutton | public
getitemrect | public
incpaintlock | public
decpaintlock | public
calcheightfixwidth | public
calcwidthfixheight | public
indexofbtn | public

propeties:
name | private | type | read | write
mainmenu | public | tmainmenu | fmainmenu | setmainmenu

继承的变量:
name | private | static | type | describe
fleft | protected |  | integer | 左边
ftop | protected |  | integer | 上边
fwidth | protected |  | integer | 宽度
fheight | protected |  | integer | 高度
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • initializewnd
  • createparams
  • realsettext
  • createwndclass
  • hitcontrol
  • captionheight
  • wmgetminmaxinfo
  • getclientrect
  • wmerasebkgnd
  • wmnotify
  • keyup
  • keydown
  • keypress
  • dosetfocus
  • dokillfocus
  • clienttowindow
  • show
  • endmodal
  • updatewindow
  • movecontrolorder
  • invalidaterect
  • createwnd
  • handleallocated
  • destroyhandle
  • handleneeded
  • setbounds
  • mainwndproc
  • designingsizer
  • designingclick
  • designingmove
  • docontrolalign
  • docontrolanchor
  • wnddefaulthandler
  • defaulthandler
  • broadcast
  • _send_
  • paintstruct
  • messagecreater
  • controlappended
  • controldeleted
  • mousedown
  • mouseup
  • contextmenu
  • notification
  • getclientrect
  • docncommand
  • docnnotify
  • domousewheel
  • getactionlinkclass
  • recycling
  • getboundsrect
  • setboundsrect
  • getbounds
  • dispatch
  • wndproc
  • perform
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | write | describe
onpaint | public | function[tcustomcontrol,tuieventbase] | fonpaint | fonpaint | 窗口关闭消息回调
minwidth | public | natural | fminwidth | setminwidth |
minheight | public | natural | fminheigt | setminheight |
borderstyle | public | bsnone|bssingle | getborderstyle | setborderstyle | 边框样式
handle | public | pointer | gethandle | sethandle | 窗口句柄
tabstop | public | bool | ftabstop | settabstop |
controlcount | public | integer | getcontrolcount |  | 子控件数量
onactivate | public | eventhandler | fonactivate | fonactivate |
onclose | public | function[twincontrol,tuieventbase] | fonclose | fonclose | 窗口关闭消息回调
onkeydown | public | function[twincontrol,tmkey] | fonkeydown | fonkeydown | 按键按下回调
onkeyup | public | function[twincontrol,tmkey] | fonkeyup | fonkeyup | 按键松开
onkeypress | public | function[twincontrol,tmkey] | fonkeypress | fonkeypress | 字符消息
wspopup | public | bool | getwspopup | setwspopup |
wsdlgmodalframe | public | bool | fwsdlgmodalframe | setwsdlgmodalframe | dlg边框效果
wscaption | public | bool | getwscaption | setwscaption |
wssizebox | public | bool | fwssizebox | setwssizebox |
wssysmenu | public | bool | fwssysmenu | setwssysmenu |
imagelist | public | tcontrolimagelist | fimagelist | setimagelist |
onkillfocus | public | eventhandler | fonkillfocus | fonkillfocus |
onsetfocus | public | eventhandler | fonsetfocus | fonsetfocus |
oncreated | public | eventhandler | foncreated | foncreated |
action | public | taction | getaction | setaction | action对象
anchors | public | array of tanchorkind member | fanchors | setanchors | 锚定位置 ,默认 array(akTop,akLeft)
align | public | member of talign | falign | setalign | 默认 alNone 对齐方式
unalignbounds | protected | array of integer | getunalignbounds | setunalignbounds | 去除自动对齐时的范围
parentfont | public | bool | fparentfont | setparentfont |
parentcolor | public | bool | fparentcolor | setparentcolor |
caption | public | string | gettext | settext | 控件标题
enabled | public | bool | getenabled | setenabled | 控件是否有效
cursor | public | tcursor 通过 member of tsystemcursor 设置 | getcursor | setcursor | 系统鼠标
font | public | font | getcontrolfont | setcontrolfont |
onmousewheel | public | function[tcontrol,tmmousewheel] | fonmousewheel | fonmousewheel | 滚动回调函数
onsize | public | eventhandler | fonsize | fonsize |
onmove | public | eventhandler | fonmove | fonmove |
onmousemove | public | function[tcontrol,tmmouse] | fonmousemove | fonmousemove | 鼠标移动回调函数
onpopupmenu | public | function[tcontrol,tmmouse] | fonpopupmenu | fonpopupmenu | 弹出菜单回调函数
onmousedown | public | function[tcontrol,tmmouse] | fonmousedown | fonmousedown | 鼠标按下回调函数
onmouseup | public | function[tcontrol,tmmouse] | fonmouseup | fonmouseup | 鼠标松开回调函数
onclick | public | function[tcontrol,tmmouse] | fonclick | fonclick | 鼠标点击回调函数
onrclick | public | eventhandler | fonrclick | fonrclick |
ondblclick | public | function[tcontrol,tmmouse] | fondblclick | fondblclick | 鼠标双击回调函数
parent | public | tcontrol | fparent | preparesetparent | 父控件
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu | 弹出菜单
visible | public | bool | fvisible | setvisible | 是否可见
clientrect | public | array of integer | getclientrect |  | 客户区矩形array(left,top,right,bottom)
height | public | integer | fheight | setheight | 高度
width | public | integer | fwidth | setwidth | 宽度
left | public | integer | fleft | setleft | 左边
top | public | integer | ftop | settop | 上方位置
border | public | bool | fborder | setborder |
boundsrect | public | array of integer | getboundsrect | setboundsrect | 控件区矩形array(left,top,right,bottom)
zorder | public | integer | getzorder | setzorder | 设置控件在父窗口的次序,最底层为 0
controlstate | public | tcontrolstate | fcontrolstate | fcontrolstate |
color | public | integer | getcolor | setcolor | 背景色
bkbitmap | public | tbitmap | fbkbitmap | setbitmap |
controls | public | tfplist of tcontrol | fcontrols |  | 子组件
canvas | public | tcanvas | fcanvas |  | 画布对象
owner | public | tcomponent | fowner |  | 所有者
componentcreated | public | bool | fcomponentcreated |  | 样式结合
componentstate | public |  | fcomponentstate | setcomponentstate | 状态集合
componentstyle | public |  | fcomponentstyle |  | 样式结合
name | public | string | fname | setname |
ondestroy | public | eventhandler | fondestroy | fondestroy |
onnotification | public | eventhandler | fonnotification | fonnotification |


tcustomtoolbutton

tvclib/utslvclstdctl/tcustomtoolbutton

定义:type tcustomtoolbutton= class(tcomponent);
说明:
工具栏项
成员函数:
function | private
getrect | public
getactionlinkclass | protected

propeties:
name | private | type | read | write | describe
onclick | public | function[o:ttoolbutton;e:tuieventbase] | fonclick | fonclick | 点击消息
caption | public | string | fcaption | setcaption | 标题
imageid | public | integer | fimageid | setimageid | 图标id
enabled | public | bool | fenabled | setenabled | 是否有效
visible | public | bool | fvisible | setvisible | 是否可见
action | public | taction | getaction | setaction |
popupmenu | public | tpopupmenu | fpopupmenu | fpopupmenu |
stylesep | public | bool | getstylesep | setstylesep |

继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • notification
  • setdesigning
  • isdescendant
  • setowner
  • executeaction
  • updateaction
  • destroycomponents
  • freenotification
  • insertcomponent
  • removecomponent
  • getpublishproperties
  • getpublishevents
  • getchangedpublish
  • setchangedpublish
  • setpublish
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | type | read | describe | write
owner | public | tcomponent | fowner | 所有者 |
componentcreated | public | bool | fcomponentcreated | 样式结合 |
componentstate | public |  | fcomponentstate | 状态集合 | setcomponentstate
componentstyle | public |  | fcomponentstyle | 样式结合 |
name | public | string | fname |  | setname
ondestroy | public | eventhandler | fondestroy |  | fondestroy
onnotification | public | eventhandler | fonnotification |  | fonnotification


tlistdrawevent

tvclib/utslvclstdctl/tlistdrawevent

定义:type tlistdrawevent= class(tuieventbase);
说明:
列表绘制消息对象
成员变量:
name | private | type | describe
rec | public | array(左上右下 | ) 区域
sel | public | bool | 选择状态
canvas | public | tcanvas | 画布

继承的变量:
name | type | private | describe | static
message | integer|any | public | 消息id |
wparam | pointer | public | 消息wparam |
lparam | pointer | public | 消息lparam |
hwnd | pointer | public | 窗口句柄 |
alnone | constant | public | 不对齐 | static
altop | constant | public | 上 | static
albottom | constant | public | 下 | static
alleft | constant | public | 左对齐 | static
alright | constant | public | 右对齐 | static
alclient | constant | public | 占满 | static
aktop | constant | public | 上 | static
akleft | constant | public | 左 | static
akright | constant | public | 右 | static
akbottom | constant | public | 下 | static
mbleft | constant | public | 左键 | static
mbright | constant | public | 右键 | static
mbmiddle | constant | public | 中间按键 | static
ssshift | constant | public | shift | static
ssalt | constant | public | alt | static
ssctrl | constant | public | ctl | static
ssdouble | constant | public | 双击 | static
al9_default | constant | public | 默认 | static
al9_topleft | constant | public | 顶部 | static
al9_center | constant | public | 居 | static
al3_left | constant | public | 左 | static
al3_right | constant | public | 右 | static
al3_center | constant | public | 居中 | static
idc_arrow | constant | public | 类型 | static

继承的函数:
  • create
  • hilparam
  • lolparam
  • hiwparam
  • lowparam
  • hilparamsigned
  • lolparamsigned
  • hiwparamsigned
  • lowparamsigned
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration

继承的properties:
name | private | read | type | describe | write
msg | public | message | integer | 消息id |
skip | public | fskip | bool | 是否忽略底层消息处理函数 | setskip
result | public | fresult | integer | 消息处理返回 | fresult
handle | public | hwnd | pointer | 窗口句柄 | hwnd
sender | public | getsender | tcontrol | 发送消息的控件,如菜单消息的触发窗口 | setsender


tvirtualcalender

tvclib/utslvclstdctl/tvirtualcalender

定义:type tvirtualcalender= class(tsluibase);
说明:
月历控件虚拟类
继承的变量:
name | private | static | type | describe
_wapi | public | static | tswin32api | win32宏定义,以及api接口
_tag | public |  | any | 调用者使用的成员变量
alnone | public | static | constant | 不对齐
altop | public | static | constant | 上
albottom | public | static | constant | 下
alleft | public | static | constant | 左对齐
alright | public | static | constant | 右对齐
alclient | public | static | constant | 占满
aktop | public | static | constant | 上
akleft | public | static | constant | 左
akright | public | static | constant | 右
akbottom | public | static | constant | 下
mbleft | public | static | constant | 左键
mbright | public | static | constant | 右键
mbmiddle | public | static | constant | 中间按键
ssshift | public | static | constant | shift
ssalt | public | static | constant | alt
ssctrl | public | static | constant | ctl
ssdouble | public | static | constant | 双击
al9_default | public | static | constant | 默认
al9_topleft | public | static | constant | 顶部
al9_center | public | static | constant | 居
al3_left | public | static | constant | 左
al3_right | public | static | constant | 右
al3_center | public | static | constant | 居中
idc_arrow | public | static | constant | 类型

继承的函数:
  • sinit
  • iskeywords
  • norecycled
  • recycling
  • hashset
  • hashget
  • hashdel
  • temppath
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration
  • basevalue
  • initenumeration


click

tvclib/utslvclstdctl/tcustombtn/click

定义: public click();virtual;
说明:
模拟点击按钮一下的操作


dokillfocus

tvclib/utslvclstdctl/tcustombtn/dokillfocus

定义: public dokillfocus(o,e);override;
说明:
控件失去焦点
参数:
name | type | describe
o | twincontrol | 控件自身
e |  |


dosetfocus

tvclib/utslvclstdctl/tcustombtn/dosetfocus

定义: public dosetfocus(o,e);override;
说明:
控件获得焦点
参数:
name | type | describe
o | twincontrol | 控件自身
e |  |


create

tvclib/utslvclstdctl/tcustomclipboard/create

定义: public create(aowner);override;
说明:
构造剪切板类对象
参数:
name
aowner


appenditem

tvclib/utslvclstdctl/tcustomcombobox/appenditem

定义: public appenditem(str);virtual;
说明:
添加子项数据
参数:
name | type | describe
str | string | 子项字符串


appenditems

tvclib/utslvclstdctl/tcustomcombobox/appenditems

定义: public appenditems(arr);virtual;
说明:
添加子项数据
参数:
name | type | describe
arr | array of string | 子项字符串数组


clean

tvclib/utslvclstdctl/tcustomcombobox/clean

定义: public clean();
说明:
清空数据


deleteitem

tvclib/utslvclstdctl/tcustomcombobox/deleteitem

定义: public deleteitem(i);virtual;
说明:
删除子项
参数:
name | type | describe
i | integer | 删除子项的位置


getcurrentitemtext

tvclib/utslvclstdctl/tcustomcombobox/getcurrentitemtext

定义: public getcurrentitemtext();
说明:
获取选中的子项字符串
返回值:
type | describe
string | 子项字符串


getitemcount

tvclib/utslvclstdctl/tcustomcombobox/getitemcount

定义: public getitemcount();
说明:
统计子项个数
返回值:
type | describe
integer | 子项个数


getitems

tvclib/utslvclstdctl/tcustomcombobox/getitems

定义: public getitems();
说明:
获得所有数据
返回值:
type | describe
array of string | 字符串项


getitemtext

tvclib/utslvclstdctl/tcustomcombobox/getitemtext

定义: public getitemtext(i);
说明:
获取第i个子项的内容
参数:
name | type | describe
i | integer | 子项的位置

返回值:
type | describe
string | 子项标题


insertitem

tvclib/utslvclstdctl/tcustomcombobox/insertitem

定义: public insertitem(str,i);virtual;
说明:
插入子项
参数:
name | type | describe
str | string | 显示标题
i | integer | 在i前插入子项


createalist

tvclib/utslvclstdctl/tcustomcomboboxbase/createalist

定义: public createalist();virtual;
返回值:
type | describe
twincontrol | 弹出窗口


setlistboxrect

tvclib/utslvclstdctl/tcustomcomboboxbase/setlistboxrect

定义: protected setlistboxrect();virtual;
说明:
设置弹出框的显示区域


showdropdown

tvclib/utslvclstdctl/tcustomcomboboxbase/showdropdown

定义: public showdropdown(flg);
说明:
展开或者关闭下拉框
参数:
name
flg


setsel

tvclib/utslvclstdctl/tcustomedit/setsel

定义: public setsel(bgid,edid);
说明:
设置选择文本
参数:
name | type | describe
bgid | integer | 开始位置 默认为0
edid | integer | 结束位置 默认为整体长度


cleanaddr

tvclib/utslvclstdctl/tcustomipaddr/cleanaddr

定义: public cleanaddr();
说明:
清除地址


setrange

tvclib/utslvclstdctl/tcustomipaddr/setrange

定义: public setrange(i,low,high);
说明:
设置地址段范围
参数:
name | type | describe
i | integer | ip段序号 0,1,2,3
low | integer | 下限
high | integer | 上限


canvasdrawaligntext

tvclib/utslvclstdctl/tcustomlabel/canvasdrawaligntext

定义: public class canvasdrawaligntext(dc,rect,txt,al);
说明:
在指定区域内按照对齐方式绘制文本
参数:
name | type | describe
dc |  |
rect |  |
txt |  |
al | member of talignstyle9 | 对齐方式


appenditem

tvclib/utslvclstdctl/tcustomlistbox/appenditem

定义: public appenditem(item);virtual;
说明:
在列表框最后添加一个项
参数:
name | type | describe
item | string | 要添加的字符串

返回值:
type | describe
integer | 所添加项在列表框中的索引


appenditems

tvclib/utslvclstdctl/tcustomlistbox/appenditems

定义: public appenditems(ari);virtual;
说明:
在列表框最后添加多个项
参数:
name | type | describe
ari | array | 要添加的字符串组成的数组

返回值:
type | describe
integer | 所添加的最后一项在列表框中的索引


checklistitem

tvclib/utslvclstdctl/tcustomlistbox/checklistitem

定义: protected checklistitem(s);virtual;
说明:
项检查,重写该方法可以控制项的类型
参数:
name
s


deleteitem

tvclib/utslvclstdctl/tcustomlistbox/deleteitem

定义: public deleteitem(n);override;
说明:
删除指定的合法下标索引的项
参数:
name | type | describe
n | integer | 指定项下标索引

返回值:
type | describe
integer | 剩余的项的数量，出错则返回-1


deleteitems

tvclib/utslvclstdctl/tcustomlistbox/deleteitems

定义: public deleteitems(n,cnt);
说明:
删除指定的合法下标处开始多个项
参数:
name | type | describe
n | integer | 指定项下标索引
cnt | integer | 删除项数，当删除的项超过尾项时，删至尾项

返回值:
type | describe
integer | 剩余的项的数量，出错则返回-1


deleteselecteditems

tvclib/utslvclstdctl/tcustomlistbox/deleteselecteditems

定义: public deleteselecteditems();
说明:
删除选中的项目


getcurrentselection

tvclib/utslvclstdctl/tcustomlistbox/getcurrentselection

定义: public getcurrentselection();virtual;
说明:
获取当前选中项的索引，仅用于单选的列表框


getitem

tvclib/utslvclstdctl/tcustomlistbox/getitem

定义: public getitem(n);
说明:
获取指定项
参数:
name | type | describe
n | integer | 指定项下标

返回值:
type | describe
 | 指定项


getitemselectedstate

tvclib/utslvclstdctl/tcustomlistbox/getitemselectedstate

定义: public getitemselectedstate(n);
说明:
获取指定项的选中状态
参数:
name | type | describe
n | integer | 指定项下标

返回值:
type | describe
bool | 是否被选中


getitemtext

tvclib/utslvclstdctl/tcustomlistbox/getitemtext

定义: public getitemtext(i);virtual;
说明:
获得item的文本
参数:
name | type | describe
i | integer | 序号

返回值:
type | describe
string | 项显示字符串


getselectedindexes

tvclib/utslvclstdctl/tcustomlistbox/getselectedindexes

定义: public getselectedindexes();virtual;
说明:
获取列表框内当前选中项的索引组成的数组
返回值:
type | describe
array | 当未选中任何项时，返回空数组


insertitem

tvclib/utslvclstdctl/tcustomlistbox/insertitem

定义: public insertitem(item,n);virtual;
说明:
在指定索引处插入一项
参数:
name | type | describe
item | string | 插入的字符串
n | integer | 指定下标索引

返回值:
type | describe
integer | 返回插入的字符串的下标，出错则返回-1


insertitems

tvclib/utslvclstdctl/tcustomlistbox/insertitems

定义: public insertitems(ari,n);virtual;
说明:
在指定索引处插入多个项，将该函数用于多选列表框将会导致所有选择项丢失
参数:
name | type | describe
ari | array of string | 插入项组成的数组
n | integer | 指定下标索引，缺省则插至末尾

返回值:
type | describe
integer | 返回插入的最后的字符串的下标，出错则返回-1


paintidx

tvclib/utslvclstdctl/tcustomlistbox/paintidx

定义: public paintidx(idx,rc,cvs);virtual;
说明:
绘制项
参数:
name | type | describe
idx |  |
rc | array | 绘制区域
cvs | tcustomcanvas | 画布


setcurrentselection

tvclib/utslvclstdctl/tcustomlistbox/setcurrentselection

定义: public setcurrentselection(n);virtual;
说明:
设置当前选中项的索引，仅用于单选的列表框
参数:
name | type
n | integer


setitemselectedstate

tvclib/utslvclstdctl/tcustomlistbox/setitemselectedstate

定义: public setitemselectedstate(n,state);
说明:
设置指定项选中状态，仅用于非连续多选的列表框
参数:
name | type | describe
n | integer | 指定项索引
state | bool | 状态


getclientidxs

tvclib/utslvclstdctl/tcustomlistboxbase/getclientidxs

定义: public getclientidxs();virtual;
说明:
获得客户区项的序号
返回值:
type | describe
array | 序号数组


getidxrect

tvclib/utslvclstdctl/tcustomlistboxbase/getidxrect

定义: public getidxrect(idx);virtual;
说明:
通过序号获得项绘制区域
参数:
name | type | describe
idx | integer | 项序号

返回值:
type | describe
array | array(左上右下)


insureidxinclient

tvclib/utslvclstdctl/tcustomlistboxbase/insureidxinclient

定义: public insureidxinclient(idx);
说明:
确保指定项在区域中
参数:
name | type | describe
idx | integer | 项序号


paintidx

tvclib/utslvclstdctl/tcustomlistboxbase/paintidx

定义: public paintidx(idx,rc,cvs);virtual;
说明:
绘制项
参数:
name | type | describe
idx | integer | 序号
rc | array | 绘制区域
cvs | tcustomcanvas | 画布


increasebyspecifiedincrement

tvclib/utslvclstdctl/tcustomprogressbar/increasebyspecifiedincrement

定义: public increasebyspecifiedincrement(n);
说明:
进度条移动指定长度，当其超过限度则设置位置至该限度
参数:
name | type | describe
n | integer | 增长的数量

返回值:
type | describe
integer | 先前的位置，出错则返回-1


increasebystep

tvclib/utslvclstdctl/tcustomprogressbar/increasebystep

定义: public increasebystep();
说明:
按照步增量移动进度条当前的位置，当其超过限度则设置位置至下限以便于从头重新开始
返回值:
type | describe
integer | 先前的位置，出错返回-1


additem

tvclib/utslvclstdctl/tcustomstatusbar/additem

定义: public additem(str,wd);
说明:
添加项目
参数:
name | type | describe
str | string | 文本
wd | number | 宽度 ,大于1 表示绝对宽阔 ,小于1 表示相对宽度


deleteitem

tvclib/utslvclstdctl/tcustomstatusbar/deleteitem

定义: public deleteitem(id);
说明:
删除项目
参数:
name | type | describe
id | integer | 序号


setitemtext

tvclib/utslvclstdctl/tcustomstatusbar/setitemtext

定义: public setitemtext(str,id);
说明:
修改字段
参数:
name | type | describe
str | string | 文本
id | integer | 序号


_timeproc_

tvclib/utslvclstdctl/tcustomtimer/_timeproc_

定义: public class _timeproc_(hwnd,message,wparam,lparam);
说明:
定时回调入接口
参数:
name | type | describe
hwnd | integer | 窗口句柄
message | integer | 消息id
wparam | integer | 消息参数1
lparam | integer | 消息参数2


recycling

tvclib/utslvclstdctl/tcustomtimer/recycling

定义: public recycling();override;
说明:
析构预备


sinit

tvclib/utslvclstdctl/tcustomtimer/sinit

定义: public class sinit();override;
说明:
初始化定时器全局


start

tvclib/utslvclstdctl/tcustomtimer/start

定义: public start();
说明:
启动


stop

tvclib/utslvclstdctl/tcustomtimer/stop

定义: public stop();
说明:
停止


timeout

tvclib/utslvclstdctl/tcustomtimer/timeout

定义: public timeout(cmd,t);
说明:
一次性事件
参数:
name | type | describe
cmd | fpointer | 执行回调
t | integer | t毫秒后执行


addbutton

tvclib/utslvclstdctl/tcustomtoolbar/addbutton

定义: public addbutton(btn);
说明:
添加工具栏项
参数:
name
btn


calcheightfixwidth

tvclib/utslvclstdctl/tcustomtoolbar/calcheightfixwidth

定义: public calcheightfixwidth(w);
说明:
固定宽度计算工具栏高度
参数:
name | type | describe
w | integer | 给定宽度

返回值:
type | describe
intger | 计算的高度


calcwidthfixheight

tvclib/utslvclstdctl/tcustomtoolbar/calcwidthfixheight

定义: public calcwidthfixheight(h);
说明:
固定高度计算工具栏宽度
参数:
name
h

返回值:
type | describe
intger | 宽度


decpaintlock

tvclib/utslvclstdctl/tcustomtoolbar/decpaintlock

定义: public decpaintlock();
说明:
取消绘制锁定,和 IncPaintLock() 成对使用


deletebutton

tvclib/utslvclstdctl/tcustomtoolbar/deletebutton

定义: public deletebutton(btn);
说明:
在删除按钮删除button
参数:
name | type | describe
btn | ttoolbutton | 工具栏项


getitemrect

tvclib/utslvclstdctl/tcustomtoolbar/getitemrect

定义: public getitemrect(btn);
说明:
获得按钮的区域
参数:
name | type | describe
btn | ttoolbutton | 工具栏项

返回值:
type | describe
array | 区域


incpaintlock

tvclib/utslvclstdctl/tcustomtoolbar/incpaintlock

定义: public incpaintlock();
说明:
锁定绘制,和 DecPaintLock() 成对使用


indexofbtn

tvclib/utslvclstdctl/tcustomtoolbar/indexofbtn

定义: public indexofbtn(btn);
说明:
获得按钮序号
参数:
name | type | describe
btn | ttoolbutton | 按钮

返回值:
type | describe
integer | >=0表示正确序号


insertbutton

tvclib/utslvclstdctl/tcustomtoolbar/insertbutton

定义: public insertbutton(btn,idx);
说明:
在指定位置插入按钮
参数:
name | type | describe
btn | ttoolbutton | 工具栏项
idx | ttoolbutton | integer | 位置


setbtnindex

tvclib/utslvclstdctl/tcustomtoolbar/setbtnindex

定义: public setbtnindex(btn,idx);
说明:
修改按钮的位置
参数:
name | type | describe
btn | ttoolbutton | 工具栏项
idx | ttoolbutton | integer | 位置


getactionlinkclass

tvclib/utslvclstdctl/tcustomtoolbutton/getactionlinkclass

定义: protected getactionlinkclass();virtual;
说明:
返回actionlinkclass
返回值:
type | describe
tmenuactionlink class |


getrect

tvclib/utslvclstdctl/tcustomtoolbutton/getrect

定义: public getrect();
说明:
获得区域
返回值:
type | describe
array | 区域


tcustomtreectl

tvclib/utslvcltree/tcustomtreectl

定义:type tcustomtreectl= class(tvirtuallist);
说明:
树控件
成员函数:
function | private
setsel | public
nodeinlist | public
mouseup | public

propeties:
name | private | read | type | write
checkbox | public | fcheckbox | bool | setcheckbox
hasline | public | fhasline | bool | sethasline
onselchanged | public | fonselchanged | eventhandler | fonselchanged
onselchanging | public | fonselchanging | eventhandler | fonselchanging

成员类:
class | private
ttreeselchngedevent | public


tcustomtreectlnode

tvclib/utslvcltree/tcustomtreectlnode

定义:type tcustomtreectlnode= class(tvirtuallistitem);
说明:
树结点
成员函数:
function | private
paint | public
mouseup | public
getnodebyindex | public
appendnodestr | public
insertnodestr | public
getindex | public
ancestorisexpand | public
appendnode | public
hasnode | public
deletenode | public
deletechildnode | public
deletenodebyindex | public
deletechildren | public
getlastshownode | public
insertnodes | public
insertnode | public
expand | public
unexpand | public
getshownodes | public
toarray | public

propeties:
name | private | read | write | type | describe
visible | public | fvisible | setvisible | bool | 可见
itemcount | public | getitemcount |  | integer | 子节点数量
hierarchy | public | fhierarchy |  | integer | 层级
expanded | public | getexpanded |  | bool | 是否展开
parent | public | fparent | setparent | tcustomtreectlnode | 父节点
checked | public | fchecked | setchecked | bool | 是否勾选
lastchild | public | getlstchild |  | tcustomtreectlnode | 最后一个子节点
dirtype | public | fdirtype | fdirtype | bool | 目录类型
mousecanchecked | public | fmousecanchecked | fmousecanchecked | bool | 能否使用鼠标点击勾选
modifychildrenchecked | public | fmodifychildrenchecked | fmodifychildrenchecked | bool | 勾选的时候是否修改自己的勾选状态


mouseup

tvclib/utslvcltree/tcustomtreectl/mouseup

定义: public mouseup(o,e);override;
说明:
点击
参数:
name
o
e


nodeinlist

tvclib/utslvcltree/tcustomtreectl/nodeinlist

定义: public nodeinlist(it);
说明:
节点是否在窗口中展示
参数:
name
it


setsel

tvclib/utslvcltree/tcustomtreectl/setsel

定义: public setsel(it);virtual;
说明:
设置选中节点
参数:
name | type | describe
it | tcustomtreectlnode | 节点


ttreeselchngedevent

tvclib/utslvcltree/tcustomtreectl/ttreeselchngedevent

定义:type ttreeselchngedevent= class(tuieventbase);
说明:
导航选择改变消息


ancestorisexpand

tvclib/utslvcltree/tcustomtreectlnode/ancestorisexpand

定义: public ancestorisexpand();virtual;
说明:
是否一致展开
返回值:
type | describe
bool | 展开为true,否则为false


appendnode

tvclib/utslvcltree/tcustomtreectlnode/appendnode

定义: public appendnode(it);virtual;
说明:
插入一个节点
参数:
name | type | describe
it | tcustomtreectlnode | 节点

返回值:
type | describe
bool | 是否成功


appendnodestr

tvclib/utslvcltree/tcustomtreectlnode/appendnodestr

定义: public appendnodestr(s);override;
说明:
追加一个节点
参数:
name | type | describe
s | string | 字符串

返回值:
type | describe
tcustomtreectlnode | 新节点


deletechildnode

tvclib/utslvcltree/tcustomtreectlnode/deletechildnode

定义: public deletechildnode(nd);
说明:
删除子节点
参数:
name | type | describe
nd | tcustomtreectlnode | 节点


deletechildren

tvclib/utslvcltree/tcustomtreectlnode/deletechildren

定义: public deletechildren();virtual;
说明:
删除所有的子节点


deletenode

tvclib/utslvcltree/tcustomtreectlnode/deletenode

定义: public deletenode(nd);virtual;
说明:
删除节点
参数:
name | type | describe
nd | tcustomtreectlnode | 待删除节点


deletenodebyindex

tvclib/utslvcltree/tcustomtreectlnode/deletenodebyindex

定义: public deletenodebyindex(idx);
说明:
根据位置删除节点
参数:
name | type | describe
idx | integer | 序号


expand

tvclib/utslvcltree/tcustomtreectlnode/expand

定义: public expand();virtual;
说明:
展开节点


getindex

tvclib/utslvcltree/tcustomtreectlnode/getindex

定义: public getindex();virtual;
说明:
获得在父节点中的序号
返回值:
type | describe
integer | 序号


getlastshownode

tvclib/utslvcltree/tcustomtreectlnode/getlastshownode

定义: public getlastshownode();
说明:
获得展示的最后第一个节点
返回值:
type | describe
tcustomtreectlnode |


getnodebyindex

tvclib/utslvcltree/tcustomtreectlnode/getnodebyindex

定义: public getnodebyindex(idx);
说明:
通过序号获得子节点
参数:
name | type
idx | tcustomtreectlnode


getshownodes

tvclib/utslvcltree/tcustomtreectlnode/getshownodes

定义: public getshownodes();
说明:
获得展开的所有子节点
返回值:
type | describe
array of tcustomtreectlnode |


hasnode

tvclib/utslvcltree/tcustomtreectlnode/hasnode

定义: public hasnode(nd);virtual;
说明:
是否为某个节点的祖先节点
参数:
name | type | describe
nd | tcustomtreectlnode | 子节点

返回值:
type | describe
tcustomtreectlnode|0 | 如果为祖先节点,就返回查询节点的父节点


insertnode

tvclib/utslvcltree/tcustomtreectlnode/insertnode

定义: public insertnode(it,idx);virtual;
说明:
插入一个节点
参数:
name | type | describe
it | tcustomtreectlnode | 字符串
idx | integer | 序号


insertnodes

tvclib/utslvcltree/tcustomtreectlnode/insertnodes

定义: public insertnodes(its,idx);virtual;
说明:
插入一个节点
参数:
name | type | describe
its |  |
idx | integer | 序号


insertnodestr

tvclib/utslvcltree/tcustomtreectlnode/insertnodestr

定义: public insertnodestr(s,idx);override;
说明:
插入一个节点
参数:
name | type | describe
s | string | 字符串
idx | integer | 序号

返回值:
type | describe
tcustomtreectlnode | 新节点


mouseup

tvclib/utslvcltree/tcustomtreectlnode/mouseup

定义: public mouseup(o,e);
说明:
点击消息处理
参数:
name
o
e


paint

tvclib/utslvcltree/tcustomtreectlnode/paint

定义: public paint(cvs,x,y,w,h);override;
说明:
绘制节点
参数:
name
cvs
x
y
w
h


toarray

tvclib/utslvcltree/tcustomtreectlnode/toarray

定义: public toarray();virtual;
说明:
转换为数组


unexpand

tvclib/utslvcltree/tcustomtreectlnode/unexpand

定义: public unexpand();virtual;
说明:
折叠节点


runthreadworkerclient

tvclib/uvclthreadworker/runthreadworkerclient

定义: runthreadworkerclient(this);
说明:
工作线程主循环
参数:
name
this


tcustomthreadworker

tvclib/uvclthreadworker/tcustomthreadworker

定义:type tcustomthreadworker= class();
说明:
工作线程宿主
成员函数:
function | private
operator [] | public
operator [1] | public
postmessage | public

propeties:
name | private | read | write | type | describe
onmessage | public | getonmessage | setonmessage | function[tthreadworker,data] | 消息回调
onerror | public | getonerror | setonerror | function[tthreadworker,d] | 子线程启动
onstart | public | getonstart | setonstart | function[tthreadworker] | 子线程启动


tworkerclient

tvclib/uvclthreadworker/tworkerclient

定义:type tworkerclient= class(tarray);
说明:
工作线程
propeties:
name | private | read | write | type | describe
onmessage | public | fonmessage | fonmessage | function[tworkerclient,data] | 消息回调


operator [1]

tvclib/uvclthreadworker/tcustomthreadworker/operator [1]

定义: public operator [1](idx,v);
说明:
set数据
参数:
name
idx
v


operator []

tvclib/uvclthreadworker/tcustomthreadworker/operator []

定义: public operator [](idx);
说明:
get数据
参数:
name
idx


postmessage

tvclib/uvclthreadworker/tcustomthreadworker/postmessage

定义: public postmessage(d);
参数:
name | type | describe
d | any | 发送数据,基础数据,不能传送对象


tpropertyaction

tvclib/uvcpropertytypespersistence/tpropertyaction

定义:type tpropertyaction= class(tpropertyvarible);
成员函数:
function | private
ifcomponent | public


tpropertyalign

tvclib/uvcpropertytypespersistence/tpropertyalign

定义:type tpropertyalign= class(uniobjectmember);
成员函数:
function | private
lazyproperty | public


tpropertybitmap

tvclib/uvcpropertytypespersistence/tpropertybitmap

定义:type tpropertybitmap= class(tpropertytype);
成员函数:
function | private
formattmf | public

继承的函数:
  • edittype
  • formatedit
  • unformatedit
  • formattmf
  • tmftonode
  • readtmf
  • lazyproperty
  • ifcomponent

继承的properties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


tpropertybool

tvclib/uvcpropertytypespersistence/tpropertybool

定义:type tpropertybool= class(tpropertytype);
成员函数:
function | private
formatedit | public
formattmf | public

继承的函数:
  • edittype
  • formatedit
  • unformatedit
  • formattmf
  • tmftonode
  • readtmf
  • lazyproperty
  • ifcomponent

继承的properties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


tpropertycolor

tvclib/uvcpropertytypespersistence/tpropertycolor

定义:type tpropertycolor= class(tpropertytype);
成员函数:
function | private
formattmf | public

继承的函数:
  • edittype
  • formatedit
  • unformatedit
  • formattmf
  • tmftonode
  • readtmf
  • lazyproperty
  • ifcomponent

继承的properties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


tpropertyicon

tvclib/uvcpropertytypespersistence/tpropertyicon

定义:type tpropertyicon= class(tpropertytype);
成员函数:
function | private
formattmf | public

继承的函数:
  • edittype
  • formatedit
  • unformatedit
  • formattmf
  • tmftonode
  • readtmf
  • lazyproperty
  • ifcomponent

继承的properties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


tpropertyimagesdata

tvclib/uvcpropertytypespersistence/tpropertyimagesdata

定义:type tpropertyimagesdata= class(tpropertytype);
成员函数:
function | private
formattmf | public

继承的函数:
  • edittype
  • formatedit
  • unformatedit
  • formattmf
  • tmftonode
  • readtmf
  • lazyproperty
  • ifcomponent

继承的properties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


tpropertynatural

tvclib/uvcpropertytypespersistence/tpropertynatural

定义:type tpropertynatural= class(tpropertytype);
成员函数:
function | private
formattmf | public

继承的函数:
  • edittype
  • formatedit
  • unformatedit
  • formattmf
  • tmftonode
  • readtmf
  • lazyproperty
  • ifcomponent

继承的properties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


tpropertystrings

tvclib/uvcpropertytypespersistence/tpropertystrings

定义:type tpropertystrings= class(tpropertytype);
成员函数:
function | private
formattmf | public

继承的函数:
  • edittype
  • formatedit
  • unformatedit
  • formattmf
  • tmftonode
  • readtmf
  • lazyproperty
  • ifcomponent

继承的properties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


tpropertytype

tvclib/uvcpropertytypespersistence/tpropertytype

定义:type tpropertytype= class();
成员函数:
function | private
edittype | public
formatedit | public
unformatedit | public
formattmf | public
tmftonode | public
readtmf | public
lazyproperty | public
ifcomponent | public

propeties:
name | private | type | read | write
tmfparser | public | ttmfparser | gettfmparser |


ttmfparser

tvclib/uvcpropertytypespersistence/ttmfparser

定义:type ttmfparser= class(ttmfparserbase);
说明:
tmf文件解析
成员函数:
function | private
samplevalue | public
gettree | public

propeties:
name | private | write | type | describe
script | public | setscript | string | 设置脚本文件
scriptpath | public | setscriptpath | string | 脚本路径


ttmfparserbase

tvclib/uvcpropertytypespersistence/ttmfparserbase

定义:type ttmfparserbase= class();
说明:
解析基类,提供基础类型,提供类型常量
目前使用的常量有 TT_NUM,TT_BIN,TT_STR,TT_SYM


ttmfparsertoken

tvclib/uvcpropertytypespersistence/ttmfparsertoken

定义:type ttmfparsertoken= class(ttmfparserbase);
说明:
tmf 文件解析token
成员函数:
function | private
cchar | public
cback | public
delct | public
gettokens | public
pstring | public
phexnumber | public
pnumber | public

propeties:
name | private | read | write | type | describe
script | public | fscript | setscript | string | 带解析的脚本


ifcomponent

tvclib/uvcpropertytypespersistence/tpropertyaction/ifcomponent

定义: public ifcomponent();override;
说明:
是否为控件


lazyproperty

tvclib/uvcpropertytypespersistence/tpropertyalign/lazyproperty

定义: public lazyproperty();override;
说明:
是否为延迟设置属性
返回值:
type | describe
bool |


formattmf

tvclib/uvcpropertytypespersistence/tpropertybitmap/formattmf

定义: public formattmf(d);override;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


formatedit

tvclib/uvcpropertytypespersistence/tpropertybool/formatedit

定义: public formatedit(d,modify);override;
说明:
控件数据转换为修改表格数据
参数:
name
d
modify


formattmf

tvclib/uvcpropertytypespersistence/tpropertybool/formattmf

定义: public formattmf(d);override;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


formattmf

tvclib/uvcpropertytypespersistence/tpropertycolor/formattmf

定义: public formattmf(d);virtual;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


formattmf

tvclib/uvcpropertytypespersistence/tpropertyicon/formattmf

定义: public formattmf(d);override;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


formattmf

tvclib/uvcpropertytypespersistence/tpropertyimagesdata/formattmf

定义: public formattmf(d);override;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


formattmf

tvclib/uvcpropertytypespersistence/tpropertynatural/formattmf

定义: public formattmf(d);virtual;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


formattmf

tvclib/uvcpropertytypespersistence/tpropertystrings/formattmf

定义: public formattmf(d);override;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


edittype

tvclib/uvcpropertytypespersistence/tpropertytype/edittype

定义: public edittype();virtual;
说明:
类型名称
返回值:
type | describe
string | 字符串


formatedit

tvclib/uvcpropertytypespersistence/tpropertytype/formatedit

定义: public formatedit(d,modify);virtual;
说明:
控件数据转换为修改表格展示数据
参数:
name | type | describe
d | any | 数据
modify | bool | 是否可以修改


formattmf

tvclib/uvcpropertytypespersistence/tpropertytype/formattmf

定义: public formattmf(d);virtual;
说明:
修改表格数据转换为tmf文件数据
参数:
name
d


ifcomponent

tvclib/uvcpropertytypespersistence/tpropertytype/ifcomponent

定义: public ifcomponent();virtual;
说明:
是否为控件


lazyproperty

tvclib/uvcpropertytypespersistence/tpropertytype/lazyproperty

定义: public lazyproperty();virtual;
说明:
是否为延迟设置属性
返回值:
type | describe
bool |


readtmf

tvclib/uvcpropertytypespersistence/tpropertytype/readtmf

定义: public readtmf(d,o);virtual;
说明:
读取tfm 数据实际窗口
参数:
name
d
o


tmftonode

tvclib/uvcpropertytypespersistence/tpropertytype/tmftonode

定义: public tmftonode(d);virtual;
说明:
读取tfm数据到设计器控件
参数:
name
d


unformatedit

tvclib/uvcpropertytypespersistence/tpropertytype/unformatedit

定义: public unformatedit(d);virtual;
说明:
修改表格数据转换为设计器控件数据
参数:
name
d


gettree

tvclib/uvcpropertytypespersistence/ttmfparser/gettree

定义: public gettree();
说明:
获得语法树


samplevalue

tvclib/uvcpropertytypespersistence/ttmfparser/samplevalue

定义: public samplevalue(v);
参数:
name | type | describe
v | array | 标记类型的数组


cback

tvclib/uvcpropertytypespersistence/ttmfparsertoken/cback

定义: public cback(n);
说明:
倒退位置
参数:
name
n


cchar

tvclib/uvcpropertytypespersistence/ttmfparsertoken/cchar

定义: public cchar();
说明:
获得当前字符,并且位置移动


delct

tvclib/uvcpropertytypespersistence/ttmfparsertoken/delct

定义: public class delct(r,ct,len,n);
说明:
处理当前字符
参数:
name
r
ct
len
n


gettokens

tvclib/uvcpropertytypespersistence/ttmfparsertoken/gettokens

定义: public gettokens();
说明:
解析token


phexnumber

tvclib/uvcpropertytypespersistence/ttmfparsertoken/phexnumber

定义: public phexnumber();
说明:
解析16进制数


pnumber

tvclib/uvcpropertytypespersistence/ttmfparsertoken/pnumber

定义: public pnumber();
说明:
解析数字


pstring

tvclib/uvcpropertytypespersistence/ttmfparsertoken/pstring

定义: public pstring(ltk);
说明:
解析字符串
参数:
name
ltk